cdma2000 Measurements (R&S FSW-K82/-K83)
Contents
  • Welcome to the CDMA2000 Applications
  • Measurements and Result Displays
  • Measurement Basics
  • I/Q Data Import and Export
  • Configuration
  • Analysis
  • Optimizing and Troubleshooting the Measurement
  • How to Perform Measurements in CDMA2000 Applications
  • Measurement Examples
  • Remote Commands for CDMA2000 Measurements
  • List of Commands
Top


Welcome to the CDMA2000 Applications

cdma2000 Measurements (R&S FSW-K82/-K83) > Welcome to the CDMA2000 Applications
Welcome to the CDMA2000 Applications

The CDMA2000 options are firmware applications that add functionality to the R&S FSW to perform measurements on downlink or uplink signals according to the CDMA2000 standard.

R&S FSW-K82 performs Base Transceiver Station (BTS) measurements on forward link signals on the basis of the 3GPP2 Standard (Third Generation Partnership Project 2).

R&S FSW-K83 performs Mobile Station (MS) measurements on reverse link signals on the basis of the 3GPP2 Standard (Third Generation Partnership Project 2).

The measurements are based on the "Physical Layer Standard for CDMA2000 Spread Spectrum Systems Release C" of version C.S0002-C V1.0 dated May 2002 and "Recommended Minimum Performance Standard for CDMA2000 Spread Spectrum Base Stations" of version C.S0010-B dated December 2002. This standard has been adopted by the following authorities with the specified norm:

TIA: TIA/EIA-97-E dated February 2003 (also known as IS-97-E)

Reference made to the CDMA2000 specification in the following text alludes to these standards.

The application firmware R&S FSW-82 supports radio configurations 1 to 5 and 10. Thus, IS95A/B signals conforming to radio configurations 1&2 can also be measured with this application firmware. Channels and modulation types of the 1xEV– DV enhancement are supported as well.

The application firmware R&S FSW-83 supports the radio configurations 3 and 4. Apart from CDMA2000 reverse link signals, the 1xEV-DV reverse link channels of Release C are also supported. Code Domain Analysis is also possible at signals where the pilot channel is active in at least one of the captured power control groups (pilot gating).

In addition to the code domain measurements described in the CDMA2000 standard, the CDMA2000 applications feature measurements in the spectral range such as channel power, adjacent channel power, occupied bandwidth and spectrum emission mask with predefined settings.

This user manual contains a description of the functionality that the applications provide, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are described in the R&S FSW User Manual. The latest version is available for download at the product homepage

http://www2.rohde-schwarz.com/product/FSW.html.

Installation

You can find detailed installation instructions in the R&S FSW Getting Started manual or in the Release Notes.

Contents
  • Starting the CDMA2000 Applications
  • Understanding the Display Information


Starting the CDMA2000 Applications

cdma2000 Measurements (R&S FSW-K82/-K83) > Welcome to the CDMA2000 Applications > Starting the CDMA2000 Applications
Starting the CDMA2000 Applications

The CDMA2000 measurements require special applications on the R&S FSW.

To activate the CDMA2000 applications

  1. Press the MODE key on the front panel of the R&S FSW.

    A dialog box opens that contains all operating modes and applications currently available on your R&S FSW.

  2. Select the "cdma2000 BTS" or "cdma2000 MS" item.

    The R&S FSW opens a new measurement channel for the CDMA2000 application.

For details see "Operating Modes" .

The measurement is started immediately with the default settings. It can be configured in the CDMA2000 "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu (see "Configuration Overview").

Multiple Measurement Channels and Sequencer Function

When you activate a CDMA2000 application, a new measurement channel is created which determines the measurement settings for that application. The same application can be activated with different measurement settings by creating several channels for the same application.

The number of channels that can be configured at the same time depends on the available memory on the instrument.

Only one measurement can be performed at any time, namely the one in the currently active channel. However, in order to perform the configured measurements consecutively, a Sequencer function is provided.

If activated, the measurements configured in the currently active channels are performed one after the other in the order of the tabs. The currently active measurement is indicated by a [image] symbol in the tab label. The result displays of the individual channels are updated in the tabs (as well as the "MultiView") as the measurements are performed. Sequential operation itself is independent of the currently displayed tab.

For details on the Sequencer function see "Running a Sequence of Measurements" .


Understanding the Display Information

cdma2000 Measurements (R&S FSW-K82/-K83) > Welcome to the CDMA2000 Applications > Understanding the Display Information
Understanding the Display Information

The following figure shows a measurement diagram in the CDMA2000 BTS application. All different information areas are labeled. They are explained in more detail in the following sections.

(The basic screen elements are identical in the CDMA2000 MS application.)

1 = Channel bar for firmware and measurement settings
2 = Window title bar with diagram-specific (trace) information
3 = Diagram area with marker information
4 = Diagram footer with diagram-specific information, depending on measurement
5 = Instrument status bar with error messages, progress bar and date/time display
MSRA operating mode

In MSRA operating mode, additional tabs and elements are available. A colored background of the screen behind the measurement channel tabs indicates that you are in MSRA operating mode. RF measurements are not available in MSRA operating mode.

For details on the MSRA operating mode see "Applications and Operating Modes" .

Channel bar information

In CDMA2000 applications, the R&S FSW shows the following settings:

Information displayed in the channel bar in CDMA2000 applications
Ref Level | Reference level
Freq | Center frequency for the RF signal
Att | Mechanical and electronic RF attenuation
Channel | Channel number (code number and spreading factor)
PCG | Power control group (see "PCGs and Sets")
Power Ref | Reference used for power results
SymbRate | Symbol rate of the currently selected channel

In addition, the channel bar also displays information on instrument settings that affect the measurement results even though this is not immediately apparent from the display of the measured values (e.g. transducer or trigger settings). This information is displayed only when applicable for the current measurement. For details see the R&S FSW Getting Started manual.

Window title bar information

For each diagram, the header provides the following information:

Window title bar information in CDMA2000 applications
1 = Window number
2 = Window type
3 = Trace color
4 = Trace number
5 = Detector
Diagram footer information

The diagram footer (beneath the diagram) contains the following information, depending on the evaluation:

Status bar information

Global instrument settings, the instrument status and any irregularities are indicated in the status bar beneath the diagram. Furthermore, the progress of the current operation is displayed in the status bar.


Measurements and Result Displays

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays
Measurements and Result Displays

The CDMA2000 applications provide several different measurements for signals according to the CDMA2000 standard. The main and default measurement is Code Domain Analysis. In addition to the code domain power measurements specified by the CDMA2000 standard, the CDMA2000 applications offer measurements with predefined settings in the frequency domain, e.g. RF power measurements.

For details on selecting measurements see "Selecting the measurement type".

Evaluation methods

The captured and processed data for each measurement can be evaluated with various different methods. All evaluation methods available for the selected CDMA2000 measurement are displayed in the evaluation bar in SmartGrid mode.

The evaluation methods for CDA are described in "Evaluation Methods for Code Domain Analysis".

Contents
  • Code Domain Analysis
  • RF Measurements


Code Domain Analysis

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis
Code Domain Analysis

The CDMA2000 firmware applications feature a Code Domain Analyzer. It can be used used to perform the measurements required in the CDMA2000 standards with regard to the power of the different codes and code channels (concentrated codes). In addition, the modulation quality (EVM and RHO factor), frequency errors and trigger–to–frame time, as well as the peak code domain errors are determined. Constellation evaluations and bitstream evaluations are also available. Furthermore, the timing and phase offsets of the channels to the pilot can also be calculated. The observation period can be set as multiples of the power control group (PCG).

Basically, the firmware differentiates between the following result classes for the evaluations:

  • Results which take the overall signal into account over the whole observation period (all PCGs)
  • Results which take the overall signal into account over a power control group (PCG)
  • Results which take one channel into account over the whole observation period (all PCGs)
  • Results which take one channel into account over a power control group (PCG)
Remote command:

CONF:CDP:MEAS CDP, see CONFigure:​CDPower[:​BTS]:​MEASurement

Contents
  • Code Domain Parameters
  • Evaluation Methods for Code Domain Analysis


Code Domain Parameters

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis > Code Domain Parameters
Code Domain Parameters

In the Result Summary, three different types of measurement results are determined and displayed:

  • General results for the current set
  • PCG results for the current set and PCG
  • Channel results for the selected channel

In the Channel Table, channel results for all channels are displayed.

General Results

Under "General Results", the measurement results that concern the total signal (that is, all channels) for the entire period of observation (that is, all PCGs) are displayed:

General code domain power results for the current set

Parameter

Description

Carrier Frequency Error

Shows the frequency error referred to the center frequency of the R&S FSW. The absolute frequency error is the sum of the frequency error of the R&S FSW and that of the device under test. Frequency differences between the transmitter and receiver of more than 1.0 kHz impair synchronization of the Code Domain Power measurement. If at all possible, the transmitter and the receiver should be synchronized.

The frequency error is available in the units Hz or ppm referred to the carrier frequency.

Chip Rate Error

Shows the chip rate error (1.2288 Mcps) in ppm. A large chip rate error results in symbol errors and, therefore, in possible synchronization errors for Code Domain Power measurements. This measurement result is also valid if the R&S FSW could not synchronize to the CDMA2000 signal.

Trigger to Frame

Reflects the time offset from the beginning of the recorded signal section to the start of the first PCG. In case of triggered data recording, this corresponds to the timing offset:

timing offset = frame trigger (+ trigger offset) – start of first PCG

If it was not possible to synchronize the R&S FSW to the CDMA2000 signal, this measurement result is meaningless. For the "Free Run" trigger mode, dashes are displayed.

Active Channels

Specifies the number of active channels found in the signal. Detected data channels as well as special channels are regarded as active. With transmit diversity, the result applies to the selected "Antenna Diversity - Antenna Number".

PCG Results

PCG results concern the total signal (that is, all channels) for the selected PCG.

Code domain power results for the current PCG
Parameter | Description
Total Power | Shows the total power of the signal.
Pilot Power | Shows the power of the pilot channel. If antenna 2 is selected, the power of the F-TDPICH is displayed, in all other cases that of the F-PICH. For details on antenna selection refer to "Antenna Diversity - Antenna Number".
RHO | Shows the quality parameter RHO. According to the CDMA2000 standard, RHO is the normalized, correlated power between the measured and the ideally generated reference signal. When RHO is measured, the CDMA2000 standard requires that only the pilot channel be supplied.
Composite EVM | The composite EVM is the difference between the test signal and the ideal reference signal. For further details refer to the "Composite EVM" result display.
IQ Imbalance | Shows the IQ imbalance of the signal in %.
Offset | Shows the IQ offset of the signal in %.
Channel results

In the Result Summary, channel results of the selected channel and the selected PCG are displayed.

In the Channel Table, channel results for all channels are displayed. For details see "Channel Table".

Not all channel results displayed in the Result Summary are also displayed in the Channel Table and vice versa.

Channel-specific parameters
Parameter | Description
Channel | Channel number including the spreading factor (in the form <Channel>.<SF>)
Modulation Type | (BTS application only): Displays the modulation type of the channel and PCG: BPSK, QPSK, 8PSK, or 16QAM
Mapping | (MS application only): Indicates the selected branch (I or Q)
Phase Offset | Phase offset between the selected channel and the pilot channel If enabled (see "Timing and phase offset calculation"), the maximum value of the phase offset is displayed together with the associated channel in the last two lines. Since the phase offset values of each active channel can be either negative or positive, the absolute values are compared and the maximum is displayed with the original sign.
Power Absolute | Absolute (dBm) power of the channel
Power Relative | Relative (dB) power of the channel (refers either to the pilot channel or the total power of the signal)
Symbol EVM | Peak or mean value of the EVM measurement result For further details refer to the result display "Symbol EVM".
Timing Offset | Timing offset between the selected channel and the pilot channel If enabled (see "Timing and phase offset calculation"), the maximum value of the timing offset is displayed together with the associated channel in the last two lines. Since the timing offset values of each active channel can be either negative or positive, the absolute values are compared and the maximum is displayed with the original sign.


Evaluation Methods for Code Domain Analysis

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis > Evaluation Methods for Code Domain Analysis
Evaluation Methods for Code Domain Analysis

The captured I/Q data can be evaluated using various different methods without having to start a new measurement. All evaluation methods available for the selected CDMA2000 measurement are displayed in the evaluation bar in SmartGrid mode.

To activate SmartGrid mode, do one of the following:
  • Select the "SmartGrid" icon from the toolbar.
  • Select the "Display Config" button in the configuration "Overview".
  • Select the "Display Config" softkey from the MEAS CONFIG menu.

To close the SmartGrid mode and restore the previous softkey menu select the [image] "Close" icon in the righthand corner of the toolbar, or press any key on the front panel.

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .

The selected evaluation not only affects the result display, but also the results of the trace data query (see TRACe<n>[:​DATA]?).

The Code Domain Analyzer provides the following evaluation methods for measurements in the code domain:

└ Bitstream
└ Channel Table
└ Table Configuration
└ Code Domain Power / Code Domain Error Power
└ Composite Constellation
└ Composite EVM
└ Mag Error vs Chip
└ Peak Code Domain Error
└ Phase Error vs Chip
└ Power vs PCG
└ Power vs Symbol
└ Result Summary
└ Symbol Constellation
└ Symbol EVM
└ Symbol Magnitude Error
└ Symbol Phase Error


Bitstream

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Bitstream
Bitstream

The "Bitstream" evaluation displays the demodulated bits of a selected channel over a selected PCG.

All bits that are part of inactive channels are marked as being invalid using dashes.

To select a specific symbol press the MKR key. If you enter a number, the marker jumps to the selected symbol. If there are more symbols than the screen is capable of displaying, use the marker to scroll inside the list.

The number of symbols per PCG depends on the spreading factor (symbol rate) and the antenna diversity. The number of bits per symbol depends on the modulation type.

For details see "Measurement Basics".

Remote command:

LAY:ADD? '1',RIGH, 'XTIM:CDP:BSTR', see LAYout:​ADD[:​WINDow]?


Channel Table

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Channel Table
Channel Table

The "Channel Table" evaluation displays the detected channels and the results of the code domain power measurement over the selected PCG. The analysis results for all channels are displayed. Thus, the Channel Table may contain up to 128 entries, corresponding to the highest base spreading factor of 128.

The first entries of the table indicate the channels that must be available in the signal to be analyzed and any other control channels (PICH, SYNC etc.).

The lower part of the table indicates the data channels that are contained in the signal.

If the type of a channel can be fully recognized, based on pilot sequences or modulation type, the type is indicated in the table. In the BTS application, all other channels are of type CHAN.

The channels are in descending order according to symbol rates and, within a symbol rate, in ascending order according to the channel numbers. Therefore, the inactive codes are always displayed at the end of the table (if "Show inactive channels" is enabled, see "Table Configuration".

Remote command:

LAY:ADD? '1',RIGH, CTABle, see LAYout:​ADD[:​WINDow]?

└ Table Configuration


Table Configuration

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Channel Table > Table Configuration
Table Configuration

You can configure which parameters are displayed in the Channel Table by double-clicking the table header. A "Table Configuration" dialog box is displayed in which you select the columns to be displayed.

By default, only active channels are displayed. In order to display all channels, including the inactive ones, enable the "Show Inactive Channels" option.

The following parameters of the detected channels are determined by the CDP measurement and can be displayed in the Channel Table result display. (For details see "Code Domain Parameters".)

Code domain power results in the channel table
Parameter | Description
Channel Type | Shows the channel type ('---' for inactive channels)
Walsh Ch.SF | Channel number including the spreading factor (in the form <Channel>.<SF>)
(P Offs [mrad]) | Phase offset between the selected channel and the pilot channel If enabled (see "Timing and phase offset calculation"), the maximum value of the phase offset is displayed together with the associated channel in the last two lines. Since the phase offset values of each active channel can be either negative or positive, the absolute values are compared and the maximum is displayed with the original sign.
Pwr [dBm]) | Absolute (dBm) power of the channel
Pwr [dB] | Relative (dB) power of the channel (refers either to the pilot channel or the total power of the signal)
RC | (BTS application only): Radio configuration
Mapping | (MS application only): Branch the data is mapped to
Status | Channel status; Unassigned codes are identified as inactive channels
Symbol Rate [ksps] | Symbol rate at which the channel is transmitted (9.6 ksps to 307.2 ksps)
(T Offs [ns]) | Timing offset between the selected channel and the pilot channel If enabled (see "Timing and phase offset calculation"), the maximum value of the timing offset is displayed together with the associated channel in the last two lines. Since the timing offset values of each active channel can be either negative or positive, the absolute values are compared and the maximum is displayed with the original sign.


Code Domain Power / Code Domain Error Power

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Code Domain Power / Code Domain Error Power
Code Domain Power / Code Domain Error Power

The "Code Domain Power" evaluation shows the power of all possible code channels in the total signal over the selected PCG.

"Code Domain Error Power" is the difference in power between the measured and the ideal signal.

The x-axis represents the channel (code) number, which corresponds to the base spreading factor. The y-axis is a logarithmic level axis that shows the (error) power of each channel. With the error power, both active and inactive channels can be evaluated at a glance.

Both evaluations support either Hadamard or BitReverse code sorting order (see "Code Display and Sort Order").

MS application only: the (error) power is calculated only for the selected branch (I or Q).

Active and inactive data channels are defined via the "Inactive Channel Threshold". The power values of the active and inactive channels are shown in different colors. In addition, codes with alias power can occur (see "Alias power").

Assignment of colors in CDEP result display
Color | Usage
Red | Selected channel (code number)
Yellow | Active channel
Green | Inactive channel
Light blue | Alias power of higher spreading factor
Magenta | Alias power as a result of transmit diversity

Note: If codes with alias power are displayed, set the highest base spreading factor available in the "Base Spreading Factor" field.
It is not recommended that you select more detailed result displays (such as "Symbol Constell") for unassigned or inactive codes, since the results are not valid.

Remote command:

CDP:

LAY:ADD? '1',RIGH, CDPower, see LAYout:​ADD[:​WINDow]?

CALC:MARK:FUNC:CDP:RES? CDP or CALC:MARK:FUNC:CDP:RES? CDPR; see CALCulate<n>:​MARKer<m>:​FUNCtion:​CDPower[:​BTS]:​RESult?

CDEP:

LAY:ADD? '1',RIGH, CDEPower, see LAYout:​ADD[:​WINDow]?

CALC:MARK:FUNC:CDP:RES?; see CALCulate<n>:​MARKer<m>:​FUNCtion:​CDPower[:​BTS]:​RESult?.


Composite Constellation

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Composite Constellation
Composite Constellation

In "Composite Constellation" evaluation the constellation points of the 1536 chips are displayed for the specified PCG. This data is determined inside the DSP even before the channel search. Thus, it is not possible to assign constellation points to channels. The constellation points are displayed normalized with respect to the total power.

Remote command:

LAY:ADD? '1',RIGH, CCON, see LAYout:​ADD[:​WINDow]?

CALC:MARK:FUNC:CDP:RES?; see CALCulate<n>:​MARKer<m>:​FUNCtion:​CDPower[:​BTS]:​RESult?


Composite EVM

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Composite EVM
Composite EVM

This result display measures the modulation accuracy. It determines the error vector magnitude (EVM) over the total signal. The EVM is the root of the ratio of the mean error power (root mean square) to the power of an ideally generated reference signal. Thus, the EVM is shown in %. The diagram consists of a composite EVM for each PCG.

The measurement evaluates the total signal over the entire period of observation. The selected PCG is highlighted red. You can set the number of PCGs in the "Signal Capture" settings (see "Number of PCGs").

Only the channels detected as being active are used to generate the ideal reference signal. If a channel is not detected as being active, e.g. on account of low power, the difference between the test signal and the reference signal and therefore the composite EVM is very large. Distortions also occur if unassigned codes are wrongly given the status of "active channel". To obtain reliable measurement results, select an adequate channel threshold via the "Inactive Channel Threshold" setting.

Remote command:

LAY:ADD? '1',RIGH, CEVM, see LAYout:​ADD[:​WINDow]?

CALC:MARK:FUNC:CDP:RES? MACCuracy; see CALCulate<n>:​MARKer<m>:​FUNCtion:​CDPower[:​BTS]:​RESult?


Mag Error vs Chip

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Mag Error vs Chip
Mag Error vs Chip

Mag Error vs Chip activates the Magnitude Error versus chip display. The magnitude error is displayed for all chips of the selected slot.

The magnitude error is calculated as the difference of the magnitude of the received signal to the magnitude of the reference signal. The reference signal is estimated from the channel configuration of all active channels. The magnitude error is related to the square root of the mean power of reference signal and given in percent.

where:

MAGk | magnitude error of chip number k
sk | complex chip value of received signal
xk | complex chip value of reference signal
k | index number of the evaluated chip
N | number of chips at each CPICH slot
n | index number for mean power calculation of reference signal
Remote command:

LAY:ADD? '1',RIGH, MECHip, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


Peak Code Domain Error

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Peak Code Domain Error
Peak Code Domain Error

The Peak Code Domain Error is defined as the maximum value for the "Code Domain Power / Code Domain Error Power" for all codes. Thus, the error between the measurement signal and the ideal reference signal is projected onto the code domain at a specific base spreading factor. In the diagram, each bar of the x-axis represents one PCG. The y-axis represents the error power.

The measurement evaluates the total signal over the entire period of observation. The currently selected PCG is highlighted red.

You can select the "Base Spreading Factor" and the number of evaluated PCGs in the Signal Capture settings (see "Number of PCGs").

MS application: the error is calculated only for the selected branch (I or Q).

Note: Only the channels detected as being active are used to generate the ideal reference signal. If a channel is not detected as being active, e.g. on account of low power, the difference between the test signal and the reference signal is very large. The result display therefore shows a peak code domain error that is too high. Distortions also occur if unassigned codes are wrongly given the status of "active channel". To obtain reliable measurement results, select an adequate channel threshold via the "Inactive Channel Threshold" setting.

Remote command:

LAY:ADD? '1',RIGH, PCDerror, see LAYout:​ADD[:​WINDow]?

CALC:MARK:FUNC:CDP:RES? PCDerror; see CALCulate<n>:​MARKer<m>:​FUNCtion:​CDPower[:​BTS]:​RESult?


Phase Error vs Chip

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Phase Error vs Chip
Phase Error vs Chip

"Phase Error vs Chip" activates the phase error versus chip display. The phase error is displayed for all chips of the slected slot.

The phase error is calculated by the difference of the phase of received signal and phase of reference signal. The reference signal is estimated from the channel configuration of all active channels. The phase error is given in degrees in a range of +180° to -180°.

Calculating the magnitude, phase and vector error per chip

where:

PHIk | phase error of chip number k
sk | complex chip value of received signal
xk | complex chip value of reference signal
k | index number of the evaluated chip
N | number of chips at each CPICH slot
φ(x) | phase calculation of a complex value
Remote command:

LAY:ADD? '1',RIGH, PECHip, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


Power vs PCG

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Power vs PCG
Power vs PCG

In this result display, the power of the selected channel is averaged for each measured PCG and referred to the pilot power of the PCG. Therefore the unit of the y-axis is dB (relative to the Pilot Channel). The result display consists of the number of the PCGs in the measurement and the power value of each one.

For measurements in which antenna diversity is inactive (OFF) or set to "Antenna 1", the F-PICH channel is used as reference, while the F-TDPICH channel is used for measurements in which antenna diversity is set to "Antenna 2".

Note: For signals with enabled power control, use the default reference power setting. For details refer to "Power Reference".

The measurement evaluates one code channel over the entire period of observation. The selected PCG is highlighted red.

MS application: the power is calculated only for the selected branch (I or Q).

Note: To detect the start of a power control group correctly, the external trigger must be used for power-regulated signals.

Remote command:

LAY:ADD? '1',RIGH, PSLot, see LAYout:​ADD[:​WINDow]?


Power vs Symbol

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Power vs Symbol
Power vs Symbol

The "Power vs. Symbol" evaluation calculates the absolute power in dBm for each symbol in the selected channel and the selected PCG.

Remote command:

LAY:ADD? '1',RIGH, PSYMbol, see LAYout:​ADD[:​WINDow]?

CALC:MARK:FUNC:CDP:RES?; see CALCulate<n>:​MARKer<m>:​FUNCtion:​CDPower[:​BTS]:​RESult?


Result Summary

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Result Summary
Result Summary

The "Result Summary" evaluation displays a list of measurement results on the screen. For details on the displayed values see "Code Domain Parameters".

Remote command:

LAY:ADD? '1',RIGH, RSUMmary, see LAYout:​ADD[:​WINDow]?

CALC:MARK:FUNC:CDP:RES?; see CALCulate<n>:​MARKer<m>:​FUNCtion:​CDPower[:​BTS]:​RESult?


Symbol Constellation

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Symbol Constellation
Symbol Constellation

The "Symbol Constellation" evaluation shows all modulated symbols of the selected channel and the selected PCG.

The BTS application supports BPSK, QPSK, 8PSK and 16QAM modulation types. The modulation type itself depends on the channel type. Refer to "BTS Channel Types" for further information.

Note: QPSK constellation points are located on the diagonals (not x and y-axis) of the constellation diagram. BPSK constellation points are always on the x-axis.

The number of symbols is in the range from 6 (min) to 384 (max), depending on the symbol rate of the channel (see "Measurement Basics").

Remote command:

LAY:ADD? '1',RIGH, SCONst, see LAYout:​ADD[:​WINDow]?

CALC:MARK:FUNC:CDP:RES?; see CALCulate<n>:​MARKer<m>:​FUNCtion:​CDPower[:​BTS]:​RESult?


Symbol EVM

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Symbol EVM
Symbol EVM

The "Symbol EVM" evaluation shows the error between the measured signal and the ideal reference signal in percent for the selected channel and the selected PCG. A trace over all symbols of a PCG is drawn.

The number of symbols is in the range from 6 (min) to 384 (max), depending on the symbol rate of the channel (see "Measurement Basics").

Inactive channels can be measured, but the result is meaningless since these channels do not contain data.

Remote command:

LAY:ADD? '1',RIGH, SEVM, see LAYout:​ADD[:​WINDow]?

CALC:MARK:FUNC:CDP:RES?; see CALCulate<n>:​MARKer<m>:​FUNCtion:​CDPower[:​BTS]:​RESult?


Symbol Magnitude Error

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Symbol Magnitude Error
Symbol Magnitude Error

The "Symbol Magnitude Error" is calculated analogous to symbol EVM. The result is one symbol magnitude error value for each symbol of the slot of a special channel. Positive values of symbol magnitude error indicate a symbol magnitude that is larger than the expected ideal value; negative symbol magnitude errors indicate a symbol magnitude that is less than the ideal one.The symbol magnitude error is the difference between the magnitude of the received symbol and that of the reference symbol, related to the magnitude of the reference symbol.

Remote command:

LAY:ADD? '1',RIGH, SMERror, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


Symbol Phase Error

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Symbol Phase Error
Symbol Phase Error

The "Symbol Phase Error" is calculated analogous to symbol EVM. The result is one symbol phase error value for each symbol of the slot of a special channel. Positive values of symbol phase error indicate a symbol phase that is larger than the expected ideal value; negative symbol phase errors indicate a symbol phase that is less than the ideal one.

Remote command:

LAY:ADD? '1',RIGH, SPERror, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


RF Measurements

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > RF Measurements
RF Measurements

In addition to the Code Domain Analysis measurements, the CDMA2000 firmware applications also provide some RF measurements as defined in the CDMA2000 standard. RF measurements are identical to the corresponding measurements in the base unit, but configured according to the requirements of the CDMA2000 standard.

For details on these measurements see "Measurements" .

Contents
  • RF Measurement Types and Results
  • Evaluation Methods for RF Measurements


RF Measurement Types and Results

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > RF Measurements > RF Measurement Types and Results
RF Measurement Types and Results

The CDMA2000 applications provide the following RF measurements:

└ Power
└ Channel Power ACLR
└ Spectrum Emission Mask
└ Occupied Bandwidth
└ CCDF


Power

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > RF Measurements > RF Measurement Types and Results > Power
Power

The Power measurement determines the CDMA2000 signal channel power.

To do so, the CDMA2000 application performs a Channel Power measurement as in the Spectrum application with settings according to the CDMA2000 standard. The bandwidth and the associated channel power are displayed in the Result Summary.

For details see "Signal Channel Power Measurements".

Remote command:

CONF:CDP:MEAS POW, see CONFigure:​CDPower[:​BTS]:​MEASurement

Querying results: CALC:MARK:FUNC:POW:RES? CPOW, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?


Channel Power ACLR

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > RF Measurements > RF Measurement Types and Results > Channel Power ACLR
Channel Power ACLR

Channel Power ACLR performs an adjacent channel power measurement in the default setting according to CDMA2000 specifications (adjacent channel leakage ratio).

The R&S FSW measures the channel power and the relative power of the adjacent channels and of the alternate channels. The results are displayed in the Result Summary.

For details see "Channel Power (ACLR) Measurements".

Remote command:

CONF:CDP:MEAS ACLR, see CONFigure:​CDPower[:​BTS]:​MEASurement

Querying results:

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?


Spectrum Emission Mask

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > RF Measurements > RF Measurement Types and Results > Spectrum Emission Mask
Spectrum Emission Mask

The Spectrum Emission Mask measurement determines the power of the CDMA2000 signal in defined offsets from the carrier and compares the power values with a spectral mask specified by the CDMA2000 specifications. The limits depend on the selected bandclass.Thus, the performance of the DUT can be tested and the emissions and their distance to the limit be identified.

Note: The CDMA2000 standard does not distinguish between spurious and spectral emissions.

For details see "Spectrum Emission Mask".

Remote command:

CONF:CDP:MEAS ESP, see CONFigure:​CDPower[:​BTS]:​MEASurement

Querying results:

CALC:MARK:FUNC:POW:RES? CPOW, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALCulate:​LIMit<k>:​FAIL?


Occupied Bandwidth

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > RF Measurements > RF Measurement Types and Results > Occupied Bandwidth
Occupied Bandwidth

The Occupied Bandwidth measurement determines the bandwidth in which – in default settings - 99 % of the total signal power is to be found. The percentage of the signal power to be included in the bandwidth measurement can be changed.

The occupied bandwidth (Occ BW) and the frequency markers are displayed in the marker table.

For details see "Occupied Bandwidth".

Remote command:

CONF:CDP:MEAS OBAN, see CONFigure:​CDPower[:​BTS]:​MEASurement

Querying results:

CALC:MARK:FUNC:POW:RES? OBW, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?


CCDF

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > RF Measurements > RF Measurement Types and Results > CCDF
CCDF

The CCDF measurement determines the distribution of the signal amplitudes (complementary cumulative distribution function). The CCDF and the Crest factor are displayed. For the purposes of this measurement, a signal section of user-definable length is recorded continuously in the zero span, and the distribution of the signal amplitudes is evaluated.

For details see "CCDF".

Remote command:

CONF:CDP:MEAS CCDF, see CONFigure:​CDPower[:​BTS]:​MEASurement

Querying results:

CALCulate<n>:​MARKer<m>:​Y?

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALCulate:​STATistics:​RESult<t>?


Evaluation Methods for RF Measurements

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > RF Measurements > Evaluation Methods for RF Measurements
Evaluation Methods for RF Measurements

The evaluation methods for RF measurements are identical to those in the Spectrum application.

└ Diagram
└ Result Summary
└ Marker Table
└ Marker Peak List


Diagram

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > RF Measurements > Evaluation Methods for RF Measurements > Diagram
Diagram

Displays a basic level vs. frequency or level vs. time diagram of the measured data to evaluate the results graphically. This is the default evaluation method. Which data is displayed in the diagram depends on the "Trace" settings. Scaling for the y-axis can be configured.

Remote command:

LAY:ADD? '1',RIGH, DIAG, see LAYout:​ADD[:​WINDow]?


Result Summary

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > RF Measurements > Evaluation Methods for RF Measurements > Result Summary
Result Summary

Result summaries provide the results of specific measurement functions in a table for numerical evaluation. The contents of the result summary vary depending on the selected measurement function. See the description of the individual measurement functions for details.

Remote command:

LAY:ADD? '1',RIGH, RSUM, see LAYout:​ADD[:​WINDow]?


Marker Table

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > RF Measurements > Evaluation Methods for RF Measurements > Marker Table
Marker Table

Displays a table with the current marker values for the active markers.

This table may be displayed automatically if configured accordingly (see "Marker Table Display").

Remote command:

LAY:ADD? '1',RIGH, MTAB, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Marker Peak List

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurements and Result Displays > RF Measurements > Evaluation Methods for RF Measurements > Marker Peak List
Marker Peak List

The marker peak list determines the frequencies and levels of peaks in the spectrum or time domain. How many peaks are displayed can be defined, as well as the sort order. In addition, the detected peaks can be indicated in the diagram. The peak list can also be exported to a file for analysis in an external application.

Remote command:

LAY:ADD? '1',RIGH, PEAK, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Measurement Basics

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Basics
Measurement Basics

CDMA2000® is based on code division multiplex access (CDMA), where all users share the same 1.25 MHz-wide channel, but use individual pseudo noise (PN) sequences for differentiation.

CDMA2000® was specified by 3GPP2 (3rd Generation Partnership Project 2). The following link provides access to 3GPP2 specifications:

http://www.3gpp2.org/Public_html/specs/index.cfm

Some background knowledge on basic terms and principles used in CDMA2000 tests and measurements is provided here for a better understanding of the required configuration settings.

Contents
  • PCGs and Sets
  • Channels, Codes and Symbols
  • Code Display and Sort Order
  • Scrambling via PN Offsets and Long Codes
  • Code Mapping and Branches
  • Radio Configuration
  • Transmission with Multiple Carriers and Multiple Antennas
  • Channel Detection and Channel Types
  • Test Setup for CDMA2000 Tests
  • CDA Measurements in MSRA Operating Mode


PCGs and Sets

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Basics > PCGs and Sets
PCGs and Sets

The user data is transmitted in individual data packages, each of which may have different transmission settings such as the power level. The data in one such package, for which the power remains constant, is called a power control group, or PCG. A PCG has a duration of 1.25 ms (or 1536 chips, same as slots in other standards).

The CDMA2000 applications can capture up to 31360 PCGs (about 26 seconds) in a single sweep. In order to improve performance during measurement and analysis, the captured PCGs are not processed by the CDMA2000 application all at once, but rather in sets, one at a time. One set consists of 64 PCGs. You can select how many sets are to be captured and which set is currently analyzed and displayed. The possible value range is from 1 to a maximum of 490 sets.


Channels, Codes and Symbols

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Basics > Channels, Codes and Symbols
Channels, Codes and Symbols

In CDMA2000 applications, the data is transmitted in channels. These channels are based on orthogonal codes and can have different symbol rates. The symbol rate depends on the used modulation type and the spreading factor of the channel.

Spreading factors

Spreading factors determine whether the transmitted data is sent in short or long sequences. The spreading factor is re-assigned dynamically in certain time intervals according to the current demand of users and data to be transmitted. The higher the spreading factor, the lower the data rate; the lower the spreading factor, the higher the data rate.

A channel with a lower spreading factor consists of several combined codes. That means a channel can be described by its number and its spreading factor.

The spread bits are called chips.

Since a PCG is a fixed time unit, knowing the symbol rate you can calculate how many symbols are transmitted for each PCG.

For evaluations which display symbols on the x–axis, the maximum number of symbols varies according to the symbol rate of the selected code channel. With transmit diversity signals, the symbols of the signal are distrubuted on two antennas (see "Antenna Diversity"). Therefore the symbol number is reduced to half.

The following table shows the relationship between the code class, the spreading factor, the number of codes per channel, and the symbol rate.

Relationship between various code parameters for CDMA2000 BTS signals
Code class | Spreading factor | No. codes / channel | Symbol rate [ksps] | Symbols per PCG (no transmit diversity) | Symbols per PCG (transmit diversity)
2 | 4 | 128 | 307.2 | 384 | 192
3 | 8 | 64 | 153.6 | 192 | 96
4 | 16 | 32 | 76.8 | 96 | 48
5 | 32 | 16 | 38.4 | 48 | 24
6 | 64 | 8 | 19.2 | 24 | 12
7 | 128 | 4 | 9.6 | 12 | 6
Relationship between various code parameters for CDMA2000 MS signals
Code class | Spreading factor | No. codes / channel | Symbol rate [ksps] | Symbols per PCG
1 | 2 | 128 | 614.4 | 768
2 | 4 | 64 | 307.2 | 384
3 | 8 | 32 | 153.6 | 192
4 | 16 | 16 | 76.8 | 96
5 | 32 | 8 | 38.4 | 48
6 | 64 | 4 | 19.2 | 24
Number of bits per symbol

Depending on the modulation type, a symbol consists of the following number of bits:

  • BPSK: 1 bit (for BTS signals, only the I-component is assigned)
  • QPSK: 2 bits (I-component followed by the Q-component)
  • 8PSK: 3 bits
  • 16QAM: 4 bits


Code Display and Sort Order

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Basics > Code Display and Sort Order
Code Display and Sort Order

In the result displays that refer to codes, the currently selected code is highlighted in the diagram. You select a code by entering a code number in the "Evaluation Range" settings.

By default, codes are displayed in ascending order of the code number (Hadamard order). The currently selected code number is highlighted. If the code belongs to a detected active channel, the entire channel is highlighted. (For details on active channels and channel detection see "Channel Detection and Channel Types".)

However, in CDMA2000 signals, the codes that belong to the same channel need not lie next to each other in the code domain, they may be distributed.

Example: Example for Hadamard order

For a base spreading factor of 64, the following code order is displayed:

0.64, 1.64, 2.64, …, 63.64.

Code Domain Error Power result display in Hadamard code sorting order

In order to compare all codes in the same channel visually, a Bit-Reverse sorting order is provided. In this case, all codes of a channel are displayed next to each other.

Example: Example for Bit-Reverse order

For a base spreading factor of 64, the following code order may be displayed:

0.64, 32.64, 16.64, 48.64, 8.64, 40.64, …, 15.64, 47.64,31.64, 63.64

Code Domain Error Power result display in BitReverse code sorting order

For the display in the CDMA2000 BTS application, the scale for code-based diagrams displays 64 codes by default (32 in the MS application). However, you can change the base spreading factor for the display, and thus the number of displayed codes.

Alias power

Note, however, that if you select a base spreading factor that is lower than the actual spreading factor used by the channel (e.g. 64 for channels with a base spreading factor of 128), the results are distorted. This is due to the fact that a wider area of the code domain is taken into consideration, for example when calculating the power level, than the code actually occupies. The excess power calculated due to a false spreading factor is referred to as alias power.


Scrambling via PN Offsets and Long Codes

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Basics > Scrambling via PN Offsets and Long Codes
Scrambling via PN Offsets and Long Codes
Short code scrambling

Base stations use a pseudo noise (PN) sequence (also referred to as short code sequence) to scramble the data during transmission. The used PN sequence is circulated in fixed time intervals. A specified PN offset value determines the start phase for the short code sequence.

The PN parameter is unique for each base station. Thus, the signals from different base stations can be distinguished quickly by the CDMA2000 BTS application if the "PN Offset" is defined in the signal description and an external trigger is used to provide a reference for the start phase. If no offset is specified or no external trigger is available, calculation is much slower as the correct PN must be determined from all possible positions.

During short code scrambling, the channel data is split up into I and Q components.

Long code scrambling

Mobile stations also use a PN short code, but with a fixed or no offset. Additionally, a complex long code is used for scrambling, making the data less susceptible to interference. The long code used by a mobile station is defined by a mask and an offset. These settings are required by the CDMA2000 MS application to distinguish the senders and are defined in the signal description.

The long code offset also includes the PN offset (if any) and is defined in chips. The offset corresponds to the GPS timing since 6.1.1980 00:00:00 UTC. The offset in chips is calculated as follows:

tSinceStartGPS * 1.2288 MChips/s

where tSinceStartGPS is defined in seconds

The offset is applied at the next trigger pulse, which cannot occur until a setup time of 300 ms has elapsed.

A special long code generation mode is provided to analyze signals sent by an Agilent ESG 101 generator.

During long code scrambling, the channel data is mapped either to the I or to the Q branch of the complex input signal.


Code Mapping and Branches

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Basics > Code Mapping and Branches
Code Mapping and Branches

Since MS signals use long code scrambling, the channel data is mapped either to the I or to the Q branch of the complex input signal. During channel detection, the branch to which the data was mapped is determined and indicated in the channel table. During analysis, each branch of the symbol constellation area (imaginary part, I, or real part, Q) can be evaluated independantly. Thus, when analyzing MS signals, you must define which branch results you want to analyze. Especially for code power measurements the results may vary considerably. While a channel may be active on one branch, the other branch may belong to an inactive channel.


Radio Configuration

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Basics > Radio Configuration
Radio Configuration

The radio configuration specifies various settings for transmission according to the CDMA2000 standard including:

  • allowed data rates
  • modulation types
  • use of special channels
  • transmit diversity

The standard describes nine RCs for BTS and six for MS signals, for different transmission scenarios.

In the BTS application, the radio configuration can be customized for two channel types: PDCH and CHAN (see "BTS Channel Types"). The applied RC is specified for each channel of these types in the channel tables. Predefined channel tables are provided for particular radio configurations (see "Reference: Predefined Channel Tables").

The following RCs are used in the BTS application:

RCs used in the BTS application:
Channel type | Modulation | Manual operation | SCPI parameter
PDCH | QPSK | 10 | 10
 | 8PSK | 10 | 20
 | 16QAM | 10 | 30
CHAN |  | 1-2 | 1
 |  | 3-5 | 3
special channels |  | - | 0


Transmission with Multiple Carriers and Multiple Antennas

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Basics > Transmission with Multiple Carriers and Multiple Antennas
Transmission with Multiple Carriers and Multiple Antennas

The CDMA2000 standard allows for transmission using multiple carriers as well as transmission via multiple antennas.

Contents
  • Multicarrier Mode
  • Antenna Diversity


Multicarrier Mode

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Basics > Transmission with Multiple Carriers and Multiple Antennas > Multicarrier Mode
Multicarrier Mode

The CDMA2000 applications can filter out and analyze one carrier out of a multicarrier signal, if a special multicarrier mode is activated in the signal description.

Two filter types used to select the required carrier from the signal are available for selection: a low-pass filter and an RRC filter.

By default, the low-pass filter is active. The low-pass filter affects the quality of the measured signal compared to a measurement without a filter. The frequency response of the low-pass filter is shown below.

Frequency response of the low-pass multicarrier filter

The RRC filter comes with an integrated Hamming window. The roll-off factor of the RRC filter defines the slope of the filter curve and therefore the excess bandwidth of the filter. The cut-off frequency of the RRC filter is the frequency at which the passband of the filter begins. Both parameters can be configured.


Antenna Diversity

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Basics > Transmission with Multiple Carriers and Multiple Antennas > Antenna Diversity
Antenna Diversity

The standard allows for transmission via multiple antennas (transmit diversity). If transmit diversity is implemented for the input signal, the CDMA2000 BTS application must know which antenna to analyze the input from. This information is provided by the signal description ("Antenna Diversity"). Depending on which antenna is selected for analysis, certain special channels are required for predefined channel tables (see also "Channel table definition for transmit diversity"):

Antenna | Required special channels
1 | Pilot channel (F-PICH, 0.64) required and used as power reference Transmit diversity pilot channel (F-TDPICH, 16.128) not allowed
2 | Transmit diversity pilot channel (F-TDPICH, 16.128) required and used as power reference Pilot channel (F-PICH, 0.64) not allowed
- (No diversity) | Pilot channel (F-PICH, 0.64) required and used as power reference Transmit diversity pilot channel (F-TDPICH, 16.128) required


Channel Detection and Channel Types

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Basics > Channel Detection and Channel Types
Channel Detection and Channel Types

The CDMA2000 applications provide two basic methods of detecting active channels:

  • Automatic search using pilot sequences
    The application performs an automatic search for active (DPCH) channels throughout the entire code domain. At the specific codes at which channels can be expected, the application detects an active channel if the corresponding symbol rate and a sufficiently high power level is measured (see "Inactive Channel Threshold").
    Any channel that does not have a predefined channel number and symbol rate is considered to be a data channel.
    In the MS application, a channel is considered to be active if a minimum signal/noise ratio is maintained within the channel.
  • Comparison with predefined channel tables
    The input signal is compared to a predefined channel table. All channels that are included in the predefined channel table are considered to be active.
    For a list of predefined channel tables provided by the CDMA2000 applications see "Reference: Predefined Channel Tables".
Quasi-inactive channels in the MS application

In the MS application, only one branch in the code domain is analyzed at a time (see also "Code Mapping and Branches"). However, even if the code on the analyzed branch is inactive, the code with the same number on the other branch may belong to an active channel. In this case, the channel is indicated as quasi-inactive in the current branch evaluation.

Contents
  • BTS Channel Types
  • MS Channel Types


BTS Channel Types

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Basics > Channel Detection and Channel Types > BTS Channel Types
BTS Channel Types

The CDMA2000 standard defines various BTS channel types. Some special channels are mandatory and must be contained in the signal, as they have control or synchronization functions. Thus, these channels always occupy a specific channel number and use a specific symbol rate by which they can be identified.

Special channels

The CDMA2000 BTS application expects at least the Pilot Channel (F-PICH) or the Transmit Diversity Pilot CHannel (F-TDPICH) for the Code Domain Power measurements.

The following channels are detected automatically during automatic channel detection:

Common CDMA2000 BTS channels and their usage
Channel type | Ch.no. / SF | Modulation | Description
F-PICH | 0.64 | BPSK | Pilot channel
F-PCH | 1.64 | BPSK | Paging channel
F-TDPICH | 16.128 | BPSK | Transmit Diversity Pilot CHannel
F-SYNC | 32.64 | BPSK | Synchronization channel
F-CHAN |  | BPSK (RC 1+2) QPSK (RC 3-5) | active data channel
INACTIVE |  | - | inactive channel
F-PDCCH |  | QPSK | Packet Data Control CHannel
F-PDCH | .32 | QPSK, 8PSK, or 16-QAM | Packet Data CHannel

In addition, the following channel types can be defined in a predefined channel table for the CDMA2000 BTS application.

Channel type | Ch.no. / SF | Description
F-APICH | BPSK | Auxiliary Pilot CHannel
F-ATDPICH | BPSK | Auxiliary Ttransmit Diversity Pilot CHannel
F-BCH | QPSK | Broadcast CHannel
F-CACH | QPSK | Common Assignment Channel
F-CCCH | QPSK | Common Control CHannel
F-CPCCH | QPSK | Common Power Control CHannel
Channel table definition for transmit diversity

In a measurement scenario with two antennas (transmit diversity), the following conditions apply to the channel table definition:

  • Antenna 1 is used for transmission:
    – The pilot channel F-PICH must be included.
    – The pilot channel of antenna 2 F-TDPICH must not be included.
  • Antenna 2 is used for transmission:
    – The pilot channel of antenna 2 F-TDPICH must be included.
    – The pilot channel F-PICH must not be included.
  • Both antennas are used for transmission:
    – The pilot channel F-PICH must be included.
    – The pilot channel of antenna 2 F-TDPICH must be included.


MS Channel Types

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Basics > Channel Detection and Channel Types > MS Channel Types
MS Channel Types

The following channel types can be detected in CDMA2000 MS signals by the CDMA2000 MS application.

Channel type | Ch.no / SF | Mapping | Description
ACKCH | 16.64 | Q | Reverse Acknowledgment Channel (1xEV-DV)
CCCH | 2.8 | Q | Reverse Common Control Channel
CQICH | 12.16 | I (if FCH available) /Q | Reverse Channel Quality Indicator Channel (1xEV-DV)
DCCH | 8.16 | I | Reverse Dedicated Control Channel
EACH | 2.8 | Q | Enhanced Access Channel
FCH | 4.16 | Q | Reverse Fundamental Channel
PICH | 0.32 | I | Reverse Pilot Channel
S1CH | 1.2 or 2.4 | Q | Reverse Supplemental 1 Channel
S2CH | 2.4 or 6.8 | I | Reverse Supplemental 2 Channel
Note: Since the EACH has the same mapping, the same channel number and the same spreading factor as the CCCH, it is not possible to distinguish them during an automatic search. In this case, both the EACH and CCCH are output.


Test Setup for CDMA2000 Tests

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Basics > Test Setup for CDMA2000 Tests
Test Setup for CDMA2000 Tests

Before a CDMA measurement can be performed, the R&S FSW must be set up in a test environment. This section describes the required settings of the R&S FSW if it is used as a CDMA2000 base or mobile station tester. Before starting the measurements, the R&S FSW has to be configured correctly and supplied with power as described in the R&S FSW Getting Started manual, "Preparing For Use". Furthermore, the application firmware CDMA2000 BTS or CDMA2000 MS must be enabled. Installation and enabling of the application firmware are described in the R&S FSW Getting Started manual or in the Release Notes.

Risk of instrument damage during operation
An unsuitable operating site or test setup can cause damage to the instrument and to connected devices. Ensure the following operating conditions before you switch on the instrument:
  • All fan openings are unobstructed and the airflow perforations are unimpeded. The minimum distance from the wall is 10 cm.
  • The instrument is dry and shows no sign of condensation.
  • The instrument is positioned as described in the following sections.
  • The ambient temperature does not exceed the range specified in the data sheet.
  • Signal levels at the input connectors are all within the specified ranges.
  • Signal outputs are correctly connected and are not overloaded.
Required units and accessories

The measurements are performed with the following units and accessories:

  • An R&S FSW equipped with the CDMA2000 BTS or MS option.
  • R&S SMU signal generator equipped with option SMU-B9/B10/B11 baseband generator and SMUK46 CDMA2000 incl. 1xEVDV.
  • 1 coaxial cable, 50 Ω, approximately 1 m, N connector
  • 2 coaxial cables, 50 Ω, approximately 1 m, BNC connector
General Test Setup

Connect the antenna output (or TX output) of the base station/mobile station to the RF input of the R&S FSW. Use a power attenuator exhibiting suitable attenuation.

The following values for external attenuation are recommended to ensure that the RF input of the R&S FSW is protected and the sensitivity of the unit is not reduced too much:

Maximum Power | Recommended external attenuation
≥ 55 to 60 dBm | 35 to 40 dB
≥ 50 to 55 dBm | 30 to 35 dB
≥ 45 to 50 dBm | 25 to 30 dB
≥ 40 to 45 dBm | 20 to 25 dB
≥ 35 to 40 dBm | 15 to 20 dB
≥ 30 to 35 dBm | 10 to 15 dB
≥ 25 to 30 dBm | 0 to 10 dB
≥ 20 to 25 dBm | 0 to 5 dB
≤ 20 dBm | 0 dB
  • For signal measurements at the output of two-port networks, connect the reference frequency of the signal source to the rear reference input (REF INPUT) of the R&S FSW.
  • The R&S FSW must be operated with an external frequency reference to ensure that the error limits of the CDMA2000 specification for frequency measurements on base stations/mobile stations are met. A rubidium frequency standard can be used as a reference source, for example.
  • If the device under test (DUT) has a trigger output, connect the trigger output of the DUT to one of the trigger inputs (TRIGGER INPUT) of the R&S FSW (see "Trigger 2/3").
Presettings

(For details see "Code Domain Analysis")

  • Enter the external attenuation.
  • Enter the reference level.
  • Enter the center frequency.
  • Set the trigger.
  • If used, enable the external reference.
  • Select the CDMA2000 standard and the desired measurement.
  • Set the PN offset.


CDA Measurements in MSRA Operating Mode

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Basics > CDA Measurements in MSRA Operating Mode
CDA Measurements in MSRA Operating Mode

The CDMA2000 BTS application can also be used to analyze data in MSRA operating mode.

In MSRA operating mode, only the MSRA Master actually captures data; the MSRA applications receive an extract of the captured data for analysis, referred to as the application data. For the CDMA2000 BTS application in MSRA operating mode, the application data range is defined by the same settings used to define the signal capture in Signal and Spectrum Analyzer mode. In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the analysis interval for the CDMA2000 BTS measurement.

Data coverage for each active application

Generally, if a signal contains multiple data channels for multiple standards, separate applications are used to analyze each data channel. Thus, it is of interest to know which application is analyzing which data channel. The MSRA Master display indicates the data covered by each application, restricted to the channel bandwidth used by the corresponding standard (for CDMA2000: 1.2288 MHz), by vertical blue lines labeled with the application name.

Analysis interval

However, the individual result displays of the application need not analyze the complete data range. The data range that is actually analyzed by the individual result display is referred to as the analysis interval.

In the CDMA2000 BTS application the analysis interval is automatically determined according to the selected set, PCG or code to analyze which is defined for the evaluation range, depending on the result display. The analysis interval can not be edited directly in the CDMA2000 BTS application, but is changed automatically when you change the evaluation range.

Analysis line

A frequent question when analyzing multi-standard signals is how each data channel is correlated (in time) to others. Thus, an analysis line has been introduced. The analysis line is a common time marker for all MSRA applications. It can be positioned in any MSRA application or the MSRA Master and is then adjusted in all other applications. Thus, you can easily analyze the results at a specific time in the measurement in all applications and determine correlations.

If the marked point in time is contained in the analysis interval of the application, the line is indicated in all time-based result displays, such as time, symbol, slot or bit diagrams. By default, the analysis line is displayed, however, it can be hidden from view manually. In all result displays, the "AL" label in the window title bar indicates whether or not the analysis line lies within the analysis interval or not:

  • orange "AL": the line lies within the interval
  • white "AL": the line lies within the interval, but is not displayed (hidden)
  • no "AL": the line lies outside the interval

For details on the MSRA operating mode see "Applications and Operating Modes" .


I/Q Data Import and Export

cdma2000 Measurements (R&S FSW-K82/-K83) > I/Q Data Import and Export
I/Q Data Import and Export

Baseband signals mostly occur as so-called complex baseband signals, i.e. a signal representation that consists of two channels; the in phase (I) and the quadrature (Q) channel. Such signals are referred to as I/Q signals. I/Q signals are useful because the specific RF or IF frequencies are not needed. The complete modulation information and even distortion that originates from the RF, IF or baseband domains can be analyzed in the I/Q baseband.

Importing and exporting I/Q signals is useful for various applications:
  • Generating and saving I/Q signals in an RF or baseband signal generator or in external software tools to analyze them with the R&S FSW later
  • Capturing and saving I/Q signals with an RF or baseband signal analyzer to analyze them with the R&S FSW or an external software tool later

As opposed to storing trace data, which may be averaged or restricted to peak values, I/Q data is stored as it was captured, without further processing. The data is stored as complex values in 32-bit floating-point format. Multi-channel data is not supported. The I/Q data is stored in a format with the file extension .iq.tar.

For a detailed description see "I/Q Data File Format (iq-tar)" .

Export only in MSRA mode

In MSRA mode, I/Q data can only be exported to other applications; I/Q data cannot be imported to the MSRA Master or any MSRA applications.

For details on import and export functions see "Import/Export Functions" .


Configuration

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration
Configuration

The CDMA2000 applications provide several different measurements for signals according to the CDMA2000 standard. The main and default measurement is Code Domain Analysis. In addition to the code domain power measurements specified by the CDMA2000 standard, the CDMA2000 applications offer measurements with predefined settings in the frequency domain, e.g. RF power measurements.

Only one measurement type can be configured per channel; however, several channels for CDMA2000 applications can be configured in parallel on the R&S FSW. Thus, you can configure one channel for a Code Domain Analysis, for example, and another for a Power measurement for the same input signal. Then you can use the Sequencer to perform all measurements consecutively and either switch through the results easily or monitor all results at the same time in the "MultiView" tab.

For details on the Sequencer function see "Running a Sequence of Measurements" .

Selecting the measurement type

When you activate a measurement channel in a CDMA2000 application, Code Domain Analysis of the input signal is started automatically. However, the CDMA2000 applications also provide other measurement types.

►

To select a different measurement type, do one of the following:

  • Select the "Overview" softkey. In the "Overview", select the "Select Measurement" button. Select the required measurement.
  • Press the MEAS key on the front panel. In the "Select Measurement" dialog box, select the required measurement.
Contents
  • Result Display
  • Code Domain Analysis
  • RF Measurements


Result Display

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Result Display
Result Display

The captured signal can be displayed using various evaluation methods. All evaluation methods available for CDMA2000 applications are displayed in the evaluation bar in SmartGrid mode when you do one of the following:

  • Select the [image] "SmartGrid" icon from the toolbar.
  • Select the "Display" button in the "Overview".
  • Press the MEAS key.
  • Select the "Display Config" softkey in any CDMA2000 menu.

Up to 16 evaluation methods can be displayed simultaneously in separate windows. The CDMA2000 evaluation methods are described in "Evaluation Methods for Code Domain Analysis".

To close the SmartGrid mode and restore the previous softkey menu select the [image] "Close" icon in the righthand corner of the toolbar, or press any key on the front panel.

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .


Code Domain Analysis

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis
Code Domain Analysis

CDMA2000 measurements require a special application on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Applications and Operating Modes" .

When you activate a CDMA2000 application the first time, a set of parameters is passed on from the currently active application:
  • center frequency and frequency offset
  • reference level and reference level offset
  • attenuation

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

When you activate a CDMA2000 application, Code Domain Analysis of the input signal is started automatically with the default configuration. The "Code Domain Analyzer" menu is displayed and provides access to the most important configuration functions. This menu is also displayed when you press the MEAS CONFIG key on the front panel.

For a description see
  • "Signal Description"
  • "Signal Capture (Data Acquisition)"
  • "Channel Detection"
  • "Code Domain Analysis Settings"
  • "Evaluation Range"
  • "Result Display"

The "Span", "Bandwidth", "Lines", and "Marker Functions" menus are not available for CDA measurements.

Code Domain Analysis can be configured easily in the "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu.

Importing and Exporting I/Q Data

The I/Q data to be evaluated for CDMA2000 can not only be measured by the CDMA2000 applications themselves, it can also be imported to the applications, provided it has the correct format. Furthermore, the evaluated I/Q data from the CDMA2000 applications can be exported for further analysis in external applications.

The import and export functions are available in the "Save/Recall" menu which is displayed when you select the [image] "Save" or [image] "Open" icon in the toolbar.

For details on importing and exporting I/Q data see "I/Q Data Import and Export".

Contents
  • Default Settings for Code Domain Analysis
  • Configuration Overview
  • Signal Description
  • Data Input and Output Settings
  • Frontend Settings
  • Trigger Settings
  • Signal Capture (Data Acquisition)
  • Application Data (MSRA)
  • Synchronization
  • Channel Detection
  • Sweep Settings
  • Automatic Settings
  • BW, Span, Lines and Marker Function Menus
  • Zoom Functions


Default Settings for Code Domain Analysis

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Default Settings for Code Domain Analysis
Default Settings for Code Domain Analysis

When you activate a CDMA2000 application the first time, a set of parameters is passed on from the currently active application:

  • center frequency and frequency offset
  • reference level and reference level offset
  • attenuation
  • signal source and digital I/Q input settings
  • input coupling
  • YIG filter state

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

Apart from these settings, the following default settings are activated directly after a CDMA2000 application is activated, or after a "Preset Channel":

The following default settings of the Code Domain Analysis are activated:

Default settings for CDMA2000 channels
Parameter | Value
Common CDMA2000 settings
Digital standard | CDMA 2000 MC1 (where MC1 stands for Multi–carrier 1 and thus describes CDMA2000 1X, i.e. a single carrier)
Measurement | Code Domain Analysis
Bandclass | BC 0: 800 MHz Cellular Band
Sweep | CONTINUOUS
Channel detection mode | AUTOSEARCH
Trigger settings | FREE RUN
Trigger offset | 0
Threshold value | -60 dB
Number of PCGs | 3
Number of Sets | 1
PCG number | 0
Code number | 0
Code Order | Hadamard
Evaluations | Window 1: Code Domain Power Relative Window 2: Result Summary
BTS specific settings
Symbol rate | 19.2 ksps
PN offset | 0 chips
Antenna Diversity | Off
MS specific settings
Symbol rate | 38.4 ksps
Long code mask | 0
Long code offset | 0
Evaluated Branch | I


Configuration Overview

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Configuration Overview
Configuration Overview

Throughout the measurement channel configuration, an overview of the most important currently defined settings is provided in the "Overview". The "Overview" is displayed when you select the "Overview" icon, which is available at the bottom of all softkey menus.

In addition to the main measurement settings, the "Overview" provides quick access to the main settings dialog boxes. Thus, you can easily configure an entire measurement channel from input over processing to output and evaluation by stepping through the dialog boxes as indicated in the "Overview".

The available settings and functions in the "Overview" vary depending on the currently selected measurement. For RF measurements see "RF Measurements".

For Code Domain Analysis, the "Overview" provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

  1. "Select Measurement"

    See "Selecting the measurement type"

  2. "Signal Description"

    See "Signal Description"

  3. "Input/ Frontend"

    See "Data Input and Output Settings" and "Frontend Settings"

  4. (Optionally:) "Trigger"

    See "Trigger Settings"

  5. "Signal Capture"

    See "Signal Capture (Data Acquisition)"

    Note: The "Synchronization" button indicated in the Overview is not required for CDMA2000 measurements.

  6. "Channel Detection"

    See "Channel Detection"

  7. "Analysis"

    See "Analysis"

  8. "Display Configuration"

    See "Evaluation Methods for Code Domain Analysis"

To configure settings
►

Select any button in the "Overview" to open the corresponding dialog box.

Select a setting in the channel bar (at the top of the measurement channel tab) to change a specific setting.

└ Preset Channel
└ Select Measurement
└ Specifics for


Preset Channel

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Configuration Overview > Preset Channel
Preset Channel

Select the "Preset Channel" button in the lower lefthand corner of the "Overview" to restore all measurement settings in the current channel to their default values.

Note that the PRESET key on the front panel restores the entire instrument to its default values and thus closes all measurement channels on the R&S FSW (except for the default Spectrum application channel)!

See "Default Settings for Code Domain Analysis" for details.

Remote command:

SYSTem:​PRESet:​CHANnel[:​EXECute]


Select Measurement

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Configuration Overview > Select Measurement
Select Measurement

Selects a different measurement to be performed.

See "Selecting the measurement type".


Specifics for

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Configuration Overview > Specifics for
Specifics for

The measurement channel may contain several windows for different results. Thus, the settings indicated in the "Overview" and configured in the dialog boxes vary depending on the selected window.

Select an active window from the "Specifics for" selection list that is displayed in the "Overview" and in all window-specific configuration dialog boxes.

The "Overview" and dialog boxes are updated to indicate the settings for the selected window.


Signal Description

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Description
Signal Description

The signal description provides information on the expected input signal.

Contents
  • BTS Signal Description
  • MS Signal Description


BTS Signal Description

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Description > BTS Signal Description
BTS Signal Description

These settings describe the input signal in BTS measurements.

└ PN Offset
└ Antenna Diversity - Antenna Number
└ Multicarrier
└ Enhanced Algorithm
└ Multicarrier Filter
└ Filter Type
└ Roll-Off Factor
└ Cut Off Frequency


PN Offset

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Description > BTS Signal Description > PN Offset
PN Offset

Specifies the Pseudo Noise (PN) offset from an external trigger. If no offset is specified or no external trigger is available, calculation is much slower as the correct PN must be determined from all possible positions.

For details see "Scrambling via PN Offsets and Long Codes".

Remote command:

[SENSe:​]CDPower:​PNOFfset


Antenna Diversity - Antenna Number

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Description > BTS Signal Description > Antenna Diversity - Antenna Number
Antenna Diversity - Antenna Number

Activates or deactivates the orthogonal transmit diversity (two-antenna system) and defines the antenna for which the results are displayed.

For details on antenna diversity see also "Antenna Diversity".

"Antenna 1" | The signal of antenna 1 is fed in.
"Antenna 2" | The signal of antenna 2 is fed in.
"Off" | The aggregate signal from both antennas is fed in. The pilot channels of both antennas are required. As reference for the code power (Power Reference), PICH is used.
Remote command:

[SENSe:​]CDPower:​ANTenna


Multicarrier

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Description > BTS Signal Description > Multicarrier
Multicarrier

Activates or deactivates the multicarrier mode. This mode improves the processing of multicarrier signals. It allows you to measure one carrier out of a multicarrier signal.

Remote command:

CONFigure:​CDPower[:​BTS]:​MCARrier[:​STATe]

└ Enhanced Algorithm
└ Multicarrier Filter
└ Filter Type
└ Roll-Off Factor
└ Cut Off Frequency


Enhanced Algorithm

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Description > BTS Signal Description > Multicarrier > Enhanced Algorithm
Enhanced Algorithm

Activates or deactivates the enhanced algorithm that is used for signal detection on multicarrier signals. This algorithm slightly increases the calculation time.

This setting is only available if "Multicarrier" is activated.

Remote command:

CONFigure:​CDPower[:​BTS]:​MCARrier:​MALGo


Multicarrier Filter

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Description > BTS Signal Description > Multicarrier > Multicarrier Filter
Multicarrier Filter

Activates or deactivates the usage of a filter for signal detection on multicarrier signals.

This setting is only available if "Multicarrier" is activated.

For details see "Multicarrier Mode".

Remote command:

CONFigure:​CDPower[:​BTS]:​MCARrier:​FILTer[:​STATe]


Filter Type

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Description > BTS Signal Description > Multicarrier > Filter Type
Filter Type

Selects the filter type if "Multicarrier Filter" is activated.

Two filter types are available for selection: a low-pass filter and an RRC filter.

By default, the low-pass filter is active. The low-pass filter affects the quality of the measured signal compared to a measurement without a filter.

The RRC filter comes with an integrated Hamming window. If selected, two more settings become available for configuration: the "Roll-Off Factor" and the "Cut Off Frequency".

For details see "Multicarrier Mode".

Remote command:

CONFigure:​CDPower[:​BTS]:​MCARrier:​FILTer:​TYPE

└ Roll-Off Factor
└ Cut Off Frequency


Roll-Off Factor

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Description > BTS Signal Description > Multicarrier > Filter Type > Roll-Off Factor
Roll-Off Factor

Defines the roll-off factor of the RRC filter which defines the slope of the filter curve and therefore the excess bandwidth of the filter. Possible values are between 0.01 and 0.99 in 0.01 steps. The default value is 0.02.

This parameter is available for the RRC filter.

Remote command:

CONFigure:​CDPower[:​BTS]:​MCARrier:​FILTer:​TYPE

CONFigure:​CDPower[:​BTS]:​MCARrier:​FILTer:​ROFF


Cut Off Frequency

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Description > BTS Signal Description > Multicarrier > Filter Type > Cut Off Frequency
Cut Off Frequency

Defines the frequency at which the passband of the RRC filter begins. Possible values are between 0.1 MHz and 2.4 MHz in 1 Hz steps. The default value is 1.25 MHz

This parameter is available for the RRC filter.

Remote command:

CONFigure:​CDPower[:​BTS]:​MCARrier:​FILTer:​TYPE

CONFigure:​CDPower[:​BTS]:​MCARrier:​FILTer:​COFRequency


MS Signal Description

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Description > MS Signal Description
MS Signal Description

These settings describe the input signal in MS measurements.

└ Long Code Mask
└ Long Code Offset
└ Long Code Generation
└ Multicarrier
└ Enhanced Algorithm
└ Multicarrier Filter
└ Filter Type
└ Roll-Off Factor
└ Cut Off Frequency


Long Code Mask

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Description > MS Signal Description > Long Code Mask
Long Code Mask

Defines the long code mask of the mobile in hexadecimal form. The value range is from 0 to 4FFFFFFFFFF.

For the default mask value of 0 the "Long Code Offset" is not taken into consideration.

For more information on long codes see "Long code scrambling".

Remote command:

[SENSe:​]CDPower:​LCODe:​MASK


Long Code Offset

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Description > MS Signal Description > Long Code Offset
Long Code Offset

Defines the long code offset, including the PN offset, in chips in hexadecimal format with a 52-bit resolution. This value corresponds to the GPS timing since 6.1.1980 00:00:00 UTC. This offset is applied at the next trigger pulse (which cannot occur until a setup time of 300 ms has elapsed). The default value is 0.

The setting is ignored if the "Long Code Mask" is set to 0.

For more information on long codes see "Long code scrambling".

Remote command:

[SENSe:​]CDPower:​LCODe:​OFFSet


Long Code Generation

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Description > MS Signal Description > Long Code Generation
Long Code Generation

Selects the mode of the long code generation.

"Standard" | The CDMA2000 standard long code generator is used.
"ESG 101" | The Agilent ESG option 101 long code is used; in this case, only signals from that generator can be analyzed.
Remote command:

[SENSe:​]CDPower:​LCODe:​MODE


Data Input and Output Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings
Data Input and Output Settings

The R&S FSW can analyze signals from different input sources and provide various types of output (such as noise or trigger signals).

Frontend settings are described in "Frontend Settings".

Contents
  • Input Source Settings
  • Output Settings
  • Digital I/Q Output Settings


Input Source Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings
Input Source Settings

The input source determines which data the R&S FSW will analyze.

Input settings can be configured in the "Input" dialog box.

Some settings are also available in the "Amplitude" tab of the "Amplitude" dialog box.

Output settings are described in "Output Settings".

Since the Digital I/Q input and the Analog Baseband input use the same digital signal path, both cannot be used simultaneously. When one is activated, established connections for the other are disconnected. When the second input is deactivated, connections to the first are re-established. This may cause a short delay in data transfer after switching the input source.

Contents
  • Radio Frequency Input
  • Digital I/Q Input Settings
  • Analog Baseband Input Settings
  • Probe Settings


Radio Frequency Input

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Radio Frequency Input
Radio Frequency Input

The default input source for the R&S FSW is "Radio Frequency", i.e. the signal at the RF INPUT connector on the front panel of the R&S FSW. If no additional options are installed, this is the only available input source.

└ Radio Frequency State
└ Input Coupling
└ Impedance
└ High-Pass Filter 1...3 GHz
└ YIG-Preselector
└ Input Connector


Radio Frequency State

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > Radio Frequency State
Radio Frequency State

Activates input from the RF INPUT connector.

Remote command:

INPut:​SELect


Input Coupling

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > Input Coupling
Input Coupling

The RF input of the R&S FSW can be coupled by alternating current (AC) or direct current (DC).

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17) or from the Analog Baseband Interface (R&S FSW-B71).

AC coupling blocks any DC voltage from the input signal. This is the default setting to prevent damage to the instrument. Very low frequencies in the input signal may be distorted.

However, some specifications require DC coupling. In this case, you must protect the instrument from damaging DC input voltages manually. For details, refer to the data sheet.

Remote command:

INPut:​COUPling


Impedance

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > Impedance
Impedance

The reference impedance for the measured levels of the R&S FSW can be set to 50 Ω or 75 Ω.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a 75 Ω adapter of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

This value also affects the unit conversion (see "Reference Level").

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17) or from the Analog Baseband Interface (R&S FSW-B71). For analog baseband input, an impedance of 50 Ω is always used.

Remote command:

INPut:​IMPedance


High-Pass Filter 1...3 GHz

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > High-Pass Filter 1...3 GHz
High-Pass Filter 1...3 GHz

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Remote command:

INPut:​FILTer:​HPASs[:​STATe]


YIG-Preselector

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > YIG-Preselector
YIG-Preselector

Activates or deactivates the YIG-preselector.

An internal YIG-preselector at the input of the R&S FSW ensures that image frequencies are rejected. However, this is only possible for a restricted bandwidth. In order to use the maximum bandwidth for signal analysis you can deactivate the YIG-preselector at the input of the R&S FSW, which may lead to image-frequency display.

Note that the YIG-preselector is active only on frequencies greater than 8 GHz. Therefore, switching the YIG-preselector on or off has no effect if the frequency is below that value.

Remote command:

INPut:​FILTer:​YIG[:​STATe]


Input Connector

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > Input Connector
Input Connector

Determines whether the RF input data is taken from the RF INPUT connector (default) or the optional BASEBAND INPUT I connector. This setting is only available if the Analog Baseband Interface (R&S FSW-B71) is installed and active for input. It is not available for the R&S FSW67.

For more information see "Processing Data From the Analog Baseband Interface" .

Remote command:

INPut:​CONNector


Digital I/Q Input Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings
Digital I/Q Input Settings

The following settings and functions are available to provide input via the Digital Baseband Interface (R&S FSW-B17) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see " Processing Data from the Digital Baseband Interface (-B17)" .

└ Digital I/Q Input State
└ Input Sample Rate
└ Full Scale Level
└ Adjust Reference Level to Full Scale Level
└ Connected Instrument
└ DigIConf


Digital I/Q Input State

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Digital I/Q Input State
Digital I/Q Input State

Enables or disable the use of the "Digital IQ" input source for measurements. "Digital IQ" is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

Remote command:

INPut:​SELect


Input Sample Rate

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Input Sample Rate
Input Sample Rate

Defines the sample rate of the digital I/Q signal source. This sample rate must correspond with the sample rate provided by the connected device, e.g. a generator.

If "Auto" is selected, the sample rate is adjusted automatically by the connected device.

The allowed range is from 100 Hz to 10 GHz.

Remote command:

INPut:​DIQ:​SRATe

INPut:​DIQ:​SRATe:​AUTO


Full Scale Level

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Full Scale Level
Full Scale Level

The "Full Scale Level" defines the level and unit that should correspond to an I/Q sample with the magnitude "1".

If "Auto" is selected, the level is automatically set to the value provided by the connected device.

Remote command:

INPut:​DIQ:​RANGe[:​UPPer]

INPut:​DIQ:​RANGe[:​UPPer]:​UNIT

INPut:​DIQ:​RANGe[:​UPPer]:​AUTO


Adjust Reference Level to Full Scale Level

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Adjust Reference Level to Full Scale Level
Adjust Reference Level to Full Scale Level

If enabled, the reference level is adjusted to the full scale level automatically if any change occurs.

Remote command:

INPut:​DIQ:​RANGe:​COUPling


Connected Instrument

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Connected Instrument
Connected Instrument

Displays the status of the Digital Baseband Interface connection.

This function is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

If an instrument is connected, the following information is displayed:

  • Name and serial number of the instrument connected to the Digital Baseband Interface
  • Used port
  • Sample rate of the data currently being transferred via the Digital Baseband Interface
  • Level and unit that corresponds to an I/Q sample with the magnitude "1" ("Full Scale Level"), if provided by connected instrument
Remote command:

INPut:​DIQ:​CDEVice


DigIConf

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > DigIConf
DigIConf

Starts the optional R&S DigIConf application. This softkey is available in the In-/Output menu, but only if the optional software is installed.

Note that R&S DigIConf requires a USB connection (not LAN!) from the R&S FSW to the R&S EX-IQ-BOX in addition to the Digital Baseband Interface (R&S FSW-B17) connection. R&S DigIConf version 2.20.360.86 Build 170 or higher is required.

To return to the R&S FSW application, press any key on the front panel. The R&S FSW application is displayed with the "Input/Output" menu, regardless of which key was pressed.

For details on the R&S DigIConf application, see the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Note: If you close the R&S DigIConf window using the "Close" icon, the window is minimized, not closed.
If you select the "File > Exit" menu item in the R&S DigIConf window, the application is closed. Note that in this case the settings are lost and the EX-IQ-BOX functionality is no longer available until you restart the application using the "DigIConf" softkey in the R&S FSW once again.


Analog Baseband Input Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings
Analog Baseband Input Settings

The following settings and functions are available to provide input via the Analog Baseband Interface (R&S FSW-B71) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see "Processing Data From the Analog Baseband Interface" .

If Analog Baseband input is used, measurements in the frequency and time domain are not available.

└ Analog Baseband Input State
└ I/Q Mode
└ Input configuration
└ Center Frequency


Analog Baseband Input State

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > Analog Baseband Input State
Analog Baseband Input State

Enables or disable the use of the "Analog Baseband" input source for measurements. "Analog Baseband" is only available if the Analog Baseband Interface (R&S FSW-B71) is installed.

Remote command:

INPut:​SELect


I/Q Mode

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > I/Q Mode
I/Q Mode

Defines the format of the input signal.

For more information see "I/Q Processing Modes" .

"I + jQ"

The input signal is filtered and resampled to the sample rate of the application.

Two inputs are required for a complex signal, one for the in-phase component, and one for the quadrature component.

"I Only / Low IF I"

The input signal at the BASEBAND INPUT I connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband I).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF I).

"Q Only / Low IF Q"

The input signal at the BASEBAND INPUT Q connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband Q).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF Q).

Remote command:

INPut:​IQ:​TYPE


Input configuration

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > Input configuration
Input configuration

Defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Note: Both single-ended and differential probes are supported as input; however, since only one connector is occupied by a probe, the "Single-ended" setting must be used for all probes.
For details on probes see "Using Probes" .

"Differential" | I, Q and inverse I,Q data
"Single Ended" | I, Q data only
Remote command:

INPut:​IQ:​BALanced[:​STATe]


Center Frequency

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > Center Frequency
Center Frequency

Defines the center frequency for analog baseband input.

For real-type baseband input (I or Q only), the center frequency is always 0 Hz.

Note: If the analysis bandwidth to either side of the defined center frequency exceeds the minimum frequency (0 Hz) or the maximum frequency (40 MHz/80 MHz), an error is displayed. In this case, adjust the center frequency or the analysis bandwidth.

Remote command:

[SENSe:​]FREQuency:​CENTer


Probe Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Probe Settings
Probe Settings

Probes are configured in a separate tab on the "Input" dialog box which is displayed when you select the INPUT/OUTPUT key and then "Input Source Config".

For each possible probe connector (Baseband Input I, Baseband Input Q), the detected type of probe, if any, is displayed. The following information is provided for each connected probe:

  • Probe name
  • Serial number
  • R&S part number
  • Type of probe ("Differential", "Single Ended")

For more information on using probes with an R&S FSW, see "Using Probes" .

For general information on the R&S®RTO probes, see the device manuals.

└ Microbutton Action


Microbutton Action

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Input Source Settings > Probe Settings > Microbutton Action
Microbutton Action

Active R&S probes (except for RT-ZS10E) have a configurable microbutton on the probe head. By pressing this button, you can perform an action on the instrument directly from the probe.

Select the action that you want to start from the probe:

"Run single" | Starts one data acquisition.
"No action" | Prevents unwanted actions due to unintended usage of the microbutton.
Remote command:

[SENSe:​]PROBe<p>:​SETup:​MODE


Output Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Output Settings
Output Settings

The R&S FSW can provide output to special connectors for other devices.

For details on connectors refer to "Instrument Tour" .

Providing trigger signals as output is described in "How to Output a Trigger Signal" .

Output settings can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

└ Noise Source
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Noise Source

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Output Settings > Noise Source
Noise Source

Switches the supply voltage for an external noise source on or off.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of a DUT.

Remote command:

DIAGnostic:​SERVice:​NSOurce


Trigger 2/3

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Output Settings > Trigger 2/3
Trigger 2/3

Defines the usage of the variable TRIGGER INPUT/OUTPUT connectors, where:

"Trigger 2": TRIGGER INPUT/OUTPUT connector on the front panel

"Trigger 3": TRIGGER 3 INPUT/ OUTPUT connector on the rear panel

(Trigger 1 is INPUT only.)

Note: Providing trigger signals as output is described in detail in "How to Output a Trigger Signal" .

"Input" | The signal at the connector is used as an external trigger source by the R&S FSW. No further trigger parameters are available for the connector.
"Output" | The R&S FSW sends a trigger signal to the output connector to be used by connected devices. Further trigger parameters are available for the connector.
Remote command:

OUTPut:​TRIGger<port>:​LEVel

OUTPut:​TRIGger<port>:​DIRection

└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Output Type

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Output Settings > Trigger 2/3 > Output Type
Output Type

Type of signal to be sent to the output

"Device Triggered" | (Default) Sends a trigger when the R&S FSW triggers.
"Trigger Armed" | Sends a (high level) trigger when the R&S FSW is in "Ready for trigger" state. This state is indicated by a status bit in the STATus:OPERation register (bit 5), as well as by a low level signal at the AUX port (pin 9).
"User Defined" | Sends a trigger when user selects "Send Trigger" button. In this case, further parameters are available for the output signal.
Remote command:

OUTPut:​TRIGger<port>:​OTYPe

└ Level
└ Pulse Length
└ Send Trigger


Level

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Output Settings > Trigger 2/3 > Output Type > Level
Level

Defines whether a constant high (1) or low (0) signal is sent to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​LEVel


Pulse Length

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Output Settings > Trigger 2/3 > Output Type > Pulse Length
Pulse Length

Defines the length of the pulse sent as a trigger to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​LENGth


Send Trigger

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Output Settings > Trigger 2/3 > Output Type > Send Trigger
Send Trigger

Sends a user-defined trigger to the output connector immediately. Note that the trigger pulse level is always opposite to the constant signal level defined by the output "Level" setting, e.g. for "Level = High", a constant high signal is output to the connector until the "Send Trigger" button is selected. Then, a low pulse is sent.

Which pulse level will be sent is indicated by a graphic on the button.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​IMMediate


Digital I/Q Output Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Digital I/Q Output Settings
Digital I/Q Output Settings

The optional Digital Baseband Interface (R&S FSW-B17) allows you to output I/Q data from any R&S FSW application that processes I/Q data to an external device. The configuration settings for digital I/Q output can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

Digital output is not available if the bandwidth extension option R&S FSW-B500 is active.

For details on digital I/Q output see "Digital Output" .

└ Digital Baseband Output
└ Output Settings Information
└ Connected Instrument


Digital Baseband Output

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Digital I/Q Output Settings > Digital Baseband Output
Digital Baseband Output

Enables or disables a digital output stream to the optional Digital Baseband Interface (R&S FSW-B17), if available.

Note: If digital baseband output is active, the sample rate is restricted to 200 MHz (max. 160 MHz bandwidth).
The only data source that can be used for digital baseband output is RF input.

For details on digital I/Q output see "Digital Output" .

Remote command:

OUTPut:​DIQ


Output Settings Information

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Digital I/Q Output Settings > Output Settings Information
Output Settings Information

Displays information on the settings for output via the Digital Baseband Interface (R&S FSW-B17).

The following information is displayed:

  • Maximum sample rate that can be used to transfer data via the Digital Baseband Interface (i.e. the maximum input sample rate that can be processed by the connected instrument)
  • Sample rate currently used to transfer data via the Digital Baseband Interface
  • Level and unit that corresponds to an I/Q sample with the magnitude "1" ("Full Scale Level")
Remote command:

OUTPut:​DIQ:​CDEVice


Connected Instrument

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Data Input and Output Settings > Digital I/Q Output Settings > Connected Instrument
Connected Instrument

Displays information on the instrument connected to the Digital Baseband Interface (R&S FSW-B17), if available.

If an instrument is connected, the following information is displayed:

  • Name and serial number of the instrument connected to the Digital Baseband Interface
  • Used port
Remote command:

OUTPut:​DIQ:​CDEVice


Frontend Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings
Frontend Settings

The frequency, amplitude and y-axis scaling settings represent the "frontend" of the measurement setup.

Contents
  • Frequency Settings
  • Amplitude Settings
  • Amplitude Settings for Analog Baseband Input
  • Y-Axis Scaling


Frequency Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Frequency Settings
Frequency Settings

Frequency settings for the input signal can be configured via the "Frequency" dialog box, which is displayed when you do one of the following:

  • Select the FREQ key and then the "Frequency Config" softkey.
  • Select the "Frequency" tab in the "Input Settings" dialog box
└ Center frequency
└ Center Frequency Stepsize
└ Frequency Offset


Center frequency

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Frequency Settings > Center frequency
Center frequency

Defines the normal center frequency of the signal. The allowed range of values for the center frequency depends on the frequency span.

span > 0: spanmin/2 ≤ fcenter ≤ fmax – spanmin/2

fmax and spanmin are specified in the data sheet.

Remote command:

[SENSe:​]FREQuency:​CENTer


Center Frequency Stepsize

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Frequency Settings > Center Frequency Stepsize
Center Frequency Stepsize

Defines the step size by which the center frequency is increased or decreased when the arrow keys are pressed. When you use the rotary knob the center frequency changes in steps of only 1/10 of the "Center Frequency Stepsize".

The step size can be coupled to another value or it can be manually set to a fixed value.

This setting is available for frequency and time domain measurements.

For more details see "Stepping Through the Frequency Range - Center Frequency Stepsize" .

"X * Span" | Sets the step size for the center frequency to a defined factor of the span. The "X-Factor" defines the percentage of the span. Values between 1 and 100 % in steps of 1 % are allowed. The default setting is 10 %.
"= Center" | Sets the step size to the value of the center frequency. The used value is indicated in the "Value" field.
"Manual" | Defines a fixed step size for the center frequency. Enter the step size in the "Value" field.
Remote command:

[SENSe:​]FREQuency:​CENTer:​STEP


Frequency Offset

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Frequency Settings > Frequency Offset
Frequency Offset

Shifts the displayed frequency range along the x-axis by the defined offset.

This parameter has no effect on the R&S FSW hardware, or on the captured data or on data processing. It is simply a manipulation of the final results in which absolute frequency values are displayed. Thus, the x-axis of a spectrum display is shifted by a constant offset if it shows absolute frequencies, but not if it shows frequencies relative to the signal's center frequency.

A frequency offset can be used to correct the display of a signal that is slightly distorted by the measurement setup, for example.

The allowed values range from -100 GHz to 100 GHz. The default setting is 0 Hz.

Remote command:

[SENSe:​]FREQuency:​OFFSet


Amplitude Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings
Amplitude Settings

Amplitude settings determine how the R&S FSW must process or display the expected input power levels.

The scaling settings are described in "Y-Axis Scaling".

Amplitude settings for input from the Analog Baseband interface (R&S FSW-B71) are described in "Amplitude Settings for Analog Baseband Input".

To configure the amplitude settings

Amplitude settings can be configured via the AMPT key or in the "Amplitude" dialog box.

►

To display the "Amplitude" dialog box, do one of the following:

  • Select "Input/Frontend" from the "Overview" and then switch to the "Amplitude" tab.
  • Select the AMPT key and then the "Amplitude Config" softkey.
└ Reference Level
└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)
└ RF Attenuation
└ Attenuation Mode / Value
└ Using Electronic Attenuation (Option B25)
└ Input Settings
└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Reference Level

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings > Reference Level
Reference Level

Defines the expected maximum reference level. Signal levels above this value may not be measured correctly, which is indicated by the "IF OVLD" status display ("OVLD" for analog baseband or digitial baseband input).

The reference level is also used to scale power diagrams; the reference level is then used as the maximum on the y-axis.

Since the R&S FSW hardware is adapted according to this value, it is recommended that you set the reference level close above the expected maximum signal level to ensure an optimum measurement (no compression, good signal-to-noise ratio).

Note that the "Reference Level" value ignores the "Shifting the Display (Offset)". It is important to know the actual power level the R&S FSW must handle.

For details see "Reference Level" .

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel

└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)


Shifting the Display (Offset)

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings > Reference Level > Shifting the Display (Offset)
Shifting the Display (Offset)

Defines an arithmetic level offset. This offset is added to the measured level irrespective of the selected unit. The scaling of the y-axis is changed accordingly.

Define an offset if the signal is attenuated or amplified before it is fed into the R&S FSW so the application shows correct power results. All displayed power level results will be shifted by this value.

Note, however, that the "Reference Level" value ignores the "Reference Level Offset". It is important to know the actual power level the R&S FSW must handle.

To determine the required offset, consider the external attenuation or gain applied to the input signal. A positive value indicates that an attenuation took place (R&S FSW increases the displayed power values) , a negative value indicates an external gain (R&S FSW decreases the displayed power values).

The setting range is ±200 dB in 0.01 dB steps.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel:​OFFSet


Unit

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings > Reference Level > Unit
Unit

For CDA measurements the unit should not be changed, as this would lead to useless results.


Setting the Reference Level Automatically (Auto Level)

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings > Reference Level > Setting the Reference Level Automatically (Auto Level)
Setting the Reference Level Automatically (Auto Level)

Automatically determines the optimal reference level for the current input data. At the same time, the internal attenuators and the preamplifier (for analog baseband input: the full scale level) are adjusted so the signal-to-noise ratio is optimized, while signal compression, clipping and overload conditions are minimized.

In order to do so, a level measurement is performed to determine the optimal reference level.

This function is only available for the MSRA/MSRT Master, not for the applications.

You can change the measurement time for the level measurement if necessary (see "Changing the Automatic Measurement Time (Meastime Manual)").

Remote command:

[SENSe:​]ADJust:​LEVel


RF Attenuation

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings > RF Attenuation
RF Attenuation

Defines the attenuation applied to the RF input.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

└ Attenuation Mode / Value


Attenuation Mode / Value

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings > RF Attenuation > Attenuation Mode / Value
Attenuation Mode / Value

The RF attenuation can be set automatically as a function of the selected reference level (Auto mode). This ensures that the optimum RF attenuation is always used. It is the default setting. By default and when "Using Electronic Attenuation (Option B25)" is not available, mechanical attenuation is applied.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

In "Manual" mode, you can set the RF attenuation in 1 dB steps (down to 0 dB, also using the rotary knob). Other entries are rounded to the next integer value. The range is specified in the data sheet. If the defined reference level cannot be set for the defined RF attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed.

NOTICE! Risk of hardware damage due to high power levels. When decreasing the attenuation manually, ensure that the power level does not exceed the maximum level allowed at the RF input, as an overload may lead to hardware damage.

Note: In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible (if option B25 is installed and active) to reduce the amount of mechanical switching required.

For details see "RF Attenuation" .

Remote command:

INPut:​ATTenuation

INPut:​ATTenuation:​AUTO


Using Electronic Attenuation (Option B25)

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings > Using Electronic Attenuation (Option B25)
Using Electronic Attenuation (Option B25)

If option R&S FSW-B25 is installed, you can also activate an electronic attenuator.

In "Auto" mode, the settings are defined automatically; in "Manual" mode, you can define the mechanical and electronic attenuation separately.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

Note: Electronic attenuation is not available for stop frequencies (or center frequencies in zero span) >13.6 GHz.
In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible to reduce the amount of mechanical switching required. Mechanical attenuation may provide a better signal-to-noise ratio, however.
When you switch off electronic attenuation, the RF attenuation is automatically set to the same mode (auto/manual) as the electronic attenuation was set to. Thus, the RF attenuation may be set to automatic mode, and the full attenuation is provided by the mechanical attenuator, if possible.

Both the electronic and the mechanical attenuation can be varied in 1 dB steps. Other entries are rounded to the next lower integer value.

If the defined reference level cannot be set for the given attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed in the status bar.

Remote command:

INPut:​EATT:​STATe

INPut:​EATT:​AUTO

INPut:​EATT


Input Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings > Input Settings
Input Settings

Some input settings affect the measured amplitude of the signal, as well.

└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Preamplifier (option B24)

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings > Input Settings > Preamplifier (option B24)
Preamplifier (option B24)

If option R&S FSW-B24 is installed, a preamplifier can be activated for the RF input signal.

You can use a preamplifier to analyze signals from DUTs with low input power.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the following settings are available:

"Off" | Deactivates the preamplifier.
"15 dB" | The RF input signal is amplified by about 15 dB.
"30 dB" | The RF input signal is amplified by about 30 dB.
Remote command:

INPut:​GAIN:​STATe

INPut:​GAIN[:​VALue]


Amplitude Settings for Analog Baseband Input

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings for Analog Baseband Input
Amplitude Settings for Analog Baseband Input

The following settings and functions are available to define amplitude settings for input via the Analog Baseband Interface (R&S FSW-B71) in the applications that support it.

They can be configured via the AMPT key or in the "Amplitude" tab of the "Input" dialog box.

The input settings provided here are identical to those in the "Input Source" > "Analog Baseband" tab, see "Analog Baseband Input Settings".

For more information see "Processing Data From the Analog Baseband Interface" .

└ Reference Level
└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)
└ Full Scale Level Mode / Value


Full Scale Level Mode / Value

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Amplitude Settings for Analog Baseband Input > Full Scale Level Mode / Value
Full Scale Level Mode / Value

The full scale level defines the maximum power you can input at the Baseband Input connector without clipping the signal.

The full scale level can be defined automatically according to the reference level, or manually.

For manual input, the following values can be selected:

  • 0.25 V
  • 0.5 V
  • 1 V
  • 2 V

If probes are connected, the possible full scale values are adapted according to the probe's attenuation and maximum allowed power.

For details on probes see "Processing Data From the Analog Baseband Interface" .

Remote command:

INPut:​IQ:​FULLscale:​AUTO

INPut:​IQ:​FULLscale[:​LEVel]


Y-Axis Scaling

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Y-Axis Scaling
Y-Axis Scaling

The vertical axis scaling is configurable. In Code Domain Analysis, the y-axis usually displays the measured power levels.

└ Y-Maximum, Y-Minimum
└ Auto Scale Once
└ Restore Scale (Window)


Y-Maximum, Y-Minimum

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Y-Axis Scaling > Y-Maximum, Y-Minimum
Y-Maximum, Y-Minimum

Defines the amplitude range to be displayed on the y-axis of the evaluation diagrams.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MAXimum

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MINimum


Auto Scale Once

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Y-Axis Scaling > Auto Scale Once
Auto Scale Once

Automatically determines the optimal range and reference level position to be displayed for the current measurement settings.

The display is only set once; it is not adapted further if the measurement settings are changed again.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO ONCE


Restore Scale (Window)

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Frontend Settings > Y-Axis Scaling > Restore Scale (Window)
Restore Scale (Window)

Restores the default scale settings in the currently selected window.


Trigger Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Trigger Settings
Trigger Settings

Trigger settings determine when the input signal is measured.

External triggers from one of the TRIGGER INPUT/OUTPUT connectors on the R&S FSW are configured in a separate tab of the dialog box.

For step-by-step instructions on configuring triggered measurements, see "How to Configure a Triggered and Gated Measurement" .

For step-by-step instructions on configuring triggered measurements, see the main R&S FSW User Manual.

└ Trigger Source
└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ Digital I/Q
└ IF Power
└ Trigger Level
└ Drop-Out Time
└ Trigger Offset
└ Hysteresis
└ Trigger Holdoff
└ Slope
└ Capture Offset
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Trigger Source

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source
Trigger Source

The trigger settings define the beginning of a measurement.

└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ Digital I/Q
└ IF Power
└ Trigger Level
└ Drop-Out Time
└ Trigger Offset
└ Hysteresis
└ Trigger Holdoff
└ Slope
└ Capture Offset


Trigger Source

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Trigger Source
Trigger Source

Defines the trigger source. If a trigger source other than "Free Run" is set, "TRG" is displayed in the channel bar and the trigger source is indicated.

Remote command:

TRIGger[:​SEQuence]:​SOURce

└ Free Run
└ External Trigger 1/2/3
└ Digital I/Q
└ IF Power


Free Run

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Trigger Source > Free Run
Free Run

No trigger source is considered. Data acquisition is started manually or automatically and continues until stopped explicitely.

Remote command:

TRIG:SOUR IMM, see TRIGger[:​SEQuence]:​SOURce


External Trigger 1/2/3

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Trigger Source > External Trigger 1/2/3
External Trigger 1/2/3

Data acquisition starts when the TTL signal fed into the specified input connector (on the front or rear panel) meets or exceeds the specified trigger level.

(See "Trigger Level (Repetition interval)" ).

Note: The "External Trigger 1" softkey automatically selects the trigger signal from the TRIGGER INPUT connector on the front panel.

For details see "TRIGGER INPUT / OUTPUT" and "TRIGGER 3 INPUT/ OUTPUT" .

"External Trigger 1" | Trigger signal from the TRIGGER 1 INPUT connector on the front panel.
"External Trigger 2" | Trigger signal from the TRIGGER 2 INPUT/OUTPUT connector on the front panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
"External Trigger 3" | Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector on the rear panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
Remote command:

TRIG:SOUR EXT, TRIG:SOUR EXT2

TRIG:SOUR EXT3

See TRIGger[:​SEQuence]:​SOURce


Digital I/Q

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Trigger Source > Digital I/Q
Digital I/Q

For applications that process I/Q data, such as the I/Q Analyzer or optional applications, and only if the Digital Baseband Interface (R&S FSW-B17) is available:

Defines triggering of the measurement directly via the LVDS connector. In the selection list you must specify which general purpose bit (GP0 to GP5) will provide the trigger data.

Note: If the Digital I/Q enhanced mode is used, i.e. the connected device supports transfer rates up to 200 Msps, only the general purpose bits GP0 and GP1 are available as a Digital I/Q trigger source.

The following table describes the assignment of the general purpose bits to the LVDS connector pins.

(For details on the LVDS connector see "Description of the LVDS Connector" )

Assignment of general purpose bits to LVDS connector pins
Bit | LVDS pin
GP0 | SDATA4_P - Trigger1
GP1 | SDATA4_P - Trigger2
GP2 *) | SDATA0_P - Reserve1
GP3 *) | SDATA4_P - Reserve2
GP4 *) | SDATA0_P - Marker1
GP5 *) | SDATA4_P - Marker2
*): not available for Digital I/Q enhanced mode
Remote command:

TRIG:SOUR GP0, see TRIGger[:​SEQuence]:​SOURce


IF Power

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Trigger Source > IF Power
IF Power

The R&S FSW starts capturing data as soon as the trigger level is exceeded around the third intermediate frequency.

This trigger source is only available for RF input.

This trigger source is available for frequency and time domain measurements only.

It is not available for input from the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

For frequency sweeps, the third IF represents the start frequency. The trigger bandwidth at the third IF depends on the RBW and sweep type.

For measurements on a fixed frequency (e.g. zero span or I/Q measurements), the third IF represents the center frequency.

The available trigger levels depend on the RF attenuation and preamplification. A reference level offset, if defined, is also considered.

For details on available trigger levels and trigger bandwidths see the data sheet.

Remote command:

TRIG:SOUR IFP, see TRIGger[:​SEQuence]:​SOURce


Trigger Level

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Trigger Level
Trigger Level

Defines the trigger level for the specified trigger source.

For details on supported trigger levels, see the data sheet.

Remote command:

TRIGger[:​SEQuence]:​LEVel[:​EXTernal<port>]

For analog baseband (B71) or digital baseband (B17) input only:


Drop-Out Time

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Drop-Out Time
Drop-Out Time

Defines the time the input signal must stay below the trigger level before triggering again.

For more information on the drop-out time see "Trigger Drop-Out Time" .

Note: For input from the Analog Baseband Interface (R&S FSW-B71) using the baseband power trigger (BBP), the default drop out time is set to 100 ns to avoid unintentional trigger events (as no hysteresis can be configured in this case).

Remote command:

TRIGger[:​SEQuence]:​DTIMe


Trigger Offset

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Trigger Offset
Trigger Offset

Defines the time offset between the trigger event and the start of the sweep.

Note: In MSRA/MSRT mode, the trigger offset defines the start of the sweep only for the MSRA/MSRT Master. For MSRA/MSRT applications, use the "Capture Offset" instead.

offset > 0: | Start of the sweep is delayed
offset < 0: | Sweep starts earlier (pre-trigger)
Remote command:

TRIGger[:​SEQuence]:​HOLDoff[:​TIME]


Hysteresis

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Hysteresis
Hysteresis

Defines the distance in dB to the trigger level that the trigger source must exceed before a trigger event occurs. Settting a hysteresis avoids unwanted trigger events caused by noise oscillation around the trigger level.

This setting is only available for "IF Power" trigger sources. The range of the value is between 3 dB and 50 dB with a step width of 1 dB.

This setting is available for frequency and time domain measurements only.

For more information see "Trigger Hysteresis" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HYSTeresis


Trigger Holdoff

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Trigger Holdoff
Trigger Holdoff

Defines the minimum time (in seconds) that must pass between two trigger events. Trigger events that occur during the holdoff time are ignored.

For more information see "Trigger Holdoff" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HOLDoff


Slope

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Slope
Slope

For all trigger sources except time and frequency mask (Realtime only) you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Remote command:

TRIGger[:​SEQuence]:​SLOPe


Capture Offset

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Trigger Settings > Trigger Source > Capture Offset
Capture Offset

This setting is only available for applications in MSRA operating mode. It has a similar effect as the trigger offset in other measurements: it defines the time offset between the capture buffer start and the start of the extracted application data.

In MSRA mode, the offset must be a positive value, as the capture buffer starts at the trigger time = 0.

For details on the MSRA operating mode see "Applications and Operating Modes" .

Remote command:

[SENSe:​]MSRA:​CAPTure:​OFFSet


Signal Capture (Data Acquisition)

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Capture (Data Acquisition)
Signal Capture (Data Acquisition)

You must define how much and how data is captured from the input signal.

MSRA operating mode

In MSRA operating mode, only the MSRA Master channel actually captures data from the input signal. The data acquisition settings for the CDMA2000 BTS application in MSRA mode define the application data (see "Application Data (MSRA) ").

For details on the MSRA operating mode see "Applications and Operating Modes" .

└ Sample Rate
└ Invert Q
└ Number of PCGs
└ Number of Sets
└ Set to Analyze


Sample Rate

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Capture (Data Acquisition) > Sample Rate
Sample Rate

The sample rate is always 5.33333 MHz (indicated for reference only).


Invert Q

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Capture (Data Acquisition) > Invert Q
Invert Q

Inverts the sign of the signal's Q-branch. The default setting is OFF.

Remote command:

[SENSe:​]CDPower:​QINVert


Number of PCGs

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Capture (Data Acquisition) > Number of PCGs
Number of PCGs

Sets the number of PCGs you want to analyze. The input value is always in multiples of the PCGs. The maximum capture length is 64. The default value is 3.

If the "Number of Sets" to capture is larger than 1, the number of PCGs is always 64.

For more information on PCGs and sets see "PCGs and Sets".

Remote command:

[SENSe:​]CDPower:​IQLength


Number of Sets

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Capture (Data Acquisition) > Number of Sets
Number of Sets

Defines the number of consecutive sets to be captured and stored in the instrument's IQ memory. The possible value range is from 1 to a maximum of 1500 (BTS application) or 810 (MS application) sets.

The default setting is 1.

If you capture more than one set, the number of slots/PCGs is always 64 (CDMA2000 BTS application: 32) and is not available for modification.

Remote command:

[SENSe:​]CDPower:​SET:​COUNt


Set to Analyze

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Signal Capture (Data Acquisition) > Set to Analyze
Set to Analyze

Selects a specific set for further analysis. The value range is between 0 and "Number of Sets" – 1.

Remote command:

[SENSe:​]CDPower:​SET


Application Data (MSRA)

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Application Data (MSRA)
Application Data (MSRA)

For the CDMA2000 BTS application in MSRA operating mode, the application data range is defined by the same settings used to define the signal capturing in Signal and Spectrum Analyzer mode (see "Number of Sets").

In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the analysis interval for the CDMA2000 BTS measurement (see "Capture Offset").

The analysis interval cannot be edited manually, but is determined automatically according to the selected PCG, code or set to analyze which is defined for the evaluation range, depending on the result display. Note that the PCG/code/set is analyzed within the application data.


Synchronization

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Synchronization
Synchronization

The "Synchronization" button indicated in the Overview is not required for CDMA2000 measurements.


Channel Detection

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection
Channel Detection

The channel detection settings determine which channels are found in the input signal.

Contents
  • General Channel Detection Settings
  • Channel Table Management
  • Channel Table Settings and Functions
  • BTS Channel Details
  • MS Channel Details


General Channel Detection Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > General Channel Detection Settings
General Channel Detection Settings

Channel detection settings are configured in the "Channel Detection" dialog box which is displayed when you select the "Channel Detection" button in the configuration "Overview".

└ Inactive Channel Threshold
└ Using Predefined Channel Tables


Inactive Channel Threshold

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > General Channel Detection Settings > Inactive Channel Threshold
Inactive Channel Threshold

Defines the minimum power that a single channel must have compared to the total signal in order to be recognized as an active channel.

The default value is -60 dB. With this value all channels with signals such as the CDMA2000 test models are detected by the Code Domain Power analysis. Decrease the Inactive Channel Threshold value, if not all channels contained in the signal are detected.

Remote command:

[SENSe:​]CDPower:​ICTReshold


Using Predefined Channel Tables

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > General Channel Detection Settings > Using Predefined Channel Tables
Using Predefined Channel Tables

Defines the channel search mode.

"Predefined" | Compares the input signal to the predefined channel table selected in the "Predefined Tables" list
"Auto" | Detects channels automatically using pilot sequences and fixed code numbers The automatic search provides an overview of the channels contained in the currently measured signal. If channels are not detected as being active, change the "Inactive Channel Threshold" or select the "Predefined" channel search mode.
Remote command:

CONFigure:​CDPower[:​BTS]:​CTABle[:​STATe]


Channel Table Management

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Management
Channel Table Management

Channel tables are managed in the "Channel Detection" dialog box which is displayed when you select the "Channel Detection" button in the configuration "Overview".

└ Predefined Tables
└ Selecting a Table
└ Creating a New Table
└ Editing a Table
└ Copying a Table
└ Deleting a Table
└ Restoring Default Tables


Predefined Tables

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Management > Predefined Tables
Predefined Tables

The list shows all available channel tables and marks the currently used table with a checkmark. The currently focussed table is highlighted blue.

For details on predefined channel tables provided by the CDMA2000 applications see "Reference: Predefined Channel Tables".

The following channel tables are available by default:

"RECENT" | Contains the most recently selected channel table
"BPC_RC4, MPC_RC1, MPC_RC4, TDC_RC4" | Channel tables for BTS measurements; configured according to a specific radio configuration
"EACHOP, RCCCHOP, RTCHOP3, RTCHOP5" | Channel tables for MS mode; configured according to a specific radio configuration
Remote command:

CONFigure:​CDPower[:​BTS]:​CTABle:​CATalog?


Selecting a Table

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Management > Selecting a Table
Selecting a Table

Selects the channel table currently focussed in the "Predefined Tables" list and compares it to the measured signal to detect channels.

Remote command:

CONFigure:​CDPower[:​BTS]:​CTABle:​SELect


Creating a New Table

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Management > Creating a New Table
Creating a New Table

Creates a new channel table. For a description of channel table settings and functions see "Channel Table Settings and Functions".

For step-by-step instructions on creating a new channel table, see "To define or edit a channel table".

Remote command:

CONFigure:​CDPower[:​BTS]:​CTABle:​NAME


Editing a Table

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Management > Editing a Table
Editing a Table

You can edit existing channel table definitions. The details of the selected channel are displayed in the "Channel Table" dialog box.

See "BTS Channel Details" or "MS Channel Details".


Copying a Table

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Management > Copying a Table
Copying a Table

Copies an existing channel table definition. The details of the selected channel are displayed in the "Channel Table" dialog box.

See "BTS Channel Details" or "MS Channel Details".

Remote command:

CONFigure:​CDPower[:​BTS]:​CTABle:​COPY


Deleting a Table

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Management > Deleting a Table
Deleting a Table

Deletes the currently selected channel table after a message is confirmed.

Remote command:

CONFigure:​CDPower[:​BTS]:​CTABle:​DELete


Restoring Default Tables

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Management > Restoring Default Tables
Restoring Default Tables

Restores the predefined channel tables delivered with the instrument.

Remote command:

CONFigure:​CDPower[:​BTS]:​CTABle:​RESTore


Channel Table Settings and Functions

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions
Channel Table Settings and Functions

Some general settings and functions are available when configuring a predefined channel table.

Channel tables are configured in the "Channel Table" dialog box which is displayed when you select the "New", "Copy" or "Edit" buttons for a predefined channel table in the "Channel Detection" dialog box.

For details on channel table entries see "BTS Channel Details" or "MS Channel Details".

└ Name
└ Comment
└ Adding a Channel
└ Deleting a Channel
└ Creating a New Channel Table from the Measured Signal (Measure Table)
└ Sorting the Table
└ Cancelling the Configuration
└ Saving the Table


Name

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > Name
Name

Name of the channel table that will be displayed in the "Predefined Channel Tables" list.

Remote command:

CONFigure:​CDPower[:​BTS]:​CTABle:​NAME


Comment

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > Comment
Comment

Optional description of the channel table.

Remote command:

CONFigure:​CDPower[:​BTS]:​CTABle:​COMMent


Adding a Channel

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > Adding a Channel
Adding a Channel

Inserts a new row in the channel table to define another channel.


Deleting a Channel

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > Deleting a Channel
Deleting a Channel

Deletes the currently selected channel from the table.


Creating a New Channel Table from the Measured Signal (Measure Table)

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > Creating a New Channel Table from the Measured Signal (Measure Table)
Creating a New Channel Table from the Measured Signal (Measure Table)

Creates a completely new channel table according to the current measurement data.

Remote command:

CONFigure:​CDPower[:​BTS]:​MEASurement


Sorting the Table

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > Sorting the Table
Sorting the Table

Sorts the channel table entries.


Cancelling the Configuration

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > Cancelling the Configuration
Cancelling the Configuration

Closes the "Channel Table" dialog box without saving the changes.


Saving the Table

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > Channel Table Settings and Functions > Saving the Table
Saving the Table

Saves the changes to the table and closes the "Channel Table" dialog box.


BTS Channel Details

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > BTS Channel Details
BTS Channel Details

Channel details are configured in the "Channel Table" dialog box which is displayed when you select the "New", "Copy" or "Edit" buttons for a predefined channel table in the "Channel Detection" dialog box.

└ Channel Type
└ Channel Number (Ch. SF)
└ Symbol Rate
└ RC
└ Power
└ Status
└ Domain Conflict


Channel Type

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > BTS Channel Details > Channel Type
Channel Type

Type of channel according to CDMA2000 standard.

For a list of possible channel types see "BTS Channel Types" or "MS Channel Types".

Remote command:

BTS application:

CONFigure:​CDPower[:​BTS]:​CTABle:​DATA

MS application:

CONFigure:​CDPower[:​BTS]:​CTABle:​DATA


Channel Number (Ch. SF)

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > BTS Channel Details > Channel Number (Ch. SF)
Channel Number (Ch. SF)

Number of channel spreading code (0 to [spreading factor-1])

Remote command:

BTS application:

CONFigure:​CDPower[:​BTS]:​CTABle:​DATA

MS application:

CONFigure:​CDPower[:​BTS]:​CTABle:​DATA


Symbol Rate

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > BTS Channel Details > Symbol Rate
Symbol Rate

Symbol rate at which the channel is transmitted.


RC

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > BTS Channel Details > RC
RC

The Radio Configuration (RC) can be customized for two channel types. For the PDCH you can set the configuration to either 10 (QPSK), 10 (8PSK) or 10 (16QAM). For CHAN channels, you can set the radio configuration to 1-2 or 3-5.

For details on radio configurations see "Radio Configuration".


Power

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > BTS Channel Details > Power
Power

Contains the measured relative code domain power. The unit is dB. The fields are filled with values after you press the "Meas" button (see "Creating a New Channel Table from the Measured Signal (Measure Table)").

Remote command:

BTS application:

CONFigure:​CDPower[:​BTS]:​CTABle:​DATA

MS application:

CONFigure:​CDPower[:​BTS]:​CTABle:​DATA


Status

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > BTS Channel Details > Status
Status

Indicates the channel status. Codes that are not assigned are marked as inactive channels.

Remote command:

BTS application:

CONFigure:​CDPower[:​BTS]:​CTABle:​DATA

MS application:

CONFigure:​CDPower[:​BTS]:​CTABle:​DATA


Domain Conflict

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > BTS Channel Details > Domain Conflict
Domain Conflict

Indicates a code domain conflict between channel definitions (e.g. overlapping channels).


MS Channel Details

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > MS Channel Details
MS Channel Details

Channel details are configured in the "Channel Table" dialog box which is displayed when you select the "New", "Copy" or "Edit" buttons for a predefined channel table in the "Channel Detection" dialog box.

└ Channel Type
└ Channel Number (Ch. SF)
└ Symbol Rate
└ Mapping
└ Power
└ Status
└ Domain Conflict


Symbol Rate

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > MS Channel Details > Symbol Rate
Symbol Rate

Symbol rate at which the channel is transmitted.


Mapping

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > MS Channel Details > Mapping
Mapping

Branch onto which the channel is mapped (I or Q). The setting is not editable, since the standard specifies the channel assignment for each channel.

For more information see "Code Mapping and Branches".

Remote command:

[SENSe:​]CDPower:​MAPPing


Domain Conflict

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Channel Detection > MS Channel Details > Domain Conflict
Domain Conflict

Indicates a code domain conflict between channel definitions (e.g. overlapping channels).


Sweep Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Sweep Settings
Sweep Settings

The sweep settings define how the data is measured.

└ Sweep/Average Count
└ Continuous Sweep/RUN CONT
└ Single Sweep/ RUN SINGLE
└ Continue Single Sweep


Sweep/Average Count

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Sweep Settings > Sweep/Average Count
Sweep/Average Count

Defines the number of sweeps to be performed in the single sweep mode. Values from 0 to 200000 are allowed. If the values 0 or 1 are set, one sweep is performed.

The sweep count is applied to all the traces in all diagrams.

If the trace modes "Average", "Max Hold" or "Min Hold" are set, this value also determines the number of averaging or maximum search procedures.

In continuous sweep mode, if sweep count = 0 (default), averaging is performed over 10 sweeps. For sweep count =1, no averaging, maxhold or minhold operations are performed.

For more information see "How Much Data is Measured: Sweep Points and Sweep Count" .

Remote command:

[SENSe:​]SWEep:​COUNt

[SENSe:​]AVERage:​COUNt


Continuous Sweep/RUN CONT

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Sweep Settings > Continuous Sweep/RUN CONT
Continuous Sweep/RUN CONT

After triggering, starts the sweep and repeats it continuously until stopped. This is the default setting.

While the measurement is running, the "Continuous Sweep" softkey and the RUN CONT key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again. The results are not deleted until a new measurement is started.

Note: Sequencer. If the Sequencer is active, the "Continuous Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in continuous sweep mode is swept repeatedly.
Furthermore, the RUN CONT key controls the Sequencer, not individual sweeps. RUN CONT starts the Sequencer in continuous mode.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate:​CONTinuous


Single Sweep/ RUN SINGLE

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Sweep Settings > Single Sweep/ RUN SINGLE
Single Sweep/ RUN SINGLE

After triggering, starts the number of sweeps set in "Sweep Count". The measurement stops after the defined number of sweeps has been performed.

While the measurement is running, the "Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Note: Sequencer. If the Sequencer is active, the "Single Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in single sweep mode is swept only once by the Sequencer.
Furthermore, the RUN SINGLE key controls the Sequencer, not individual sweeps. RUN SINGLE starts the Sequencer in single mode.
If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate[:​IMMediate]


Continue Single Sweep

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Sweep Settings > Continue Single Sweep
Continue Single Sweep

After triggering, repeats the number of sweeps set in "Sweep Count", without deleting the trace of the last measurement.

While the measurement is running, the "Continue Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Remote command:

INITiate:​CONMeas


Automatic Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Automatic Settings
Automatic Settings

Some settings can be adjusted by the R&S FSW automatically according to the current measurement settings. In order to do so, a measurement is performed. The duration of this measurement can be defined automatically or manually.

To activate the automatic adjustment of a setting, select the corresponding function in the AUTO SET menu or in the configuration dialog box for the setting, where available.

MSRA operating mode

In MSRA operating mode, the following automatic settings are not available, as they require a new data acquisition. However, CDMA2000 applications cannot perform data acquisition in MSRA operating mode.

└ Adjusting all Determinable Settings Automatically (Auto All)
└ Setting the Reference Level Automatically (Auto Level)
└ Auto Scale Window
└ Auto Scale All
└ Restore Scale (Window)
└ Resetting the Automatic Measurement Time (Meastime Auto)
└ Changing the Automatic Measurement Time (Meastime Manual)
└ Upper Level Hysteresis
└ Lower Level Hysteresis


Adjusting all Determinable Settings Automatically (Auto All)

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Automatic Settings > Adjusting all Determinable Settings Automatically (Auto All)
Adjusting all Determinable Settings Automatically (Auto All)

Activates all automatic adjustment functions for the current measurement settings.

This includes:

  • Auto Level
  • "Auto Scale All"

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​ALL


Auto Scale Window

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Automatic Settings > Auto Scale Window
Auto Scale Window

Automatically determines the optimal range and reference level position to be displayed for the current measurement settings in the currently selected window. No new measurement is performed.


Auto Scale All

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Automatic Settings > Auto Scale All
Auto Scale All

Automatically determines the optimal range and reference level position to be displayed for the current measurement settings in all displayed diagrams. No new measurement is performed.


Resetting the Automatic Measurement Time (Meastime Auto)

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Automatic Settings > Resetting the Automatic Measurement Time (Meastime Auto)
Resetting the Automatic Measurement Time (Meastime Auto)

Resets the measurement duration for automatic settings to the default value.

For details see "Adjusting Settings Automatically" .

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE


Changing the Automatic Measurement Time (Meastime Manual)

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Automatic Settings > Changing the Automatic Measurement Time (Meastime Manual)
Changing the Automatic Measurement Time (Meastime Manual)

This function allows you to change the measurement duration for automatic setting adjustments. Enter the value in seconds.

For details see "Adjusting Settings Automatically" .

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE

[SENSe:​]ADJust:​CONFigure:​DURation


Upper Level Hysteresis

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Automatic Settings > Upper Level Hysteresis
Upper Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​UPPer


Lower Level Hysteresis

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Automatic Settings > Lower Level Hysteresis
Lower Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​LOWer


BW, Span, Lines and Marker Function Menus

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > BW, Span, Lines and Marker Function Menus
BW, Span, Lines and Marker Function Menus

The "Span", "Bandwidth", "Lines"and "Marker Function" menus are disabled for CDA measurements.


Zoom Functions

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Zoom Functions
Zoom Functions

The zoom functions are only available from the toolbar.

For details on the zoom functions see "Single Zoom Versus Multiple Zoom" .

└ Single Zoom
└ Multiple Zoom
└ Restore Original Display
└ Deactivating Zoom (Selection mode)


Single Zoom

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Zoom Functions > Single Zoom
Single Zoom

A single zoom replaces the current diagram by a new diagram which displays an enlarged extract of the trace. This function can be used repetitively until the required details are visible.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​AREA


Multiple Zoom

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Zoom Functions > Multiple Zoom
Multiple Zoom

In multiple zoom mode, you can enlarge several different areas of the trace simultaneously. An overview window indicates the zoom areas in the original trace, while the zoomed trace areas are displayed in individual windows. The zoom area that corresponds to the individual zoom display is indicated in the lower right corner, between the scrollbars.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​AREA


Restore Original Display

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Zoom Functions > Restore Original Display
Restore Original Display

Restores the original display and closes all zoom windows.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


Deactivating Zoom (Selection mode)

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > Code Domain Analysis > Zoom Functions > Deactivating Zoom (Selection mode)
Deactivating Zoom (Selection mode)

Deactivates zoom mode.

Tapping the screen no longer invokes a zoom, but selects an object.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


RF Measurements

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > RF Measurements
RF Measurements

CDMA2000 measurements require a special application on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Applications and Operating Modes" .

When you activate a CDMA2000 application, Code Domain Analysis of the input signal is started automatically. However, the CDMA2000 applications also provide various RF measurement types.

Selecting the measurement type
►

To seler konnte sich ect an RF measurement type, do one of the following:

  • Select the "Overview" softkey. In the "Overview", select the "Select Measurement" button. Select the required measurement.
  • Press the MEAS key on the front panel. In the "Select Measurement" dialog box, select the required measurement.

Some parameters are set automatically according to the CDMA2000 standard the first time a measurement is selected (since the last PRESET operation). A list of these parameters is given with each measurement type. The parameters can be changed, but are not reset automatically the next time you re-enter the measurement.

The main measurement configuration menus for the RF measurements are identical to the Spectrum application.

For details refer to "Common Measurement Settings" .

The measurement-specific settings for the following measurements are available via the "Overview".

Contents
  • Signal Channel Power Measurements
  • Channel Power (ACLR) Measurements
  • Spectrum Emission Mask
  • Occupied Bandwidth
  • CCDF


Signal Channel Power Measurements

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > RF Measurements > Signal Channel Power Measurements
Signal Channel Power Measurements

The Power measurement determines the CDMA2000 signal channel power.

To do so, the RF signal power of a single channel is analyzed with 1.2288 MHz bandwidth over a single trace. The displayed results are based on the root mean square. The bandwidth and the associated channel power are displayed in the Result Summary.

In order to determine the signal channel power, the CDMA2000 application performs a Channel Power measurement as in the Spectrum application with the following settings:

Predefined settings for CDMA2000 Output Channel Power measurements
Setting | Default Value
ACLR Standard | CDMA2000 MC1
Number of adjacent channels | 0
Frequency Span | 2 MHz

For further details about the Power measurement refer to "Channel Power and Adjacent-Channel Power (ACLR) Measurement" .


Channel Power (ACLR) Measurements

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > RF Measurements > Channel Power (ACLR) Measurements
Channel Power (ACLR) Measurements

The Adjacent Channel Power measurement analyzes the power of the Tx channel and the power of adjacent and alternate channels on the left and right side of the Tx channel. The number of Tx channels and adjacent channels can be modified as well as the band class. The bandwidth and power of the Tx channel and the bandwidth, spacing and power of the adjacent and alternate channels are displayed in the Result Summary.

Channel Power ACLR measurements are performed as in the Spectrum application with the following predefined settings according to CDMA2000 specifications (adjacent channel leakage ratio).

Predefined settings for CDMA2000 ACLR Channel Power measurements
Setting | Default value
Bandclass | 0: 800 MHz Cellular
Number of adjacent channels | 2

For further details about the Power measurement refer to "Channel Power and Adjacent-Channel Power (ACLR) Measurement" .

To restore adapted measurement parameters, the following parameters are saved on exiting and are restored on re-entering this measurement:
  • Reference level and reference level offset
  • RBW, VBW
  • Sweep time
  • Span
  • Number of adjacent channels
  • Fast ACLR mode

The main measurement menus for the RF measurements are identical to the Spectrum application. However, for ACLR and SEM measurements in CDMA2000 applications, an additional softkey is available to select the required bandclass.

└ Bandclass


Bandclass

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > RF Measurements > Channel Power (ACLR) Measurements > Bandclass
Bandclass

The bandclass defines the frequency band used for ACLR and SEM measurements. It also determines the corresponding limits and ACLR channel settings according to the CDMA2000 standard.

For an overview of supported bandclasses and their usage see "Reference: Supported Bandclasses".

Remote command:

CONFigure:​CDPower[:​BTS]:​BCLass|BANDclass


Spectrum Emission Mask

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > RF Measurements > Spectrum Emission Mask
Spectrum Emission Mask

The Spectrum Emission Mask measurement shows the quality of the measured signal by comparing the power values in the frequency range near the carrier against a spectral mask that is defined by the CDMA2000 specifications. The limits depend on the selected bandclass. In this way, the performance of the DUT can be tested and the emissions and their distance to the limit be identified.

Note that the CDMA2000 standard does not distinguish between spurious and spectral emissions.

The Result Summary contains a peak list with the values for the largest spectral emissions including their frequency and power.

The CDMA2000 applications perform the SEM measurement as in the Spectrum application with the following settings:

Predefined settings for CDMA2000 SEM measurements
Bandclass | 0: 800 MHz Cellular
Span | -4 MHz to +1.98 MHz
Number of ranges | 5
Fast SEM | ON
Sweep time | 100 ms
Number of power classes | 3
Power reference type | Channel power

For further details about the Spectrum Emission Mask measurements refer to "Spectrum Emission Mask (SEM) Measurement" .

Changing the RBW and the VBW is restricted due to the definition of the limits by the standard.

To restore adapted measurement parameters, the following parameters are saved on exiting and are restored on re-entering this measurement:
  • Reference level and reference level offset
  • Sweep time
  • Span

The main measurement menus for the RF measurements are identical to the Spectrum application. However, for ACLR and SEM measurements, an additional softkey is available to select the required bandclass.

└ Bandclass


Bandclass

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > RF Measurements > Spectrum Emission Mask > Bandclass
Bandclass

The bandclass defines the frequency band used for ACLR and SEM measurements. It also determines the corresponding limits and ACLR channel settings according to the CDMA2000 standard.

For an overview of supported bandclasses and their usage see "Reference: Supported Bandclasses".

Remote command:

CONFigure:​CDPower[:​BTS]:​BCLass|BANDclass


Occupied Bandwidth

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > RF Measurements > Occupied Bandwidth
Occupied Bandwidth

The Occupied Bandwidth measurement is performed as in the Spectrum application with default settings.

Predefined settings for CDMA2000 OBW measurements
Setting | Default value
% Power Bandwidth | 99 %
Channel bandwidth | 1.2288 MHz

The Occupied Bandwidth measurement determines the bandwidth that the signal occupies. The occupied bandwidth is defined as the bandwidth in which – in default settings - 99 % of the total signal power is to be found. The percentage of the signal power to be included in the bandwidth measurement can be changed.

For further details about the Occupied Bandwidth measurements refer to "Occupied Bandwidth Measurement (OBW)" .

To restore adapted measurement parameters, the following parameters are saved on exiting and are restored on re-entering this measurement:
  • Reference level and reference level offset
  • RBW, VBW
  • Sweep time
  • Span


CCDF

cdma2000 Measurements (R&S FSW-K82/-K83) > Configuration > RF Measurements > CCDF
CCDF

The CCDF measurement determines the distribution of the signal amplitudes (complementary cumulative distribution function). The CCDF and the Crest factor are displayed. For the purposes of this measurement, a signal section of user-definable length is recorded continuously in zero span, and the distribution of the signal amplitudes is evaluated.

The measurement is useful to determine errors of linear amplifiers. The crest factor is defined as the ratio of the peak power and the mean power. The Result Summary displays the number of included samples, the mean and peak power and the crest factor.

The CCDF measurement is performed as in the Spectrum application with the following settings:

Predefined settings for CDMA2000 CCDF measurements
CCDF | Active on trace 1
Analysis bandwidth | 10 MHz
Number of samples | 62500
VBW | 5 MHz

For further details about the CCDF measurements refer to "Statistical Measurements (APD, CCDF)" .

To restore adapted measurement parameters, the following parameters are saved on exiting and are restored on re-entering this measurement:
  • Reference level and reference level offset
  • Analysis bandwidth
  • Number of samples


Analysis

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis
Analysis

General result analysis settings concerning the evaluation range, trace, markers, etc. can be configured via the "Analysis" button in the "Overview".

The remote commands required to perform these tasks are described in "General Analysis".

Analyzing RF Measurements

General result analysis settings concerning the trace, markers, lines etc. for RF measurements are identical to the analysis functions in the Spectrum application except for some special marker functions and spectrograms, which are not available in the CDMA2000 applications.

See
  • "Common Analysis and Display Functions"
  • "Analyzing Measurements (Basics)"
Contents
  • Code Domain Analysis Settings
  • Evaluation Range
  • Traces
  • Markers


Code Domain Analysis Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Code Domain Analysis Settings
Code Domain Analysis Settings

Some evaluations provide further settings for the results. The settings for CDA measurements are described here.

└ Base Spreading Factor
└ Compensate IQ Offset
└ Timing and phase offset calculation
└ Code Power Display
└ Pilot Power Display (MS application only)
└ Power Reference
└ Code Display Order


Base Spreading Factor

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Code Domain Analysis Settings > Base Spreading Factor
Base Spreading Factor

Changes the base spreading factor, which also changes the scale for code-based result displays. If you set the base spreading factor too low (e.g. to 64 for channels with a base spreading factor of 128 = code class 7), an alias power is displayed in the Code Domain Power and Code Domain Error Power diagrams.

For more information see "Code Display and Sort Order".

Remote command:

[SENSe:​]CDPower:​SFACtor


Compensate IQ Offset

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Code Domain Analysis Settings > Compensate IQ Offset
Compensate IQ Offset

If enabled, the I/Q offset is eliminated from the measured signal. This is useful to deduct a DC offset to the baseband caused by the DUT, thus improving the EVM. Note, however, that for EVM measurements according to standard, compensation must be disabled.

Remote command:

[SENSe:​]CDPower:​NORMalize


Timing and phase offset calculation

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Code Domain Analysis Settings > Timing and phase offset calculation
Timing and phase offset calculation

Activates or deactivates the timing and phase offset calculation of the channels to the pilot channel. If deactivated, or if more than 50 active channels are in the signal, the calculation does not take place and dashes are displayed instead of values as results.

Remote command:

[SENSe:​]CDPower:​TPMeas


Code Power Display

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Code Domain Analysis Settings > Code Power Display
Code Power Display

For "Code Domain Power" evaluation:

Defines whether the absolute power or the power relative to the chosen reference (in BTS application: relative to total power) is displayed.

Remote command:

[SENSe:​]CDPower:​PDISplay


Pilot Power Display (MS application only)

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Code Domain Analysis Settings > Pilot Power Display (MS application only)
Pilot Power Display (MS application only)

For "Code Domain Power" evaluation in the MS application only:

Defines whether the absolute power or the power relative to the chosen reference is displayed for the pilot channel.

Remote command:

[SENSe:​]CDPower:​PPReference


Power Reference

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Code Domain Analysis Settings > Power Reference
Power Reference

For "Code Domain Power" evaluation in the MS application only:

Defines the reference for relative power display.

Note: In the BTS application, relative powers are always in relation to the total signal power.

"Total" | Relative to the total signal power
"PICH" | Relative to the power of the PICH
Remote command:

[SENSe:​]CDPower:​PREFerence


Code Display Order

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Code Domain Analysis Settings > Code Display Order
Code Display Order

Defines the sorting of the channels for the Code Domain Power and Code Domain Error result displays.

For further details on the code order refer to "Code Display and Sort Order" and "Reference: Code Tables".

"Hadamard" | By default, the codes are sorted in Hadamard order, i.e. in ascending order. The power of each code is displayed; there is no visible distinction between channels. If a channel covers several codes, the display shows the individual power of each code.
"Bit-Reverse" | Bundles the channels with concentrated codes, i.e. all codes of a channel are next to one another. Thus you can see the total power of a concentrated channel.
Remote command:

[SENSe:​]CDPower:​ORDer


Evaluation Range

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Evaluation Range
Evaluation Range

The evaluation range defines which channel (Code Number), PCG or set is analyzed in the result display.

For CDMA2000 MS measurements, the branch to be analyzed can also be defined.

└ Code Number
└ Power Control Group
└ Set to Analyze
└ Branch (MS application only)


Code Number

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Evaluation Range > Code Number
Code Number

Selects a code for the following evaluations (see also "Evaluation Methods for Code Domain Analysis"):

  • Bitstream
  • Code Domain Power
  • Code Domain Error Power
  • Peak Code Domain Error
  • Power vs PCG
  • Power vs Symbol
  • Result Summary
  • Symbol Constellation
  • Symbol EVM

The specified code is selected and marked in red.

For details on how specific codes are displayed see "Code Display and Sort Order".

Remote command:

[SENSe:​]CDPower:​CODE


Power Control Group

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Evaluation Range > Power Control Group
Power Control Group

Selects a PCG for the following evaluations:

(See also "Evaluation Methods for Code Domain Analysis")

  • Bitstream
  • Channel Table
  • Code Domain Error Power
  • Code Domain Power
  • Composite Constellation
  • Peak Code Domain Error
  • Power vs PCG
  • Power vs Symbol
  • Result Summary
  • Symbol Constellation
  • Symbol EVM
Remote command:

[SENSe:​]CDPower:​SLOT


Set to Analyze

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Evaluation Range > Set to Analyze
Set to Analyze

Selects a specific set for further analysis. The value range is between 0 and "Number of Sets" – 1.

Remote command:

[SENSe:​]CDPower:​SET


Branch (MS application only)

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Evaluation Range > Branch (MS application only)
Branch (MS application only)

Switches between the evaluation of the I and the Q branch in MS measurements.

This affects the following evaluations:

(See also "Evaluation Methods for Code Domain Analysis")

  • Code Domain Power
  • Code Domain Error Power
  • Peak Code Domain Error
  • Power vs PCG
  • Result Summary
Remote command:

[SENSe:​]CDPower:​MAPPing


Traces

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Traces
Traces

The trace settings determine how the measured data is analyzed and displayed on the screen.

In CDA evaluations, only one trace can be active in each diagram at any time.

Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box.

└ Trace Mode


Trace Mode

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Traces > Trace Mode
Trace Mode

Defines the update mode for subsequent traces.

For details see "Analyzing Several Traces - Trace Mode" .

"Clear Write" | Overwrite mode: the trace is overwritten by each sweep. This is the default setting.
"Max Hold" | The maximum value is determined over several sweeps and displayed. The R&S FSW saves each trace point in the trace memory only if the new value is greater than the previous one.
"Min Hold" | The minimum value is determined from several measurements and displayed. The R&S FSW saves each trace point in the trace memory only if the new value is lower than the previous one.
"Average" | The average is formed over several sweeps. The "Sweep/Average Count" determines the number of averaging procedures.
"View" | The current contents of the trace memory are frozen and displayed.
"Blank" | Removes the selected trace from the display.
Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE


Markers

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers
Markers

Markers help you analyze your measurement results by determining particular values in the diagram. Thus you can extract numeric values from a graphical display.

Markers are configured in the "Marker" dialog box which is displayed when you do one of the following:

  • In the "Overview", select "Analysis", and switch to the vertical "Marker" tab.
  • Press the MKR key, then select the "Marker Config" softkey.
Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box.

Markers in Code Domain Analysis measurements

In Code Domain Analysis measurements, the markers are set to individual symbols, codes, slots or channels, depending on the result display. Thus you can use the markers to identify individual codes, for example.

Contents
  • Individual Marker Settings
  • General Marker Settings
  • Marker Search Settings
  • Marker Positioning Functions


Individual Marker Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > Individual Marker Settings
Individual Marker Settings

In CDA evaluations, up to 4 markers can be activated in each diagram at any time.

└ Marker 1 / Marker 2 / Marker 3 / Marker 4
└ Selected Marker
└ Marker State
└ X-value
└ Marker Type
└ All Markers Off


Marker 1 / Marker 2 / Marker 3 / Marker 4

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > Individual Marker Settings > Marker 1 / Marker 2 / Marker 3 / Marker 4
Marker 1 / Marker 2 / Marker 3 / Marker 4

The "Marker X" softkey activates the corresponding marker and opens an edit dialog box to enter the marker position ("X-value"). Pressing the softkey again deactivates the selected marker.

Marker 1 is always the default reference marker for relative measurements. If activated, markers 2 to 4 are delta markers that refer to marker 1. These markers can be converted into markers with absolute value display using the "Marker Type" function.

If normal marker 1 is the active marker, pressing the "Mkr Type" softkey switches on an additional delta marker 1.

Several markers can be configured very easily using the "Marker" dialog box, see "Marker Settings" .

Note: For Code Domain Analysis the marker position moves from one slot (PCG) / channel / code / symbol to the next, depending on the current evaluation.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?

CALCulate<n>:​DELTamarker<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>:​X

CALCulate<n>:​DELTamarker<m>:​X:​RELative?

CALCulate<n>:​DELTamarker<m>:​Y?


Selected Marker

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > Individual Marker Settings > Selected Marker
Selected Marker

Marker name. The marker which is currently selected for editing is highlighted orange.

Remote command:

Marker selected via suffix <m> in remote commands.


Marker State

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > Individual Marker Settings > Marker State
Marker State

Activates or deactivates the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


X-value

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > Individual Marker Settings > X-value
X-value

Defines the position of the marker on the x-axis (channel, slot, symbol, depending on evaluation).

Remote command:

CALCulate<n>:​DELTamarker<m>:​X

CALCulate<n>:​MARKer<m>:​X


Marker Type

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > Individual Marker Settings > Marker Type
Marker Type

Toggles the marker type.

The type for marker 1 is always "Normal", the type for delta marker 1 is always "Delta". These types cannot be changed.

Note: If normal marker 1 is the active marker, switching the "Mkr Type" activates an additional delta marker 1. For any other marker, switching the marker type does not activate an additional marker, it only switches the type of the selected marker.

"Normal" | A normal marker indicates the absolute value at the defined position in the diagram.
"Delta" | A delta marker defines the value of the marker relative to the specified reference marker (marker 1 by default).
Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


All Markers Off

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > Individual Marker Settings > All Markers Off
All Markers Off

Deactivates all markers in one step.

Remote command:

CALCulate<n>:​MARKer<m>:​AOFF


General Marker Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > General Marker Settings
General Marker Settings

General marker settings are defined in the "Marker Config" tab of the "Marker" dialog box.

└ Marker Table Display


Marker Table Display

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > General Marker Settings > Marker Table Display
Marker Table Display

Defines how the marker information is displayed.

For more details see "Marker Results" .

"On" | Displays the marker information in a table in a separate area beneath the diagram.
"Off" | Displays the marker information within the diagram area.
"Auto" | (Default) Up to two markers are displayed in the diagram area. If more markers are active, the marker table is displayed automatically.
Remote command:

DISPlay:​MTABle


Marker Search Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > Marker Search Settings
Marker Search Settings

Several functions are available to set the marker to a specific position very quickly and easily. In order to determine the required marker position, searches may be performed. The search results can be influenced by special settings.

These settings are available as softkeys in the "Marker To" menu, or in the "Search" tab of the "Marker" dialog box. To display this tab, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey. Then select the horizontal "Search" tab.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Config" tab. Then select the horizontal "Search" tab.
└ Search Mode for Next Peak


Search Mode for Next Peak

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > Marker Search Settings > Search Mode for Next Peak
Search Mode for Next Peak

Selects the search mode for the next peak search.

"Left" | Determines the next maximum/minimum to the left of the current peak.
"Absolute" | Determines the next maximum/minimum to either side of the current peak.
"Right" | Determines the next maximum/minimum to the right of the current peak.
Remote command:

CALCulate<n>:​DELTamarker<m>:​MAXimum:​LEFT

CALCulate<n>:​MARKer<m>:​MAXimum:​LEFT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MAXimum:​RIGHt

CALCulate<n>:​DELTamarker<m>:​MINimum:​LEFT

CALCulate<n>:​MARKer<m>:​MINimum:​LEFT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MINimum:​RIGHt


Marker Positioning Functions

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > Marker Positioning Functions
Marker Positioning Functions

The following functions set the currently selected marker to the result of a peak search. These functions are available as softkeys in the "Marker To" menu, which is displayed when you press the MKR -> key.

Markers in Code Domain Analysis measurements

In Code Domain Analysis measurements, the markers are set to individual symbols, codes, slots or channels, depending on the result display. Thus you can use the markers to identify individual codes, for example.

└ Select Marker
└ Search Next Peak
└ Search Next Minimum
└ Peak Search
└ Search Minimum
└ Marker To PICH
└ Marker To TDPICH


Select Marker

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > Marker Positioning Functions > Select Marker
Select Marker

Selects the subsequent marker (marker 1/2/3/4 or delta marker) to be edited or to be used for a marker function. The currently selected marker number is highlighted.

Remote command:

Marker selected via suffix <m> in remote commands.


Search Next Peak

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > Marker Positioning Functions > Search Next Peak
Search Next Peak

Sets the selected marker/delta marker to the next (lower) maximum of the assigned trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT


Search Next Minimum

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > Marker Positioning Functions > Search Next Minimum
Search Next Minimum

Sets the selected marker/delta marker to the next (higher) minimum of the selected trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT


Peak Search

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > Marker Positioning Functions > Peak Search
Peak Search

Sets the selected marker/delta marker to the maximum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MAXimum[:​PEAK]


Search Minimum

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > Marker Positioning Functions > Search Minimum
Search Minimum

Sets the selected marker/delta marker to the minimum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MINimum[:​PEAK]


Marker To PICH

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > Marker Positioning Functions > Marker To PICH
Marker To PICH

Sets the marker to the PICH channel.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​PICH


Marker To TDPICH

cdma2000 Measurements (R&S FSW-K82/-K83) > Analysis > Markers > Marker Positioning Functions > Marker To TDPICH
Marker To TDPICH

Sets the marker to the TDPICH channel.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​TDPIch


Optimizing and Troubleshooting the Measurement

cdma2000 Measurements (R&S FSW-K82/-K83) > Optimizing and Troubleshooting the Measurement
Optimizing and Troubleshooting the Measurement

If the results do not meet your expectations, try the following methods to optimize the measurement:

Synchronization fails:
  • Check the center frequency.
  • Perform an automatic reference level adjustment.
  • In BTS measurements, when using an external trigger, check whether an external trigger signal is being sent to the R&S FSW and check the "PN offset".
  • In MS measurements, check the "Long Code Mask" and "Long Code Offset".
  • Make sure "Invert Q" is off.
Contents
  • Error Messages


Error Messages

cdma2000 Measurements (R&S FSW-K82/-K83) > Optimizing and Troubleshooting the Measurement > Error Messages
Error Messages

Error messages are entered in the error/event queue of the status reporting system in the remote control mode and can be queried with the command SYSTem:ERRor?.

A short explanation of the application-specific error messages for CDMA2000 measurements is given below.

Status bar message | Description
Sync not found | This message is displayed if synchronization is not possible. Possible causes are that frequency, level, or signal description values are set incorrectly, or the input signal is invalid.
Sync OK | This message is displayed if synchronization is possible.


How to Perform Measurements in CDMA2000 Applications

cdma2000 Measurements (R&S FSW-K82/-K83) > How to Perform Measurements in CDMA2000 Applications
How to Perform Measurements in CDMA2000 Applications

The following step-by-step instructions describe how to perform measurements with the CDMA2000 applications.

To perform Code Domain Analysis

  1. Press the MODE key on the front panel and select the "cdma2000 BTS" application for base station tests, or "cdma2000 MS" for mobile station tests.

    Code Domain Analysis of the input signal is performed by default.

  2. Select the "Overview" softkey to display the "Overview" for Code Domain Analysis.

  3. Select the "Signal Description" button and configure the expected input signal.

  4. Select the "Input/Frontend" button and then the "Frequency" tab to define the input signal's center frequency.

  5. Optionally, select the "Trigger" button and define a trigger for data acquisition, for example an external trigger to start capturing data only when a useful signal is transmitted.

  6. Select the "Signal Capture" button and define the acquisition parameters for the input signal.

    In MSRA mode, define the application data instead, see "To select the application data for MSRA measurements".

  7. Select the "Channel Detection" button and define how the individual channels are detected within the input signal. If necessary, define a channel table as described in "To define or edit a channel table".

  8. Select the "Display Config" button and select the evaluation methods that are of interest to you.

    Arrange them on the display to suit your preferences.

  9. Exit the SmartGrid mode and select the "Overview" softkey to display the "Overview" again.

  10. Select the "Analysis" button in the "Overview" to configure how the data is evaluated in the individual result displays.

    • Select the set, PCG/slot or code to be evaluated.
    • Configure specific settings for the selected evaluation method(s).
    • Optionally, configure the trace to display the average over a series of sweeps. If necessary, increase the "Sweep/Average Count" in the "Sweep Config" dialog box.
    • Configure markers and delta markers to determine deviations and offsets within the results, e.g. when comparing errors or peaks.

  11. Start a new sweep with the defined settings.

    In MSRA mode you may want to stop the continuous measurement mode by the Sequencer and perform a single data acquisition:

    1. Select the Sequencer icon ( [image]) from the toolbar.

    2. Set the Sequencer state to "OFF".

    3. Press the RUN SINGLE key.

To define or edit a channel table

Channel tables contain a list of channels to be detected and their specific parameters. You can create user-defined and edit pre-defined channel tables.

  1. From the main "Code Domain Analyzer" menu, select the "Channel Detection" softkey to open the "Channel Detection" dialog box.

  2. To define a new channel table, select the "New" button next to the "Predefined Tables" list.

    To edit an existing channel table:

    1. Select the existing channel table in the "Predefined Tables" list.

    2. Select the "Edit" button next to the "Predefined Tables" list.

  3. In the "Channel Table" dialog box, define a name and, optionally, a comment that describes the channel table. The comment is displayed when you set the focus on the table in the "Predefined Tables" list.

  4. Define the channels to be detected using one of the following methods:

    Select the "Measure Table" button to create a table that consists of the channels detected in the currently measured signal.

    Or:

    1. Select the "Add Channel" button to insert a row for a new channel below the currently selected row in the channel table.

    2. Define the channel specifications required for detection:

      • Channel type
      • Channel number and spreading factor used by the channel
      • Symbol rate
      • Which RC is used
        (BTS mode only)
      • Which mapping is applied (MS mode only)
      • The channel's code domain power (relative to the total signal power)
      • The channel's state (active or inactive)

  5. Select the "Save Table" button to store the channel table.

    The table is stored and the dialog box is closed. The new channel table is included in the "Predefined Tables" list in the "Channel Detection" dialog box.

  6. To activate the use of the new channel table:

    1. Select the table in the "Predefined Tables" list.

    2. Select the "Select" button.

      A checkmark is displayed next to the selected table.

    3. Toggle the "Use Predefined Channel Table" setting to "Predefined".

    4. Toggle the "Compare Meas Signal with Predefined Table" setting to "On".

    5. Start a new measurement.

To perform an RF measurement

  1. Press the MODE key on the front panel and select the "cdma2000 BTS" application for base station tests, or "cdma2000 MS" for mobile station tests.

    Code Domain Analysis of the input signal is performed by default.

  2. Select the RF measurement:

    1. Press the MEAS key on the front panel.

    2. In the "Select Measurement" dialog box, select the required measurement.

    The selected measurement is activated with the default settings for CDMA2000 immediately.

  3. If necessary, adapt the settings as described for the individual measurements in "Measurements" .

  4. Select the "Display Config" button and select the evaluation methods that are of interest to you.

    Arrange them on the display to suit your preferences.

  5. Exit the SmartGrid mode and select the "Overview" softkey to display the "Overview" again.

  6. Select the "Analysis" button in the "Overview" to make use of the advanced analysis functions in the result displays.

    • Configure a trace to display the average over a series of sweeps; if necessary, increase the "Sweep Count" in the "Sweep" settings.
    • Configure markers and delta markers to determine deviations and offsets within the evaluated signal.
    • Use special marker functions to calculate noise or a peak list.
    • Configure a limit check to detect excessive deviations.

  7. Optionally, export the trace data of the graphical evaluation results to a file.

    1. In the "Traces" tab of the "Analysis" dialog box, switch to the "Trace Export" tab.

    2. Select "Export Trace to ASCII File".

    3. Define a file name and storage location and select "OK".

To select the application data for MSRA measurements

In multi-standard radio analysis you can analyze the data captured by the MSRA Master in the CDMA2000 BTS application. Assuming you have detected a suspect area of the captured data in another application, you would now like to analyze the same data in the CDMA2000 BTS application.

  1. Select the "Overview" softkey to display the "Overview" for Code Domain Analysis.

  2. Select the "Signal Capture" button.

  3. Define the application data range as and the "Number of Sets". You must determine the number of sets according to the following formula:

    <No of sets> = <measurement time in seconds> / 80 ms (time per set)

    Enter the next larger integer value.

  4. Define the starting point of the application data as the "Capture offset". The offset is calculated according to the following formula:

    <capture offset> = <starting point for application> - <starting point in capture buffer>

  5. The analysis interval is automatically determined according to the selected channel, slot or frame to analyze (defined for the evaluation range), depending on the result display. Note that the frame/slot/channel is analyzed within the application data. If the analysis interval does not yet show the required area of the capture buffer, move through the frames/slots/channels in the evaluation range or correct the application data range.

  6. If the Sequencer is off, select the "Refresh" softkey in the "Sweep" menu to update the result displays for the changed application data.


Measurement Examples

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Examples
Measurement Examples

The following measurement examples demonstrate the basic Code Domain Analysis functions for the CDMA2000 standard. These examples assume a basic test setup as described in "Test Setup for CDMA2000 Tests".

The following measurement examples are basic CDMA2000 base station tests using a setup with a signal generator, e.g. an R&S SMU. They are meant to demonstrate how operating and measurement errors can be avoided using correct settings. The measurements are performed on a CDMA2000 signal with an R&S FSW equipped with the CDMA2000 BTS application.

Measurement examples for mobile station tests

The measurements can be performed for mobile station tests in a similar way with the CDMA2000 MS application. In this case, use the following settings:

  • "DIGITAL STD > LINK DIRECTION > UP/REVERSE"
  • "FREQ" = 833.49GHz

The measurements are performed using the following devices and accessories:

  • The R&S FSW with Application Firmware R&S FSW-K82: CDMA2000 Base Station Test
  • The Vector Signal Generator R&S SMU with option R&S SMU-B46: digital standard CDMA2000 (options R&S SMU-B20 and R&S SMU-B11 required)
  • 1 coaxial cable, 50Ω, approx. 1 m, N connector
  • 1 coaxial cable, 50Ω, approx. 1 m, BNC connector

The following measurements are described:

Contents
  • Meas 1: Measuring the Signal Channel Power
  • Meas 2: Measuring the Spectrum Emission Mask
  • Meas 3: Measuring the Relative Code Domain Power and Frequency Error
  • Meas 4: Measuring the Triggered Relative Code Domain Power
  • Meas 5: Measuring the Composite EVM
  • Meas 6: Measuring the Peak Code Domain Error and the RHO Factor


Meas 1: Measuring the Signal Channel Power

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Examples > Meas 1: Measuring the Signal Channel Power
Meas 1: Measuring the Signal Channel Power

In the Power measurement, the total channel power of the CDMA2000 signal is displayed. The measurement also displays spurious emissions like harmonics or intermodulation products that occur close to the carrier.

Test setup
►

Connect the RF output of the R&S SMU to the RF input of the R&S FSW (coaxial cable with N connectors).

Settings on the R&S SMU

  1. PRESET

  2. "FREQ" = 878.49 MHz

  3. "LEVEL"= 0 dBm

  4. "DIGITAL STD" = "cdma2000"

  5. "DIGITAL STD > Set Default"

  6. "DIGITAL STD > LINK DIRECTION > DOWN/FORWARD"

  7. "DIGITAL STD > cdma2000 > STATE"= "ON"

Settings on the R&S FSW

  1. PRESET

  2. "MODE > cdma2000 BTS"

  3. "AMPT > Reference level"= 0 dBm

  4. "FREQ > Center frequency" = 878.49 MHz

  5. "MEAS > POWER"

    The spectrum of the signal and the corresponding power levels within the 1.2288 MHz channel bandwidth are displayed.


Meas 2: Measuring the Spectrum Emission Mask

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Examples > Meas 2: Measuring the Spectrum Emission Mask
Meas 2: Measuring the Spectrum Emission Mask

The CDMA2000 specification calls for a measurement that monitors compliance with a spectral mask over a range of at least ±4.0 MHz around the CDMA2000 carrier. To assess the power emissions within the specified range, the signal power is measured with a 30kHz filter. The resulting trace is compared with a limit line as defined in the CDMA2000 standard. The limit lines are automatically selected as a function of the used band class.

Test setup
►

Connect the RF output of the R&S SMU to the RF input of the R&S FSW (coaxial cable with N connectors).

Settings on the R&S SMU

  1. PRESET

  2. "FREQ" = 878.49 MHz

  3. "LEVEL"= 0 dBm

  4. "DIGITAL STD" = "cdma2000"

  5. "DIGITAL STD > Set Default"

  6. "DIGITAL STD > LINK DIRECTION > DOWN/FORWARD"

  7. "DIGITAL STD > cdma2000 > STATE"= "ON"

Settings on the R&S FSW

  1. PRESET

  2. "MODE > cdma2000 BTS"

  3. "AMPT > Reference level"= 0 dBm

  4. "FREQ > Center frequency" = 878.49 MHz

  5. "MEAS > Spectrum Emission Mask"

    The spectrum of the signal is displayed, including the limit line defined in the standard. To understand where and about how much the measurement has failed, the "List Evaluation" shows the frequencies where spurious emissions occur.


Meas 3: Measuring the Relative Code Domain Power and Frequency Error

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Examples > Meas 3: Measuring the Relative Code Domain Power and Frequency Error
Meas 3: Measuring the Relative Code Domain Power and Frequency Error

A Code Domain Power measurement analyzes the signal over a single Power Control Group (PCG). It also determines the power of all codes and channels.

The following examples show a Code Domain Power measurement on a test model with 9 channels. In this measurement, changing some parameters one after the other should demonstrate the resulting effects: values adapted to the measurement signal are changed to non-adapted values.

Test setup

  1. Connect the RF output of the R&S SMU to the input of the R&S FSW.

  2. Connect the reference input (REF INPUT) on the rear panel of the R&S FSW to the reference input (REF) on the rear panel of the R&S SMU (coaxial cable with BNC connectors).

Settings on the R&S SMU

  1. PRESET

  2. "FREQ" = 878.49 MHz

  3. "LEVEL"= 0 dBm

  4. "DIGITAL STD" = "cdma2000"

  5. "DIGITAL STD > Set Default"

  6. "DIGITAL STD > LINK DIRECTION > DOWN/FORWARD"

  7. "DIGITAL STD > cdma2000 > STATE"= "ON"

Settings on the R&S FSW

  1. PRESET

  2. "MODE > cdma2000 BTS"

  3. "AMPT > Reference level"= 10 dBm

  4. "FREQ > Center frequency" = 878.49 MHz

    The following results are displayed: the first window shows the power of the code domain of the signal. The x-axis represents the individual channels (or codes), while the y-axis shows the power of each channel.

    In the second window, the Result Summary is displayed. It shows the numeric results of the code domain power measurement, including the frequency error.

Synchronization of the reference frequencies

The frequency error can be reduced by synchronizing the transmitter and the receiver to the same reference frequency.

► | "SETUP > Reference > External Reference ..."
 | Again, the first window shows the Code Domain Power measurement and the second window contains the Result Summary. After the reference frequencies of the devices have been synchronized, the frequency error should be smaller than 10 Hz.
Behavior with deviating center frequency setting

A measurement can only be valid if the center frequency of the DUT and the analyzer are balanced.

  1. On the signal generator, change the center frequency in steps of 0.1 kHz and observe the analyzer display.

    Up to a frequency error of approximately 1.0 kHz, a Code Domain Power measurement on the R&S FSW is still possible. A frequency error within this range causes no apparent difference in the accuracy of the Code Domain Power measurement.

    In case of a frequency error of more than 1.0 kHz, the probability of incorrect synchronization increases. This is indicated by the "SYNC FAILED" error message.

    If the frequency error exceeds approximately 1.5 kHz, a Code Domain Power measurement cannot be performed. This is also indicated by the "SYNC FAILED" error message.

  2. Reset the center frequency of the signal generator to 878.49 MHz.

The center frequency of the DUT should not deviate by more than 1.0 kHz from that of the R&S FSW.


Meas 4: Measuring the Triggered Relative Code Domain Power

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Examples > Meas 4: Measuring the Triggered Relative Code Domain Power
Meas 4: Measuring the Triggered Relative Code Domain Power

If the code domain power measurement is performed without external triggering, a section of the test signal is recorded at an arbitrary point of time and the firmware attempts to detect the start of a PCG. To detect this start, all possibilities of the PN sequence location have to be tested in Free Run trigger mode. This requires computing time. This computing time can be reduced by using an external (frame) trigger and entering the correct PN offset. If the search range for the start of the power control group and the PN offset are known then fewer possibilities have to be tested. This increases the measurement speed.

Test setup

  1. Connect the RF output of the R&S SMU to the input of the R&S FSW.

  2. Connect the reference input (REF INPUT) on the rear panel of the R&S FSW to the reference input (REF) on the rear panel of the R&S SMU (coaxial cable with BNC connectors).

  3. Connect the external trigger input on the front panel of the R&S FSW (TRIGGER INPUT) to the external trigger output on the front panel of the R&S SMU (TRIGOUT1 of PAR DATA).

Settings on the R&S SMU

  1. PRESET

  2. "FREQ" = 878.49 MHz

  3. "LEVEL"= 0 dBm

  4. "DIGITAL STD" = "cdma2000"

  5. "DIGITAL STD > Set Default"

  6. "DIGITAL STD > LINK DIRECTION > DOWN/FORWARD"

  7. "DIGITAL STD > cdma2000 > STATE"= "ON"

Settings on the R&S FSW

  1. PRESET

  2. "MODE > cdma2000 BTS"

  3. "AMPT > Reference level"= 10 dBm

  4. "FREQ > Center frequency" = 878.49 MHz

  5. "TRIG > External Trigger 1"

    The following results are displayed: the first window shows the power of the code domain of the signal. Compared to the measurement without an external trigger (see "Meas 3: Measuring the Relative Code Domain Power and Frequency Error"), the repetition rate of the measurement increases.

    In the second window, the Result Summary is displayed. It shows the numeric results of the code domain power measurement, including the frequency error. The "Trigger to Frame" shows the offset between the trigger event and and the start of the PCG.

Contents
  • Adjusting the Trigger Offset
  • Behaviour With the Wrong PN Offset


Adjusting the Trigger Offset

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Examples > Meas 4: Measuring the Triggered Relative Code Domain Power > Adjusting the Trigger Offset
Adjusting the Trigger Offset

The delay between the trigger event and the start of the PCG can be compensated for by adjusting the trigger offset.

  1. "TRIG > External Trigger 1"

  2. "TRIG > Trigger Offset" = 100 µs

    The following results are displayed: the first window shows the power of the code domain of the signal.

    In the second window, the Result Summary is displayed. The "Trigger to Frame" offset between the trigger event and and the start of the PCG has been eliminated.


Behaviour With the Wrong PN Offset

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Examples > Meas 4: Measuring the Triggered Relative Code Domain Power > Behaviour With the Wrong PN Offset
Behaviour With the Wrong PN Offset

The last adjustment is setting the PN (Pseudo Noise) offset correctly. The measurement is only valid if the PN offset on the analyzer is the same as that of the transmit signal.

►

"Signal Description > PN Offset"= 200.

In the Result Summary, the "Trigger to Frame" result is not correct. Also, the error message SYNC FAILED indicates that the synchronization has failed.

Correct the "PN Offset".

►

"Signal Description > PN Offset"= 0.

Now the PN offset on the R&S FSW is the same as that of the signal. In the Result Summary the "Trigger to Frame" value is now correct.


Meas 5: Measuring the Composite EVM

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Examples > Meas 5: Measuring the Composite EVM
Meas 5: Measuring the Composite EVM

The Error Vector Magnitude (EVM) describes the quality of the measured signal compared to an ideal reference signal generated by the R&S FSW. In the I-Q plane, the error vector represents the ratio of the measured signal to the ideal signal on symbol level. The error vector is equal to the square root of the ratio of the measured signal to the reference signal. The result is given in %.

In the Composite EVM measurement the error is averaged over all channels (by means of the root mean square) for a given PCG. The measurement covers the entire signal during the entire observation time. In the graphical display the results are shown in a diagram, in which the x-axis represents the examined PCGs and the y-axis shows the EVM values.

Test setup

  1. Connect the RF output of the R&S SMU to the input of the R&S FSW.

  2. Connect the reference input (REF INPUT) on the rear panel of the R&S FSW to the reference input (REF) on the rear panel of the R&S SMU (coaxial cable with BNC connectors).

  3. Connect the external trigger input on the front panel of the R&S FSW (TRIGGER INPUT) to the external trigger output on the front panel of the R&S SMU (TRIGOUT1 of PAR DATA).

Settings on the R&S SMU

  1. PRESET

  2. "FREQ" = 878.49 MHz

  3. "LEVEL"= 0 dBm

  4. "DIGITAL STD" = "cdma2000"

  5. "DIGITAL STD > Set Default"

  6. "DIGITAL STD > LINK DIRECTION > DOWN/FORWARD"

  7. "DIGITAL STD > cdma2000 > STATE"= "ON"

Settings on the R&S FSW

  1. PRESET

  2. "MODE > cdma2000 BTS"

  3. "AMPT > Reference level"= 10 dBm

  4. "FREQ > Center frequency" = 878.49 MHz

  5. "TRIG > External Trigger 1"

  6. "MEAS CONFIG > Display Config > Composite EVM" (Window 2)

  7. "AMPT > Scale Config > Auto Scale Once"

    The following results are displayed: the first window shows the diagram of the Composite EVM measurement result. In the second window, the Result Summary is displayed. It shows the numeric results of the Code Domain Power measurement, including the values for the Composite EVM.


Meas 6: Measuring the Peak Code Domain Error and the RHO Factor

cdma2000 Measurements (R&S FSW-K82/-K83) > Measurement Examples > Meas 6: Measuring the Peak Code Domain Error and the RHO Factor
Meas 6: Measuring the Peak Code Domain Error and the RHO Factor

The Code Domain Error Power describes the quality of the measured signal compared to an ideal reference signal generated by the R&S FSW. In the I-Q plane, the error vector represents the difference of the measured signal and the ideal signal. The Code Domain Error is the difference in power on symbol level of the measured and the reference signal projected to the class of of the base spreading factor. The unit of the result is dB.

In the Peak Code Domain Error (PCDE) measurement, the maximum error value over all channels is determined and displayed for a given PCG. The measurement covers the entire signal during the entire observation time. In the graphical display the results are shown in a diagram, in which the x-axis represents the PCGs and the y-axis shows the PCDE values.

A measurement of the RHO factor is shown in the second part of the example. RHO is the normalized, correlated power between the measured and the ideal reference signal. The maximum value of RHO is 1. In that case the measured signal and the reference signal are identical. When measuring RHO, it is required that only the pilot channel is active.

Test setup

  1. Connect the RF output of the R&S SMU to the input of the R&S FSW.

  2. Connect the reference input (REF INPUT) on the rear panel of the R&S FSW to the reference input (REF) on the rear panel of the R&S SMU (coaxial cable with BNC connectors).

  3. Connect the external trigger input on the front panel of the R&S FSW (TRIGGER INPUT) to the external trigger output on the front panel of the R&S SMU (TRIGOUT1 of PAR DATA).

Settings on the R&S SMU

  1. PRESET

  2. "FREQ" = 878.49 MHz

  3. "LEVEL" = 0 dBm

  4. "DIGITAL STD" = "cdma2000"

  5. "DIGITAL STD > Set Default"

  6. "DIGITAL STD > LINK DIRECTION > DOWN/FORWARD"

  7. "DIGITAL STD > cdma2000 > STATE" = "ON"

Settings on the R&S FSW

  1. PRESET

  2. "MODE > cdma2000 BTS"

  3. "AMPT > Reference level"= 0 dBm

  4. "FREQ > Center frequency" = 878.49 MHz

  5. "TRIG > External Trigger 1"

  6. "MEAS CONFIG > Display Config > Peak Code Domain Error" (Window 1)

  7. "AMPT > Scale Config > Auto Scale Once"

    The following results are displayed: the first window shows the diagram of the Peak Code Domain Error. In the second window, the Result Summary is displayed.

Displaying RHO

Make sure that all channels except the pilot channel (code 0.64) are OFF, so that only the pilot channel is available in the measurement.

No specific measurement is required to get the value for RHO. The R&S FSW always calculates this value automatically regardless of the code domain measurement performed. Besides the results of the code domain measurements, the numeric result of the RHO measurement is shown in the Result Summary, by default in the second window.


Remote Commands for CDMA2000 Measurements

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements
Remote Commands for CDMA2000 Measurements

The following commands are required to perform measurements in CDMA2000 applications in a remote environment. It assumes that the R&S FSW has already been set up for remote operation in a network as described in the base unit manual.

(See "How to Set Up a Network and Remote Control" .)

Note that basic tasks that are also performed in the base unit in the same way are not described here.

In particular, this includes:

  • Managing Settings and Results, i.e. storing and loading settings and result data, see "Managing Settings and Results"
  • Basic instrument configuration, e.g. checking the system configuration, customizing the screen layout, or configuring networks and remote operation, see "Configuring the "
  • Using the common status registers, see "Using the Status Register"

After a short introduction to remote commands, the tasks specific to CDMA2000 applications are described here:

Contents
  • Introduction
  • Common Suffixes
  • Activating the Measurement Channel
  • Selecting a Measurement
  • Configuring Code Domain Analysis
  • Configuring RF Measurements
  • Configuring the Result Display
  • Starting a Measurement
  • Retrieving Results
  • General Analysis
  • Configuring the Application Data Range (MSRA mode only)
  • Querying the Status Registers
  • Commands for Compatibility
  • Programming Examples for CDMA2000 BTS Measurements


Introduction

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Introduction
Introduction

Commands are program messages that a controller (e.g. a PC) sends to the instrument or software. They operate its functions ('setting commands' or 'events') and request information ('query commands'). Some commands can only be used in one way, others work in two ways (setting and query). If not indicated otherwise, the commands can be used for settings and queries.

The syntax of a SCPI command consists of a header and, in most cases, one or more parameters. To use a command as a query, you have to append a question mark after the last header element, even if the command contains a parameter.

A header contains one or more keywords, separated by a colon. Header and parameters are separated by a "white space" (ASCII code 0 to 9, 11 to 32 decimal, e.g. blank). If there is more than one parameter for a command, these are separated by a comma from one another.

Only the most important characteristics that you need to know when working with SCPI commands are described here. For a more complete description, refer to the User Manual of the R&S FSW.

Remote command examples

Note that some remote command examples mentioned in this general introduction may not be supported by this particular application.

Contents
  • Long and Short Form
  • Numeric Suffixes
  • Optional Keywords
  • Alternative Keywords
  • SCPI Parameters


Long and Short Form

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Introduction > Long and Short Form
Long and Short Form

The keywords have a long and a short form. You can use either the long or the short form, but no other abbreviations of the keywords.

The short form is emphasized in upper case letters. Note however, that this emphasis only serves the purpose to distinguish the short from the long form in the manual. For the instrument, the case does not matter.

Example:

SENSe:FREQuency:CENTer is the same as SENS:FREQ:CENT.


Numeric Suffixes

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Introduction > Numeric Suffixes
Numeric Suffixes

Some keywords have a numeric suffix if the command can be applied to multiple instances of an object. In that case, the suffix selects a particular instance (e.g. a measurement window).

Numeric suffixes are indicated by angular brackets (<n>) next to the keyword.

If you don't quote a suffix for keywords that support one, a 1 is assumed.

Example:

DISPlay[:WINDow<1...4>]:ZOOM:STATe enables the zoom in a particular measurement window, selected by the suffix at WINDow.

DISPlay:WINDow4:ZOOM:STATe ON refers to window 4.


Optional Keywords

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Introduction > Optional Keywords
Optional Keywords

Some keywords are optional and are only part of the syntax because of SCPI compliance. You can include them in the header or not.

Note that if an optional keyword has a numeric suffix and you need to use the suffix, you have to include the optional keyword. Otherwise, the suffix of the missing keyword is assumed to be the value 1.

Optional keywords are emphasized with square brackets.

Example:

Without a numeric suffix in the optional keyword:

[SENSe:]FREQuency:CENTer is the same as FREQuency:CENTer

With a numeric suffix in the optional keyword:

DISPlay[:WINDow<1...4>]:ZOOM:STATe

DISPlay:ZOOM:STATe ON enables the zoom in window 1 (no suffix).

DISPlay:WINDow4:ZOOM:STATe ON enables the zoom in window 4.


Alternative Keywords

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Introduction > Alternative Keywords
Alternative Keywords

A vertical stroke indicates alternatives for a specific keyword. You can use both keywords to the same effect.

Example:

[SENSe:]BANDwidth|BWIDth[:RESolution]

In the short form without optional keywords, BAND 1MHZ would have the same effect as BWID 1MHZ.


SCPI Parameters

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Introduction > SCPI Parameters
SCPI Parameters

Many commands feature one or more parameters.

If a command supports more than one parameter, these are separated by a comma.

Example:

LAYout:ADD:WINDow Spectrum,LEFT,MTABle

Parameters may have different forms of values.

Contents
  • Numeric Values
  • Boolean
  • Character Data
  • Character Strings
  • Block Data


Numeric Values

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Introduction > SCPI Parameters > Numeric Values
Numeric Values

Numeric values can be entered in any form, i.e. with sign, decimal point or exponent. In case of physical quantities, you can also add the unit. If the unit is missing, the command uses the basic unit.

Example:

with unit: SENSe:FREQuency:CENTer 1GHZ

without unit: SENSe:FREQuency:CENTer 1E9 would also set a frequency of 1 GHz.

Values exceeding the resolution of the instrument are rounded up or down.

If the number you have entered is not supported (e.g. in case of discrete steps), the command returns an error.

Instead of a number, you can also set numeric values with a text parameter in special cases.

  • MIN/MAX
    Defines the minimum or maximum numeric value that is supported.
  • DEF
    Defines the default value.
  • UP/DOWN
    Increases or decreases the numeric value by one step. The step size depends on the setting. In some cases you can customize the step size with a corresponding command.
Querying numeric values

When you query numeric values, the system returns a number. In case of physical quantities, it applies the basic unit (e.g. Hz in case of frequencies). The number of digits after the decimal point depends on the type of numeric value.

Example:

Setting: SENSe:FREQuency:CENTer 1GHZ

Query: SENSe:FREQuency:CENTer? would return 1E9

In some cases, numeric values may be returned as text.

  • INF/NINF
    Infinity or negative infinity. Represents the numeric values 9.9E37 or -9.9E37.
  • NAN
    Not a number. Represents the numeric value 9.91E37. NAN is returned in case of errors.


Boolean

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Introduction > SCPI Parameters > Boolean
Boolean

Boolean parameters represent two states. The "ON" state (logically true) is represented by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by "OFF" or the numeric value 0.

Querying boolean parameters

When you query boolean parameters, the system returns either the value 1 ("ON") or the value 0 ("OFF").

Example:

Setting: DISPlay:WINDow:ZOOM:STATe ON

Query: DISPlay:WINDow:ZOOM:STATe? would return 1


Character Data

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Introduction > SCPI Parameters > Character Data
Character Data

Character data follows the syntactic rules of keywords. You can enter text using a short or a long form. For more information see "Long and Short Form".

Querying text parameters

When you query text parameters, the system returns its short form.

Example:

Setting: SENSe:BANDwidth:RESolution:TYPE NORMal

Query: SENSe:BANDwidth:RESolution:TYPE? would return NORM


Character Strings

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Introduction > SCPI Parameters > Character Strings
Character Strings

Strings are alphanumeric characters. They have to be in straight quotation marks. You can use a single quotation mark ( ' ) or a double quotation mark ( " ).

Example:

INSTRument:DELete 'Spectrum'


Block Data

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Introduction > SCPI Parameters > Block Data
Block Data

Block data is a format which is suitable for the transmission of large amounts of data.

The ASCII character # introduces the data block. The next number indicates how many of the following digits describe the length of the data block. In the example the 4 following digits indicate the length to be 5168 bytes. The data bytes follow. During the transmission of these data bytes all end or other control signs are ignored until all bytes are transmitted. #0 specifies a data block of indefinite length. The use of the indefinite format requires a NL^END message to terminate the data block. This format is useful when the length of the transmission is not known or if speed or other considerations prevent segmentation of the data into blocks of definite length.


Common Suffixes

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Common Suffixes
Common Suffixes

In CDMA2000 applications, the following common suffixes are used in remote commands (and not described for each command individually):

Suffix | Value range | Description
<n> | 1..16 | Window
<t> | 1 (CDA) 6 (RF) | Trace
<m> | 1..4 (CDA) 1..16 (RF) | Marker
<ch> | 1..18 (Tx channel) 1..11 (ALT channel) | Channel in RF measurements
<k> | 1..8 (Limit line) 1 | 2 (Display line) | Line in RF measurements


Activating the Measurement Channel

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Activating the Measurement Channel
Activating the Measurement Channel

CDMA2000 measurements require a special application on the R&S FSW. The measurement is started immediately with the default settings.

List of Commands
INSTrument:CREate:DUPLicate
INSTrument:CREate[:NEW]
INSTrument:CREate:REPLace
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
SYSTem:PRESet:CHANnel[:EXECute]


INSTrument:CREate:DUPLicate

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Activating the Measurement Channel > INSTrument:CREate:DUPLicate
INSTrument:CREate:DUPLicate

This command duplicates the currently selected measurement channel, i.e starts a new measurement channel of the same type and with the identical measurement settings. The name of the new channel is the same as the copied channel, extended by a consecutive number (e.g. "Spectrum" -> "Spectrum 2").

The channel to be duplicated must be selected first using the INST:SEL command.

(See INSTrument[:​SELect] ).

This command is not available if the MSRA Master channel is selected.

Example: | INST:SEL 'Spectrum' INST:CRE:DUPL Duplicates the channel named 'Spectrum' and creates a new measurement channel named 'Spectrum 2'.
Usage: | Event


INSTrument:CREate[:NEW]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Activating the Measurement Channel > INSTrument:CREate[:NEW]
INSTrument:CREate[:NEW] <ChannelType>, <ChannelName>

This command adds an additional measurement channel. The number of measurement channels you can configure at the same time depends on available memory.

Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel. The channel name is displayed as the tab label for the measurement channel.

Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).

Example: INST:CRE SAN, 'Spectrum 2'

Adds an additional spectrum display named "Spectrum 2".

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Programming Example: Performing a Sequence of Measurements" .


INSTrument:CREate:REPLace

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Activating the Measurement Channel > INSTrument:CREate:REPLace
INSTrument:CREate:REPLace <ChannelName1>,<ChannelType>,<ChannelName2>

This command replaces a measurement channel with another one.

Parameters:
<ChannelName1> | String containing the name of the measurement channel you want to replace.
<ChannelType> | Channel type of the new channel. For a list of available channel types see INSTrument:​LIST?.
<ChannelName2> | String containing the name of the new channel. Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).
Example: | INST:CRE:REPL 'Spectrum2',IQ,'IQAnalyzer' Replaces the channel named 'Spectrum2' by a new measurement channel of type 'IQ Analyzer' named 'IQAnalyzer'.


INSTrument:DELete

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Activating the Measurement Channel > INSTrument:DELete
INSTrument:DELete <ChannelName>

This command deletes a measurement channel. If you delete the last measurement channel, the default "Spectrum" channel is activated.

Parameters:
<ChannelName> | String containing the name of the channel you want to delete. A measurement channel must exist in order to be able delete it.
Example: | INST:DEL 'Spectrum4' Deletes the spectrum channel with the name 'Spectrum4'.


INSTrument:LIST?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Activating the Measurement Channel > INSTrument:LIST?
INSTrument:LIST?

This command queries all active measurement channels. This is useful in order to obtain the names of the existing measurement channels, which are required in order to replace or delete the channels.

Return values:
<ChannelType>, <ChannelName> | For each channel, the command returns the channel type and channel name (see tables below). Tip: to change the channel name, use the INSTrument:​REName command.
Example: | INST:LIST? Result for 3 measurement channels: 'ADEM','Analog Demod','IQ','IQ Analyzer','SANALYZER','Spectrum'
Usage: | Query only
Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode
Application | <ChannelType> Parameter | Default Channel Name*)
Spectrum | SANALYZER | Spectrum
I/Q Analyzer | IQ | IQ Analyzer
Pulse (R&S FSW-K6) | PULSE | Pulse
Analog Demodulation (R&S FSW-K7) | ADEM | Analog Demod
GSM (R&S FSW-K10) | GSM | GSM
Multi-Carrier Group Delay (R&S FSW-K17) | MCGD | MC Group Delay
Noise (R&S FSW-K30) | NOISE | Noise
Phase Noise (R&S FSW-K40) | PNOISE | Phase Noise
Transient Analysis (R&S FSW-K60) | TA | Transient Analysis
VSA (R&S FSW-K70) | DDEM | VSA
3GPP FDD BTS (R&S FSW-K72) | BWCD | 3G FDD BTS
3GPP FDD UE (R&S FSW-K73) | MWCD | 3G FDD UE
TD-SCDMA BTS (R&S FSW-K76) | BTDS | TD-SCDMA BTS
TD-SCDMA UE (R&S FSW-K77) | MTDS | TD-SCDMA UE
cdma2000 BTS (R&S FSW-K82) | BC2K | CDMA2000 BTS
cdma2000 MS (R&S FSW-K83) | MC2K | CDMA2000 MS
1xEV-DO BTS (R&S FSW-K84) | BDO | 1xEV-DO BTS
1xEV-DO MS (R&S FSW-K85) | MDO | 1xEV-DO MS
WLAN (R&S FSW-K91) | WLAN | WLAN
LTE (R&S FSW-K10x) | LTE | LTE
Realtime Spectrum (R&S FSW-K160R) | RTIM | Realtime Spectrum
Note: the default channel name is also listed in the table. If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel.


INSTrument:REName

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Activating the Measurement Channel > INSTrument:REName
INSTrument:REName <ChannelName1>, <ChannelName2>

This command renames a measurement channel.

Parameters:
<ChannelName1> | String containing the name of the channel you want to rename.
<ChannelName2> | String containing the new channel name. Note that you can not assign an existing channel name to a new channel; this will cause an error.
Example: | INST:REN 'Spectrum2','Spectrum3' Renames the channel with the name 'Spectrum2' to 'Spectrum3'.


INSTrument[:SELect]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Activating the Measurement Channel > INSTrument[:SELect]
INSTrument[:SELect] <ChannelType>

This command activates a new measurement channel with the defined channel type, or selects an existing measurement channel with the specified name.

See also INSTrument:​CREate[:​NEW].

For a list of available channel types see table "Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode".

Parameters:
<ChannelType>
BC2K

cdma2000 BTS option, R&S FSW–K82

MC2K

cdma2000 MS option, R&S FSW–K83


SYSTem:PRESet:CHANnel[:EXECute]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Activating the Measurement Channel > SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:CHANnel[:EXECute]

This command restores the default instrument settings in the current channel.

Use INST:SEL to select the channel.

For details see "Factory Default Configuration" .

Example: | INST 'Spectrum2' Selects the channel for "Spectrum2". SYST:PRES:CHAN:EXEC Restores the factory default settings to the "Spectrum2" channel.
Usage: | Event
Manual operation: | See "Preset Channel"


Selecting a Measurement

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Selecting a Measurement
Selecting a Measurement

The following commands are required to define the measurement type in a remote environment. For details on available measurements see "Measurements and Result Displays".

List of Commands
CONFigure:CDPower[:BTS]:MEASurement


CONFigure:CDPower[:BTS]:MEASurement

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Selecting a Measurement > CONFigure:CDPower[:BTS]:MEASurement
CONFigure:CDPower[:BTS]:MEASurement <Measurement>

This command selects the RF measurement type (with predefined settings according to the CDMA2000 standard).

Parameters:
<Measurement>
ACLR | CCDF | CDPower | ESPectrum | OBWidth | POWer
ACLR

Adjacent-Channel Power measurement

CCDF

measurement of the complementary cumulative distribution function (signal statistics)

CDPower

Code Domain Analyzer measurement.

ESPectrum

check of signal power (Spectrum Emission Mask)

OBWidth

measurement of the occupied bandwidth

POWer

Signal Channel Power measurement

(with predefined settings according to the CDMA2000 standard)

*RST: CDPower
Example: CONF:CDP:MEAS POW

Selects Signal Channel Power measurement.

Manual operation: See "Power"
See "Channel Power ACLR"
See "Spectrum Emission Mask"
See "Occupied Bandwidth"
See "CCDF"
See "Creating a New Channel Table from the Measured Signal (Measure Table)"


Configuring Code Domain Analysis

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis
Configuring Code Domain Analysis
Contents
  • Signal Description
  • Configuring the Data Input and Output
  • Frontend Configuration
  • Configuring Triggered Measurements
  • Signal Capturing
  • Channel Detection
  • Sweep Settings
  • Automatic Settings
  • Evaluation Range
  • Code Domain Analysis Settings


Signal Description

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Signal Description
Signal Description

The signal description provides information on the expected input signal.

Contents
  • BTS Signal Description
  • MS Signal Description


BTS Signal Description

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Signal Description > BTS Signal Description
BTS Signal Description

The following commands describe the input signal in BTS measurements.

For more information see "Transmission with Multiple Carriers and Multiple Antennas".

List of Commands
CONFigure:CDPower[:BTS]:MCARrier:FILTer:COFRequency
CONFigure:CDPower[:BTS]:MCARrier:FILTer:ROFF
CONFigure:CDPower[:BTS]:MCARrier:FILTer[:STATe]
CONFigure:CDPower[:BTS]:MCARrier:FILTer:TYPE
CONFigure:CDPower[:BTS]:MCARrier:MALGo
CONFigure:CDPower[:BTS]:MCARrier[:STATe]
[SENSe:]CDPower:ANTenna
[SENSe:]CDPower:PNOFfset


CONFigure:CDPower[:BTS]:MCARrier:FILTer:COFRequency

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Signal Description > BTS Signal Description > CONFigure:CDPower[:BTS]:MCARrier:FILTer:COFRequency
CONFigure:CDPower[:BTS]:MCARrier:FILTer:COFRequency <Frequency>

This command sets the cut-off frequency for the RRC filter.

Parameters:
<Frequency>
Range: | 0.1 MHz to 2.4 MHz
*RST: | 1.25
Example: CONF:CDP:MCAR ON

Activates multicarrier mode

CONF:CDP:MCAR:FILT ON

Activates an additional filter for multicarrier measurements

CONF:CDP:MCAR:FILT:TYPE RRC

Activates the RRC filter

CONF:CDP:MCAR:FILT:COFR 1.5MHZ

Sets the cut-off frequency to 1.5 MHz

Manual operation: See "Cut Off Frequency"


CONFigure:CDPower[:BTS]:MCARrier:FILTer:ROFF

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Signal Description > BTS Signal Description > CONFigure:CDPower[:BTS]:MCARrier:FILTer:ROFF
CONFigure:CDPower[:BTS]:MCARrier:FILTer:ROFF <RollOffFactor>

This command sets the roll-off factor for the RRC filter.

Parameters:
<RollOffFactor>
Range: | 0.01 to 0.99
*RST: | 0.02
Example: CONF:CDP:MCAR ON

Activates multicarrier mode

CONF:CDP:MCAR:FILT ON

Activates an additional filter for multicarrier measurements

CONF:CDP:MCAR:FILT:TYPE RRC

Activates the RRC filter

CONF:CDP:MCAR:FILT:ROFF 0.05

Sets the roll-off factor to 0.05

Manual operation: See "Roll-Off Factor"


CONFigure:CDPower[:BTS]:MCARrier:FILTer[:STATe]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Signal Description > BTS Signal Description > CONFigure:CDPower[:BTS]:MCARrier:FILTer[:STATe]
CONFigure:CDPower[:BTS]:MCARrier:FILTer[:STATe] <State>

This command activates or deactivates the usage of a filter for multicarrier measurements.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CONF:CDP:MCAR ON

Activates multicarrier mode

CONF:CDP:MCAR:FILT OFF

Activates an additional filter for multicarrier measurements

Manual operation: See "Multicarrier Filter"


CONFigure:CDPower[:BTS]:MCARrier:FILTer:TYPE

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Signal Description > BTS Signal Description > CONFigure:CDPower[:BTS]:MCARrier:FILTer:TYPE
CONFigure:CDPower[:BTS]:MCARrier:FILTer:TYPE <Type>

This command sets the filter type to be used in multicarrier mode.

You can set the parameters for the RRC filter with the CONFigure:​CDPower[:​BTS]:​MCARrier:​FILTer:​COFRequency and CONFigure:​CDPower[:​BTS]:​MCARrier:​FILTer:​ROFF commands.

Parameters:
<Type>
LPASs | RCC
*RST: LPAS
Example: CONF:CDP:MCAR ON

Activates multicarrier mode

CONF:CDP:MCAR:FILT ON

Activates an additional filter for multicarrier measurements

CONF:CDP:MCAR:FILT:TYPE RRC

Activates the RRC filter

Manual operation: See "Filter Type"
See "Roll-Off Factor"
See "Cut Off Frequency"


CONFigure:CDPower[:BTS]:MCARrier:MALGo

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Signal Description > BTS Signal Description > CONFigure:CDPower[:BTS]:MCARrier:MALGo
CONFigure:CDPower[:BTS]:MCARrier:MALGo <State>

This command activates or deactivates the enhanced algorithm for the filters in multicarrier mode.

Parameters:
<State>
ON | OFF
*RST: ON
Example: CONF:CDP:MCAR ON

Activates multicarrier mode

CONF:CDP:MCAR:FILT ON

Activates an additional filter for multicarrier measurements

CONF:CDP:MCAR:MALG OFF

Deactivates the enhanced algorithm

Manual operation: See "Enhanced Algorithm"


CONFigure:CDPower[:BTS]:MCARrier[:STATe]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Signal Description > BTS Signal Description > CONFigure:CDPower[:BTS]:MCARrier[:STATe]
CONFigure:CDPower[:BTS]:MCARrier[:STATe] <State>

This command activates or deactivates the multicarrier mode.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CONF:CDP:MCAR ON

Activates the multicarrier settings.

Manual operation: See "Multicarrier"


[SENSe:]CDPower:ANTenna

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Signal Description > BTS Signal Description > [SENSe:]CDPower:ANTenna
[SENSe:]CDPower:ANTenna <AntennaState>

This command deactivates the orthogonal transmit diversity (two-antenna system) or defines the antenna for which the result display is evaluated.

For details on antenna diversity see also "Antenna Diversity".

Parameters:
<AntennaState>
OFF | 1 | 2
OFF

The aggregate signal from both antennas is fed in.

1

The signal of antenna 1 is fed in.

2

The signal of antenna 2 is fed in.

*RST: OFF

For further details refer to "Antenna Diversity - Antenna Number".

Example: CDP:ANT 2

Selects antenna 2.

Manual operation: See "Antenna Diversity - Antenna Number"


[SENSe:]CDPower:PNOFfset

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Signal Description > BTS Signal Description > [SENSe:]CDPower:PNOFfset
[SENSe:]CDPower:PNOFfset <Offset>

This command sets the PN offset of the base station in multiples of 64 chips.

Parameters:
<Offset>
Range: | 0 to 511
*RST: | 0
Example: CDP:PNOF 45

Sets PN offset.

Manual operation: See "PN Offset"


MS Signal Description

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Signal Description > MS Signal Description
MS Signal Description

The following commands describe the input signal in MS measurements.

For more information see "Long code scrambling".

Useful commands for describing MS signals described elsewhere:
  • CONFigure:​CDPower[:​BTS]:​MCARrier:​FILTer:​COFRequency
  • CONFigure:​CDPower[:​BTS]:​MCARrier:​FILTer:​ROFF
  • CONFigure:​CDPower[:​BTS]:​MCARrier:​FILTer:​TYPE
  • CONFigure:​CDPower[:​BTS]:​MCARrier:​FILTer[:​STATe]
  • CONFigure:​CDPower[:​BTS]:​MCARrier:​MALGo
  • CONFigure:​CDPower[:​BTS]:​MCARrier[:​STATe]
Remote commands exclusive to describing MS signals:
List of Commands
[SENSe:]CDPower:LCODe:MASK
[SENSe:]CDPower:LCODe:MODE
[SENSe:]CDPower:LCODe:OFFSet


[SENSe:]CDPower:LCODe:MASK

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Signal Description > MS Signal Description > [SENSe:]CDPower:LCODe:MASK
[SENSe:]CDPower:LCODe:MASK <Mask>

Defines the long code mask of the mobile in hexadecimal form.

Note: For the default mask value of 0 the long code offset (see ) is not taken into consideration.

Parameters:
<Mask>
Range: | #H0 to #H4FFFFFFFFFF
*RST: | #H0
Example: INST:SEL MC2K

'Activate cdma2000 MS; by default, "CDP relative" is displayed in screen A and "Result Summary" in screen B.

INIT:CONT OFF

'Select single sweep

TRIG:SOUR:EXT

'Select external trigger source

CDP:LCOD:MASK '#HF'

'Define long code mask

INIT;*WAI

'Start measurement with synchronization

Manual operation: See "Long Code Mask"


[SENSe:]CDPower:LCODe:MODE

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Signal Description > MS Signal Description > [SENSe:]CDPower:LCODe:MODE
[SENSe:]CDPower:LCODe:MODE <Mode>

This command selects the mode of the long code generation.

Parameters:
<Mode>
STANdard

The cdma2000 standard long code generator is used.

ESG101

The Agilent ESG option 101 long code is used; in this case, only signals from that generator can be analysed.

*RST: STANdard
Manual operation: See "Long Code Generation"


[SENSe:]CDPower:LCODe:OFFSet

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Signal Description > MS Signal Description > [SENSe:]CDPower:LCODe:OFFSet
[SENSe:]CDPower:LCODe:OFFSet <CodeOffset>

Defines the long code offset, including the PN offset. This offset is applied at the next trigger pulse (which cannot occur until a setup time of 300 ms has elapsed).

This command is ignored if [SENSe:​]CDPower:​LCODe:​MODE is set to 0.

Parameters:
<CodeOffset>
Offset in chips in hexadecimal format with a 52-bit resolution. The chips offset is calculated as follows: tSinceStartGPS * 1.2288 MChips/s, where tSinceStartGPS is defined in seconds.

This value corresponds to the GPS timing since 6.1.1980 00:00:00 UTC.

*RST: #H0
Example:

The hexadecimal offset of 258000 h chips is set for the first even second clock trigger:

INST:SEL MC2K

'Activate cdma2000 MS; by default, "CDP relative" is displayed in screen A and "Result Summary" in screen B.

INIT:CONT OFF

'Select single sweep

TRIG:SOUR:EXT

'Select external trigger source

CDP:LCOD:MASK '#H2'

'Define long code mask

CDP:LCOD:OFFS '#H258000'

'Define long code offset

INIT;*WAI

'Start measurement with synchronization

Manual operation: See "Long Code Offset"


Configuring the Data Input and Output

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output
Configuring the Data Input and Output

The following commands are required to configure data input and output. For more information see "Data Input and Output Settings".

Contents
  • RF Input
  • Remote Commands for the Digital Baseband Interface (R&S FSW-B17)
  • Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
  • Setting up Probes
  • Configuring the Outputs


RF Input

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > RF Input
RF Input
List of Commands
INPut:ATTenuation:PROTection:RESet
INPut:CONNector
INPut:COUPling
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:IMPedance
INPut:SELect


INPut:ATTenuation:PROTection:RESet

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > RF Input > INPut:ATTenuation:PROTection:RESet
INPut:ATTenuation:PROTection:RESet

This command resets the attenuator and reconnects the RF input with the input mixer after an overload condition occured and the protection mechanism intervened.The error status bit (bit 3 in the STAT:QUES:POW status register) and the INPUT OVLD message in the status bar are cleared.

(For details on the status register see the R&S FSW User Manual).

The command works only if the overload condition has been eliminated first.

Usage: Event


INPut:CONNector

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > RF Input > INPut:CONNector
INPut:CONNector <ConnType>

Determines whether the RF input data is taken from the RF input connector or the optional Analog Baseband I connector. This command is only available if the Analog Baseband interface (R&S FSW-B71) is installed and active for input.

For more information see "Processing Data From the Analog Baseband Interface" .

Parameters:
<ConnType>
RF

RF input connector

AIQI

Analog Baseband I connector

*RST: RF
Example: INP:CONN:AIQI

Selects the analog baseband input.

Usage: SCPI confirmed
Manual operation: See "Input Connector"


INPut:COUPling

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > RF Input > INPut:COUPling
INPut:COUPling <CouplingType>

This command selects the coupling type of the RF input.

The command is not available for measurements with the Digital Baseband Interface (R&S FSW-B17).

Parameters:
<CouplingType>
AC

AC coupling

DC

DC coupling

*RST: AC
Example: INP:COUP DC
Usage: SCPI confirmed
Manual operation: See "Input Coupling"


INPut:FILTer:HPASs[:STATe]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > RF Input > INPut:FILTer:HPASs[:STATe]
INPut:FILTer:HPASs[:STATe] <State>

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "High-Pass Filter 1...3 GHz"


INPut:FILTer:YIG[:STATe]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > RF Input > INPut:FILTer:YIG[:STATe]
INPut:FILTer:YIG[:STATe] <State>

This command turns the YIG-preselector on and off.

Note the special conditions and restrictions for the YIG filter described in "YIG-Preselector".

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 (0 for I/Q Analyzer, GSM, VSA and MC Group Delay measurements)
Example: INP:FILT:YIG OFF

Deactivates the YIG-preselector.

Manual operation: See "YIG-Preselector"


INPut:IMPedance

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > RF Input > INPut:IMPedance
INPut:IMPedance <Impedance>

This command selects the nominal input impedance of the RF input.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a matching pad of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The power loss correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

The command is not available for measurements with the Digital Baseband Interface (R&S FSW-B17).

Parameters:
<Impedance>
50 | 75
*RST: 50 Ω
Example: INP:IMP 75
Usage: SCPI confirmed
Manual operation: See "Impedance"


INPut:SELect

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > RF Input > INPut:SELect
INPut:SELect <Source>

This command selects the signal source for measurements, i.e. it defines which connector is used to input data to the R&S FSW. If no additional options are installed, only RF input is supported.

Parameters:
<Source>
RF

Radio Frequency ("RF INPUT" connector)

DIQ

Digital IQ data (only available with optional Digital Baseband Interface R&S FSW-B17)

For details on I/Q input see "Digital Input" .

AIQ

Analog Baseband signal (only available with optional Analog Baseband Interface R&S FSW-B71)

For details on Analog Baseband input see "Processing Data From the Analog Baseband Interface" .

*RST: RF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Radio Frequency State"
See "Digital I/Q Input State"
See "Analog Baseband Input State"


Remote Commands for the Digital Baseband Interface (R&S FSW-B17)

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17)
Remote Commands for the Digital Baseband Interface (R&S FSW-B17)

The following commands are required to control the Digital Baseband Interface (R&S FSW-B17) in a remote environment.They are only available if this option is installed.

For more information on the Digital Baseband Interface see " Processing Data from the Digital Baseband Interface (-B17)" .

For more information on the Digital Baseband Interface see the R&S FSW I/Q Analyzer User Manual.

Information on the STATus:QUEStionable:DIQ register can be found in "STATus:QUEStionable:DIQ Register".

Contents
  • Configuring Digital I/Q Input and Output
  • STATus:QUEStionable:DIQ Register


Configuring Digital I/Q Input and Output

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output
Configuring Digital I/Q Input and Output
Remote commands for the R&S DigIConf software

Remote commands for the R&S DigIConf software always begin with SOURce:EBOX. Such commands are passed on from the R&S FSW to the R&S DigIConf automatically which then configures the R&S EX-IQ-BOX via the USB connection.

Be sure to connect the R&S EX-IQ-BOX to the R&S FSW via USB, not via LAN!

All remote commands available for configuration via the R&S DigIConf software are described in the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Example 1:

SOURce:EBOX:*RST

SOURce:EBOX:*IDN?

Result:

"Rohde&Schwarz,DigIConf,02.05.436 Build 47"

Example 2:

SOURce:EBOX:USER:CLOCk:REFerence:FREQuency 5MHZ

Defines the frequency value of the reference clock.

Remote commands exclusive to digital I/Q data input and output
List of Commands
INPut:DIQ:CDEVice
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO
OUTPut:DIQ
OUTPut:DIQ:CDEVice


INPut:DIQ:CDEVice

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output > INPut:DIQ:CDEVice
INPut:DIQ:CDEVice

This command queries the current configuration and the status of the digital I/Q input from the optional Digital Baseband Interface (R&S FSW-B17).

For details see "Interface Status Information" .

Return values:
<ConnState>

Defines whether a device is connected or not.

0

No device is connected.

1

A device is connected.

<DeviceName>

Device ID of the connected device

<SerialNumber>

Serial number of the connected device

<PortName>

Port name used by the connected device

<SampleRate>

Maximum or currently used sample rate of the connected device in Hz (depends on the used connection protocol version; indicated by <SampleRateType> parameter)

<MaxTransferRate>

Maximum data transfer rate of the connected device in Hz

<ConnProtState>

State of the connection protocol which is used to identify the connected device.

Not Started
Has to be Started
Started
Passed
Failed
Done
<PRBSTestState>

State of the PRBS test.

Not Started
Has to be Started
Started
Passed
Failed
Done
<SampleRateType>
0

Maximum sample rate is displayed

1

Current sample rate is displayed

<FullScaleLevel>

The level (in dBm) that should correspond to an I/Q sample with the magnitude "1" (if transferred from connected device);

If not available, 9.97e37 is returned

Example: INP:DIQ:CDEV?

Result:

1,SMU200A,103634,Out A,70000000,100000000,Passed,Not Started,0,0
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Connected Instrument"


INPut:DIQ:RANGe[:UPPer]:AUTO

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:AUTO <State>

If enabled, the digital input full scale level is automatically set to the value provided by the connected device (if available).

This command is only available if the optional Digital Baseband interface (option R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe:COUPling

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe:COUPling <State>

If enabled, the reference level for digital input is adjusted to the full scale level automatically if the full scale level changes.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Adjust Reference Level to Full Scale Level"


INPut:DIQ:RANGe[:UPPer]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer] <Level>

Defines or queries the "Full Scale Level", i.e. the level that corresponds to an I/Q sample with the magnitude "1".

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
<numeric value>
Range: | 1 μV to 7.071 V
*RST: | 1 V
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe[:UPPer]:UNIT

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:RANGe[:UPPer]:UNIT <Unit>

Defines the unit of the full scale level (see "Full Scale Level"). The availability of units depends on the measurement application you are using.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
VOLT | DBM | DBPW | WATT | DBMV | DBUV | DBUA | AMPere
*RST: Volt
Manual operation: See "Full Scale Level"


INPut:DIQ:SRATe

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe
INPut:DIQ:SRATe <SampleRate>

This command specifies or queries the sample rate of the input signal from the Digital Baseband Interface (R&S FSW-B17, see "Input Sample Rate").

Parameters:
<SampleRate>
Range: | 1 Hz to 10 GHz
*RST: | 32 MHz
Example:

INP:DIQ:SRAT 200 MHz

Manual operation: See "Input Sample Rate"


INPut:DIQ:SRATe:AUTO

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe:AUTO
INPut:DIQ:SRATe:AUTO <State>

If enabled, the sample rate of the digital I/Q input signal is set automatically by the connected device.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Input Sample Rate"


OUTPut:DIQ

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output > OUTPut:DIQ
OUTPut:DIQ <State>

This command turns continuous output of I/Q data to the optional Digital Baseband Interface (R&S FSW-B17) on and off.

Using the digital input and digital output simultaneously is not possible.

If digital baseband output is active, the sample rate is restricted to 100 MHz (200 MHz if enhanced mode is possible; max. 160 MHz bandwidth).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: OUTP:DIQ ON
Example:

See "Converting an RF Signal to a Digital I/Q Signal via the Digital Baseband Interface (-B17)" .

Example:

See "Output via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Digital Baseband Output"


OUTPut:DIQ:CDEVice

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output > OUTPut:DIQ:CDEVice
OUTPut:DIQ:CDEVice

This command queries the current configuration and the status of the digital I/Q data output to the optional Digital Baseband Interface (R&S FSW-B17).

For details see "Interface Status Information" .

Return values:
<ConnState>

Defines whether a device is connected or not.

0

No device is connected.

1

A device is connected.

<DeviceName>

Device ID of the connected device

<SerialNumber>

Serial number of the connected device

<PortName>

Port name used by the connected device

<NotUsed>

to be ignored

<MaxTransferRate>

Maximum data transfer rate of the connected device in Hz

<ConnProtState>

State of the connection protocol which is used to identify the connected device.

Not Started
Has to be Started
Started
Passed
Failed
Done
<PRBSTestState>

State of the PRBS test.

Not Started
Has to be Started
Started
Passed
Failed
Done
<NotUsed>

to be ignored

<Placeholder>

for future use; currently "0"

Example: OUTP:DIQ:CDEV?

Result:

1,SMU200A,103634,Out A,70000000,100000000,Passed,Not Started,0,0
Example:

See "Output via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Output Settings Information"
See "Connected Instrument"


STATus:QUEStionable:DIQ Register

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > STATus:QUEStionable:DIQ Register
STATus:QUEStionable:DIQ Register

This register contains information about the state of the digital I/Q input and output. This register is available with option Digital Baseband Interface (R&S FSW-B17)Digital Baseband Interface (R&S FSW-B17).

The status of the STATus:QUESTionable:DIQ register is indicated in bit 14 of the STATus:QUESTionable register.

You can read out the state of the register with STATus:​QUEStionable:​DIQ:​CONDition? and STATus:​QUEStionable:​DIQ[:​EVENt]?.

Bit No.

Meaning

0

Digital I/Q Input Device connected

This bit is set if a device is recognized and connected to the Digital Baseband Interface of the analyzer.

1

Digital I/Q Input Connection Protocol in progress

This bit is set while the connection between analyzer and digital baseband data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

2

Digital I/Q Input Connection Protocol error

This bit is set if an error occurred during establishing of the connect between analyzer and digital I/Q data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

3

Digital I/Q Input PLL unlocked

This bit is set if the PLL of the Digital I/Q input is out of lock due to missing or unstable clock provided by the connected Digital I/Q TX device. To solve the problem the Digital I/Q connection has to be newly initialized after the clock has been restored.

4

Digital I/Q Input DATA Error

This bit is set if the data from the Digital I/Q input module is erroneous. Possible reasons:

  • Bit errors in the data transmission. The bit will only be set if an error occurred at the current measurement.
  • Protocol or data header errors. May occurred at data synchronization problems or vast transmission errors. The bit will be set constantly and all data will be erroneous. To solve the problem the Digital I/Q connection has to be newly initialized.

NOTE: If this error is indicated repeatedly either the Digital I/Q LVDS connection cable or the receiving or transmitting device might be defect.

5

not used

6

Digital I/Q Input FIFO Overload

This bit is set if the sample rate on the connected instrument is higher than the input sample rate setting on the R&S FSW. Possible solution:

  • Reduce the sample rate on the connected instrument
  • Increase the input sample rate setting on the R&S FSW

7

not used

8

Digital I/Q Output Device connected

This bit is set if a device is recognized and connected to the Digital I/Q Output.

9

Digital I/Q Output Connection Protocol in progress

This bit is set while the connection between analyzer and digital I/Q data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

10

Digital I/Q Output Connection Protocol error

This bit is set if an error occurred while the connection between analyzer and digital I/Q data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

11

Digital I/Q Output FIFO Overload

This bit is set if an overload of the Digital I/Q Output FIFO occurred. This happens if the output data rate is higher than the maximal data rate of the connected instrument. Reduce the sample rate to solve the problem.

12-14

not used

15

This bit is always set to 0.

List of Commands
STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:DIQ:ENABle
STATus:QUEStionable:DIQ:NTRansition
STATus:QUEStionable:DIQ:PTRansition
STATus:QUEStionable:DIQ[:EVENt]?


STATus:QUEStionable:DIQ:CONDition?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:DIQ:CONDition? <ChannelName>

This command reads out the CONDition section of the STATus:QUEStionable:DIQ:CONDition status register.

The command does not delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Example: | STAT:QUES:DIQ:COND?
Usage: | Query only


STATus:QUEStionable:DIQ:ENABle

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:ENABle
STATus:QUEStionable:DIQ:ENABle <BitDefinition>, <ChannelName>

This command controls the ENABle part of a register.

The ENABle part allows true conditions in the EVENt part of the status register to be reported in the summary bit. If a bit is 1 in the enable register and its associated event bit transitions to true, a positive transition will occur in the summary bit reported to the next higher level.

Parameters:
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Setting parameters:
<SumBit>
Range: 0 to 65535
Usage: SCPI confirmed


STATus:QUEStionable:DIQ:NTRansition

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:NTRansition
STATus:QUEStionable:DIQ:NTRansition <BitDefinition>,<ChannelName>

This command controls the Negative TRansition part of a register.

Setting a bit causes a 1 to 0 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Setting parameters:
<BitDefinition>
Range: 0 to 65535


STATus:QUEStionable:DIQ:PTRansition

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:PTRansition
STATus:QUEStionable:DIQ:PTRansition <BitDefinition>,<ChannelName>

This command controls the Positive TRansition part of a register.

Setting a bit causes a 0 to 1 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Setting parameters:
<BitDefinition>
Range: 0 to 65535


STATus:QUEStionable:DIQ[:EVENt]?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ[:EVENt]?
STATus:QUEStionable:DIQ[:EVENt]? <ChannelName>

This command queries the contents of the "EVENt" section of the STATus:QUEStionable:DIQ register for IQ measurements.

Readout deletes the contents of the "EVENt" section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Example: | STAT:QUES:DIQ?
Usage: | Query only


Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

The following commands are required to control the Analog Baseband Interface (R&S FSW-B71) in a remote environment.They are only available if this option is installed.

For more information on the Analog Baseband Interface see "Processing Data From the Analog Baseband Interface" .

Useful commands for Analog Baseband data described elsewhere:
  • INP:SEL AIQ (see INPut:​SELect)
  • [SENSe:​]FREQuency:​CENTer
For calibration:
  • DIAGnostic:​SERVice:​INPut[:​SELect]
  • DIAGnostic:​SERVice:​INPut:​AIQ[:​TYPE]
Remote commands exclusive to Analog Baseband data input and output
List of Commands
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
[SENSe:]PROBe<ch>:SETup:CMOFfset
TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?


INPut:IQ:BALanced[:STATe]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:BALanced[:STATe]
INPut:IQ:BALanced[:STATe] <State>

This command defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Parameters:
<State>
ON

Differential

OFF

Simple-ended

*RST: ON
Example: INP:IQ:BAL OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Input configuration"


INPut:IQ:FULLscale:AUTO

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale:AUTO <State>

This command defines whether the full scale level (i.e. the maximum input power on the Baseband Input connector) is defined automatically according to the reference level, or manually.

Parameters:
<State>
ON

Automatic definition

OFF

Manual definition according to INPut:​IQ:​FULLscale[:​LEVel]

*RST: ON
Example: INP:IQ:FULL:AUTO OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Full Scale Level Mode / Value"


INPut:IQ:FULLscale[:LEVel]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale[:LEVel]
INPut:IQ:FULLscale[:LEVel] <PeakVoltage>

This command defines the peak voltage at the Baseband Input connector if the full scale level is set to manual mode (see INPut:​IQ:​FULLscale:​AUTO).

Parameters:
<PeakVoltage>
0.25 V | 0.5 V | 1 V | 2 V

Peak voltage level at the connector.

For probes, the possible full scale values are adapted according to the probe's attenuation and maximum allowed power.

*RST: 1V
Example: INP:IQ:FULL 0.5V
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Full Scale Level Mode / Value"


INPut:IQ:TYPE

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:TYPE
INPut:IQ:TYPE <DataType>

This command defines the format of the input signal.

Parameters:
<DataType>
IQ | I | Q
IQ

The input signal is filtered and resampled to the sample rate of the application.

Two input channels are required for each input signal, one for the in-phase component, and one for the quadrature component.

I

The in-phase component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0 (see [SENSe:​]FREQuency:​CENTer), the in-phase component of the input signal is down-converted first (Low IF I).

Q

The quadrature component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0, the quadrature component of the input signal is down-converted first (Low IF Q).

*RST: IQ
Example:

INP:IQ:TYPE Q

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "I/Q Mode"


CALibration:AIQ:DCOFfset:I

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:I <Offset>

This command defines a DC offset of the I input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:I 0.001


CALibration:AIQ:DCOFfset:Q

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:Q
CALibration:AIQ:DCOFfset:Q <Offset>

This command defines a DC offset of the Q input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:Q 0.001


[SENSe:]PROBe<ch>:SETup:CMOFfset

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > [SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PROBe<ch>:SETup:CMOFfset <CMOffset>

Sets the common mode offset. The setting is only available if a differential probe is connected to the R&S FSW.

If the probe is disconnected, the common mode offset of the probe is reset to 0.0 V.

For details see "Common Mode Offset" .

Suffix:
<ch>
1..4

Selects the input channel.

Parameters:
<CMOffset>
Range: | -100E+24 to 100E+24
Increment: | 1E-3
*RST: | 0
Default unit: | V


TRACe:IQ:APCon[:STATe]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon[:STATe] <State>

If enabled, the average power consumption is calculated at the end of the I/Q data measurement. This command must be set before the measurement is performed!

The conversion factors A and B for the calculation are defined using TRACe:​IQ:​APCon:​A and TRACe:​IQ:​APCon:​B.

The results can be queried using TRACe:​IQ:​APCon:​RESult?.

For details see "Average Power Consumption" .

Parameters:
<State>
ON | OFF
*RST: OFF
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:A

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:A
TRACe:IQ:APCon:A <ConvFact>

Defines the conversion factor A for the calculation of the average power consumption.

For details see "Average Power Consumption" .

Parameters:
<ConvFact>
numeric value
*RST: 1.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:B

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:B
TRACe:IQ:APCon:B <ConvFact>

Defines the conversion factor B for the calculation of the average power consumption.

For details see "Average Power Consumption" .

Parameters:
<ConvFact>
numeric value
*RST: 0.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:RESult?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon:RESult?

Queries the average power consumption for an analog baseband input. This value is only calculated at the end of the I/Q data measurement if the TRACe:​IQ:​APCon[:​STATe] command is set to ON before the measurement is performed!

For details see "Average Power Consumption" .

Parameters:
<Average>
numeric value
Default unit: W
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?
Usage: Query only


Setting up Probes

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Setting up Probes
Setting up Probes

Probes can be connected to the optional BASEBAND INPUT connectors, if the Analog Baseband interface ( option R&S FSW-B71) is installed.

List of Commands
[SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:TYPE?


[SENSe:]PROBe<p>:ID:PARTnumber?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:PARTnumber?

Queries the R&S part number of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<PartNumber> | Part number in a string.
Usage: | Query only


[SENSe:]PROBe<p>:ID:SRNumber?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:ID:SRNumber?

Queries the serial number of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<SerialNo> | Serial number in a string.
Usage: | Query only


[SENSe:]PROBe<p>:SETup:MODE

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:MODE <Mode>

Select the action that is started with the micro button on the probe head.

See also: "Microbutton Action".

Suffix:
<p>
1 | 2 | 3

Selects the connector:

1 = Baseband Input I

2 = Baseband Input Q

3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")

Parameters:
<Mode>
RSINgle

Run single: starts one data acquisition.

NOACtion

Nothing is started on pressing the micro button.

*RST: RSINgle
Manual operation: See "Microbutton Action"


[SENSe:]PROBe<p>:SETup:NAME?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:NAME?

Queries the name of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<Name> | Name string
Usage: | Query only


[SENSe:]PROBe<p>:SETup:STATe?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:STATe?

Queries if the probe at the specified connector is active (detected) or not active (not detected). To switch the probe on, i.e. activate input from the connector, use INP:SEL:AIQ (see INPut:​SELect).

Suffix:
<p>
1 | 2 | 3

Selects the connector:

1 = Baseband Input I

2 = Baseband Input Q

3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")

Return values:
<State>
DETected | NDETected
*RST: NDETected
Usage: Query only


[SENSe:]PROBe<p>:SETup:TYPE?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:TYPE?
[SENSe:]PROBe<p>:SETup:TYPE?

Queries the type of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<Type> | String containing one of the following values: – None (no probe detected) – active differential – active single-ended
Usage: | Query only


Configuring the Outputs

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring the Outputs
Configuring the Outputs

Configuring trigger input/output is described in "Configuring the Trigger Output".

List of Commands
DIAGnostic:SERVice:NSOurce
OUTPut:IF:IFFRequency


DIAGnostic:SERVice:NSOurce

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring the Outputs > DIAGnostic:SERVice:NSOurce
DIAGnostic:SERVice:NSOurce <State>

This command turns the 28 V supply of the BNC connector labeled NOISE SOURCE CONTROL on the front panel on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DIAG:SERV:NSO ON
Manual operation: See "Noise Source"


OUTPut:IF:IFFRequency

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring the Data Input and Output > Configuring the Outputs > OUTPut:IF:IFFRequency
OUTPut:IF:IFFRequency <Frequency>

This command defines the frequency for the IF output. The IF frequency of the signal is converted accordingly.

This command is available in the time domain and if the IF/VIDEO/DEMOD output is configured for IF.

Parameters:
<Frequency>
*RST: 50.0 MHz


Frontend Configuration

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration
Frontend Configuration

The following commands configure frequency, amplitude and y-axis scaling settings, which represent the "frontend" of the measurement setup.

For more information see "Frontend Settings".

Contents
  • Frequency
  • Amplitude and Scaling Settings
  • Configuring the Attenuation


Frequency

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Frequency
Frequency
List of Commands
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:LINK
[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor
[SENSe:]FREQuency:OFFSet


[SENSe:]FREQuency:CENTer

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer <Frequency>

This command defines the center frequency.

Parameters:
<Frequency>

The allowed range and fmax is specified in the data sheet.

UP

Increases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

DOWN

Decreases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

*RST: | fmax/2
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Center Frequency"
See "Center frequency"


[SENSe:]FREQuency:CENTer:STEP

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP <StepSize>

This command defines the center frequency step size.

You can increase or decrease the center frequency quickly in fixed steps using the SENS:FREQ UP AND SENS:FREQ DOWN commands, see [SENSe:​]FREQuency:​CENTer.

Parameters:
<StepSize>

fmax is specified in the data sheet.

Range: | 1 to fMAX
*RST: | 0.1 x span
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Manual operation: See "Center Frequency Stepsize"


[SENSe:]FREQuency:CENTer:STEP:AUTO

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:AUTO <State>

This command couples or decouples the center frequency step size to the span.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: FREQ:CENT:STEP:AUTO ON

Activates the coupling of the step size to the span.


[SENSe:]FREQuency:CENTer:STEP:LINK

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer:STEP:LINK
[SENSe:]FREQuency:CENTer:STEP:LINK <CouplingType>

This command couples and decouples the center frequency step size to the span or the resolution bandwidth.

Parameters:
<CouplingType>
SPAN

Couples the step size to the span. Available for measurements in the frequency domain.

RBW

Couples the step size to the resolution bandwidth. Available for measurements in the time domain.

OFF

Decouples the step size.

*RST: SPAN
Example: FREQ:CENT:STEP:LINK SPAN


[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer:STEP:LINK:FACTor
[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor <Factor>

This command defines a step size factor if the center frequency step size is coupled to the span or the resolution bandwidth.

Parameters:
<Factor>
1 to 100 PCT
*RST: 10
Example: FREQ:CENT:STEP:LINK:FACT 20PCT


[SENSe:]FREQuency:OFFSet

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Frequency > [SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:OFFSet <Offset>

This command defines a frequency offset.

If this value is not 0 Hz, the application assumes that the input signal was frequency shifted outside the application. All results of type "frequency" will be corrected for this shift numerically by the application.

See also "Frequency Offset".

Note: In MSRA mode, the setting command is only available for the MSRA Master. For MSRA applications, only the query command is available.

Parameters:
<Offset>
Range: | -100 GHz to 100 GHz
*RST: | 0 Hz
Example: FREQ:OFFS 1GHZ
Usage: SCPI confirmed
Manual operation: See "Frequency Offset"


Amplitude and Scaling Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings
Amplitude and Scaling Settings
Useful commands for amplitude settings described elsewhere:
  • INPut:​COUPling
  • INPut:​IMPedance
  • [SENSe:​]ADJust:​LEVel
Remote commands exclusive to amplitude settings:
List of Commands
CALCulate<n>:UNIT:POWer
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
INPut:GAIN:STATe
INPut:GAIN[:VALue]


CALCulate<n>:UNIT:POWer

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > CALCulate<n>:UNIT:POWer
CALCulate<n>:UNIT:POWer <Unit>

This command selects the unit of the y-axis.

The unit applies to all measurement windows.

Parameters:
<Unit>
DBM | V | A | W | DBPW | WATT | DBUV | DBMV | VOLT | DBUA | AMPere
*RST: dBm
Example: CALC:UNIT:POW DBM

Sets the power unit to dBm.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

Automatic scaling of the y-axis is performed once, then switched off again.

Usage: | SCPI confirmed
Manual operation: | See "Auto Scale Once"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum <Value>

This command defines the maximum value of the y-axis for the selected result display.

Parameters:
<Value>
<numeric value>
*RST: depends on the result display

The unit and range depend on the result display.

Example: DISP:TRAC:Y:MIN -60
DISP:TRAC:Y:MAX 0

Defines the y-axis with a minimum value of -60 and maximum value of 0.

Manual operation: See "Y-Maximum, Y-Minimum"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum <Value>

This command defines the minimum value of the y-axis for the selected result display.

Parameters:
<Value>
<numeric value>
*RST: depends on the result display

The unit and range depend on the result display.

Example: DISP:TRAC:Y:MIN -60
DISP:TRAC:Y:MAX 0

Defines the y-axis with a minimum value of -60 and maximum value of 0.

Manual operation: See "Y-Maximum, Y-Minimum"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision <Value>

This remote command determines the grid spacing on the Y-axis for all diagrams, where possible.

Parameters:
<Value>
numeric value WITHOUT UNIT (unit according to the result display)

Defines the range per division (total range = 10*<Value>)

*RST: depends on the result display
Example: DISP:TRAC:Y:PDIV 10

Sets the grid spacing to 10 units (e.g. dB) per division

(For example 10 dB in the Code Domain Power result display.)


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel <ReferenceLevel>

This command defines the reference level.

With a reference level offset ≠ 0, the value range of the reference level is modified by the offset.

Parameters:
<ReferenceLevel>

The unit is variable.

Range: | see datasheet
*RST: | 0 dBm
Example: DISP:TRAC:Y:RLEV -60dBm
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Reference Level"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet <Offset>

This command defines a reference level offset.

Parameters:
<Offset>
Range: | -200 dB to 200 dB
*RST: | 0dB
Example: DISP:TRAC:Y:RLEV:OFFS -10dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Shifting the Display (Offset)"


INPut:GAIN:STATe

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > INPut:GAIN:STATe
INPut:GAIN:STATe <State>

This command turns the preamplifier on and off.

The command requires option R&S FSW-B24.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:GAIN:STAT ON

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


INPut:GAIN[:VALue]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Amplitude and Scaling Settings > INPut:GAIN[:VALue]
INPut:GAIN[:VALue] <Gain>

This command selects the preamplification level if the preamplifier is activated (INP:GAIN:STAT ON, see INPut:​GAIN:​STATe).

The command requires option R&S FSW-B24.

Parameters:
<Gain>
15 dB | 30 dB

The availability of preamplification levels depends on the R&S FSW model.

R&S FSW8/13: 15dB and 30 dB

R&S FSW26 or higher: 30 dB

All other values are rounded to the nearest of these two.

*RST: OFF
Example: INP:GAIN:VAL 30

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


Configuring the Attenuation

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Configuring the Attenuation
Configuring the Attenuation
List of Commands
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe


INPut:ATTenuation

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Configuring the Attenuation > INPut:ATTenuation
INPut:ATTenuation <Attenuation>

This command defines the total attenuation for RF input.

If an electronic attenuator is available and active, the command defines a mechanical attenuation (see INPut:​EATT:​STATe).

If you set the attenuation manually, it is no longer coupled to the reference level, but the reference level is coupled to the attenuation. Thus, if the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

This function is not available if the Digital Baseband Interface (R&S FSW-B17) is active.

Parameters:
<Attenuation>
Range: | see data sheet
Increment: | 5 dB
*RST: | 10 dB (AUTO is set to ON)
Example: INP:ATT 30dB

Defines a 30 dB attenuation and decouples the attenuation from the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:ATTenuation:AUTO

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Configuring the Attenuation > INPut:ATTenuation:AUTO
INPut:ATTenuation:AUTO <State>

This command couples or decouples the attenuation to the reference level. Thus, when the reference level is changed, the R&S FSW determines the signal level for optimal internal data processing and sets the required attenuation accordingly.

This function is not available if the Digital Baseband Interface (R&S FSW-B17) is active.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:ATT:AUTO ON

Couples the attenuation to the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:EATT

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Configuring the Attenuation > INPut:EATT
INPut:EATT <Attenuation>

This command defines an electronic attenuation manually. Automatic mode must be switched off (INP:EATT:AUTO OFF, see INPut:​EATT:​AUTO).

If the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

This command is only available with option R&S FSW-B25.

It is not available if R&S FSW-B17 is active.

Parameters:
<Attenuation>
attenuation in dB
Range: | see data sheet
Increment: | 1 dB
*RST: | 0 dB (OFF)
Example: INP:EATT:AUTO OFF
INP:EATT 10 dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:AUTO

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Configuring the Attenuation > INPut:EATT:AUTO
INPut:EATT:AUTO <State>

This command turns automatic selection of the electronic attenuation on and off.

If on, electronic attenuation reduces the mechanical attenuation whenever possible.

This command is only available with option R&S FSW-B25.

It is not available if R&S FSW-B17 is active.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:EATT:AUTO OFF
Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:STATe

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Frontend Configuration > Configuring the Attenuation > INPut:EATT:STATe
INPut:EATT:STATe <State>

This command turns the electronic attenuator on and off.

This command is only available with option R&S FSW-B25.

It is not available if R&S FSW-B17 is active.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:EATT:STAT ON

Switches the electronic attenuator into the signal path.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


Configuring Triggered Measurements

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements
Configuring Triggered Measurements

The following commands are required to configure a triggered measurement in a remote environment. The tasks for manual operation are described in "Trigger Settings".

The *OPC command should be used after commands that retrieve data so that subsequent commands to change the selected trigger source are held off until after the sweep is completed and the data has been returned.

Contents
  • Configuring the Triggering Conditions
  • Configuring the Trigger Output


Configuring the Triggering Conditions

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions
Configuring the Triggering Conditions
List of Commands
TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel:VIDeo
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:TIME:RINTerval


TRIGger[:SEQuence]:BBPower:HOLDoff

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:BBPower:HOLDoff <Period>

This command defines the holding time before the baseband power trigger event.

The command requires the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

Note that this command is maintained for compatibility reasons only. Use the TRIGger[:​SEQuence]:​IFPower:​HOLDoff command for new remote control programs.

Parameters:
<Period>
Range: | 150 ns to 1000 s
*RST: | 150 ns
Example: TRIG:SOUR BBP

Sets the baseband power trigger source.

TRIG:BBP:HOLD 200 ns

Sets the holding time to 200 ns.


TRIGger[:SEQuence]:DTIMe

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:DTIMe <DropoutTime>

Defines the time the input signal must stay below the trigger level before a trigger is detected again.

For input from the Analog Baseband Interface (R&S FSW-B71) using the baseband power trigger (BBP), the default drop out time is set to 100 ns to avoid unintentional trigger events (as no hysteresis can be configured in this case).

Parameters:
<DropoutTime>

Dropout time of the trigger.

Range: | 0 s to 10.0 s
*RST: | 0 s
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Drop-Out Time"


TRIGger[:SEQuence]:HOLDoff[:TIME]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:HOLDoff[:TIME] <Offset>

Defines the time offset between the trigger event and the start of the sweep (data capturing).

Parameters:
<Offset>
*RST: 0 s
Example: TRIG:HOLD 500us
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger Offset"


TRIGger[:SEQuence]:IFPower:HOLDoff

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HOLDoff <Period>

This command defines the holding time before the next trigger event.

Note that this command can be used for any trigger source, not just IF Power (despite the legacy keyword).

Note: If you perform gated measurements in combination with the IF Power trigger, the R&S FSW ignores the holding time for frequency sweep, FFT sweep, zero span and I/Q data measurements.

Parameters:
<Period>
Range: | 0 s to 10 s
*RST: | 0 s
Example: TRIG:SOUR EXT

Sets an external trigger source.

TRIG:IFP:HOLD 200 ns

Sets the holding time to 200 ns.

Manual operation: See "Trigger Holdoff"


TRIGger[:SEQuence]:IFPower:HYSTeresis

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:IFPower:HYSTeresis <Hysteresis>

This command defines the trigger hysteresis, which is only available for "IF Power" trigger sources.

Parameters:
<Hysteresis>
Range: | 3 dB to 50 dB
*RST: | 3 dB
Example: TRIG:SOUR IFP

Sets the IF power trigger source.

TRIG:IFP:HYST 10DB

Sets the hysteresis limit value.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Hysteresis"


TRIGger[:SEQuence]:LEVel:BBPower

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:BBPower <Level>

This command sets the level of the baseband power trigger.

This command is available for the Digital Baseband Interface (R&S FSW-B17) and the Analog Baseband Interface (R&S FSW-B71).

Parameters:
<Level>
Range: | -50 dBm to +20 dBm
*RST: | -20 dBm
Example: TRIG:LEV:BB -30DBM
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


TRIGger[:SEQuence]:LEVel[:EXTernal<port>]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel[:EXTernal<port>] <TriggerLevel>

This command defines the level the external signal must exceed to cause a trigger event.

Note that the variable INPUT/OUTPUT connectors (ports 2+3) must be set for use as input using the OUTPut:​TRIGger<port>:​DIRection command.

Suffix:
<port>

Selects the trigger port.

1 = trigger port 1 (TRIGGER INPUT connector on front panel)

2 = trigger port 2 (TRIGGER INPUT/OUTPUT connector on front panel)

3 = trigger port 3 (TRIGGER3 INPUT/OUTPUT connector on rear panel)

Parameters:
<TriggerLevel>
Range: | 0.5 V to 3.5 V
*RST: | 1.4 V
Example: TRIG:LEV 2V
Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:LEVel:IFPower

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IFPower <TriggerLevel>

This command defines the power level at the third intermediate frequency that must be exceeded to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

For compatibility reasons, this command is also available for the "baseband power" trigger source when using the Analog Baseband Interface (R&S FSW-B71).

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -10 dBm
Example: TRIG:LEV:IFP -30DBM
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .


TRIGger[:SEQuence]:LEVel:IQPower

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:IQPower <TriggerLevel>

This command defines the magnitude the I/Q data must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed.

Parameters:
<TriggerLevel>
Range: | -130 dBm to 30 dBm
*RST: | -20 dBm
Example: TRIG:LEV:IQP -30DBM
Example:

See "Basic I/Q Analysis with Improved Performance" .


TRIGger[:SEQuence]:LEVel:RFPower

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel:RFPower <TriggerLevel>

This command defines the power level the RF input must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

The input signal must be between 500 MHz and 8 GHz.

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -20 dBm
Example: TRIG:LEV:RFP -30dBm


TRIGger[:SEQuence]:LEVel:VIDeo

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:VIDeo
TRIGger[:SEQuence]:LEVel:VIDeo <Level>

This command defines the level the video signal must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed.

Parameters:
<Level>
Range: | 0 PCT to 100 PCT
*RST: | 50 PCT
Example: TRIG:LEV:VID 50PCT


TRIGger[:SEQuence]:SLOPe

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SLOPe <Type>

For external and time domain trigger sources you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Parameters:
<Type>
POSitive | NEGative
POSitive

Triggers when the signal rises to the trigger level (rising edge).

NEGative

Triggers when the signal drops to the trigger level (falling edge).

*RST: POSitive
Example: TRIG:SLOP NEG
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Slope"


TRIGger[:SEQuence]:SOURce

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:SOURce <Source>

This command selects the trigger source.

Note on external triggers:

If a measurement is configured to wait for an external trigger signal in a remote control program, remote control is blocked until the trigger is received and the program can continue. Make sure this situation is avoided in your remote control programs.

Parameters:
<Source>
IMMediate

Free Run

EXTernal

Trigger signal from the TRIGGER INPUT connector.

EXT2

Trigger signal from the TRIGGER INPUT/OUTPUT connector.

Note: Connector must be configured for "Input".

EXT3

Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector.

Note: Connector must be configured for "Input".

RFPower

First intermediate frequency

(Frequency and time domain measurements only.)

Not available for input from the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

IFPower

Second intermediate frequency

(For frequency and time domain measurements only.)

Not available for input from the Digital Baseband Interface (R&S FSW-B17). For input from the Analog Baseband Interface (R&S FSW-B71), this parameter is interpreted as BBPower for compatibility reasons.

TIME

Time interval

(For frequency and time domain measurements only.)

PSEN

External power sensor

(For frequency and time domain measurements only.)

GP0 | GP1 | GP2 | GP3 | GP4 | GP5

For applications that process I/Q data, such as the I/Q Analyzer or optional applications, and only if the Digital Baseband Interface (R&S FSW-B17) is available.

Defines triggering of the measurement directly via the LVDS connector. The parameter specifies which general purpose bit (0 to 5) will provide the trigger data.

The assignment of the general purpose bits used by the Digital IQ trigger to the LVDS connector pins is provided in "Digital I/Q".

*RST: IMMediate
Example: TRIG:SOUR EXT

Selects the external trigger input as source of the trigger signal

Example:

See "Basic I/Q Analysis with Improved Performance" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Example:

See "Programming Example" .

Manual operation: See "Trigger Source"
See "Free Run"
See "External Trigger 1/2/3"
See "Digital I/Q"
See "IF Power"


TRIGger[:SEQuence]:TIME:RINTerval

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:TIME:RINTerval
TRIGger[:SEQuence]:TIME:RINTerval <Interval>

This command defines the repetition interval for the time trigger.

Parameters:
<Interval>
2.0 ms to 5000
Range: | 2 ms to 5000 s
*RST: | 1.0 s
Example: TRIG:SOUR TIME

Selects the time trigger input for triggering.

TRIG:TIME:RINT 50

The sweep starts every 50 s.


Configuring the Trigger Output

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Trigger Output
Configuring the Trigger Output

The following commands are required to send the trigger signal to one of the variable TRIGGER INPUT/OUTPUT connectors. The tasks for manual operation are described in "Trigger 2/3".

List of Commands
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth


OUTPut:TRIGger<port>:DIRection

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:DIRection <Direction>

This command selects the trigger direction.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Direction>
INPut

Port works as an input.

OUTPut

Port works as an output.

*RST: INPut
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"


OUTPut:TRIGger<port>:LEVel

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:LEVel <Level>

This command defines the level of the signal generated at the trigger output.

This command works only if you have selected a user defined output with OUTPut:​TRIGger<port>:​OTYPe.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Level>
HIGH

TTL signal.

LOW

0 V

*RST: LOW
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"
See "Level"


OUTPut:TRIGger<port>:OTYPe

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:OTYPe <OutputType>

This command selects the type of signal generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<OutputType>
DEVice

Sends a trigger signal when the R&S FSW has triggered internally.

TARMed

Sends a trigger signal when the trigger is armed and ready for an external trigger event.

UDEFined

Sends a user defined trigger signal. For more information see OUTPut:​TRIGger<port>:​LEVel.

*RST: DEVice
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Output Type"


OUTPut:TRIGger<port>:PULSe:IMMediate

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:IMMediate

This command generates a pulse at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: Event
Manual operation: See "Send Trigger"


OUTPut:TRIGger<port>:PULSe:LENGth

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:LENGth
OUTPut:TRIGger<port>:PULSe:LENGth <Length>

This command defines the length of the pulse generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Length>

Pulse length in seconds.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Pulse Length"


Signal Capturing

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Signal Capturing
Signal Capturing

The following commands configure how much and how data is captured from the input signal.

MSRA operating mode

In MSRA operating mode, only the MSRA Master channel actually captures data from the input signal. The data acquisition commands for the CDMA2000 application in MSRA mode define the application data (see "Configuring the Application Data Range (MSRA mode only)").

For details on the MSRA operating mode see "Applications and Operating Modes" .

List of Commands
[SENSe:]CDPower:IQLength
[SENSe:]CDPower:QINVert
[SENSe:]CDPower:SET:COUNt


[SENSe:]CDPower:IQLength

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Signal Capturing > [SENSe:]CDPower:IQLength
[SENSe:]CDPower:IQLength <CaptureLength>

This command sets the capture length in multiples of the power control group.

Parameters:
<CaptureLength>
Range: | 2 to 64
*RST: | 3
Example:

SENS:CDP:IQLength 3

Manual operation: See "Number of PCGs"


[SENSe:]CDPower:QINVert

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Signal Capturing > [SENSe:]CDPower:QINVert
[SENSe:]CDPower:QINVert <State>

This command inverts the Q component of the signal.

Parameters:
ON | OFF
*RST: OFF
Example: CDP:QINV ON

Activates inversion of Q component.

Manual operation: See "Invert Q"


[SENSe:]CDPower:SET:COUNt

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Signal Capturing > [SENSe:]CDPower:SET:COUNt
[SENSe:]CDPower:SET:COUNt <NumberSets>

This command sets the number of sets to be captured and stored in the instrument's memory. Refer to "Number of Sets" for more information.

Parameters:
<NumberSets>
Range: | 1 to 1500 (BTS mode) or 810 (MS mode)
*RST: | 1
Example:

CDP:SET:COUN 10

Sets the number of sets to be captured to 10.

Manual operation: See "Number of Sets"


Channel Detection

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Channel Detection
Channel Detection

The channel detection settings determine which channels are found in the input signal. The commands for working with channel tables are described here.

When the channel type is required as a parameter by a remote command or provided as a result for a remote query, the following abbreviations and assignments to a numeric value are used:

BTS channel types and their assignment to a numeric parameter value
Parameter | Channel type
0 | PICH
1 | SYNC
2 | PCH
3 | TDPICH
4 | APICH
5 | ATDPICH
6 | BCH
7 | CPCCH
8 | CACH
9 | CCCH
10 | CHAN
11 | INACTIVE
12 | PDCCH
13 | PDCH
Allowed RC values depending on channel type for BTS measurements
RC | Channel type | Modulation
0 | all special channels (not CHAN, PDCH) |
1 | 2 | 3 | 4 | 5 | CHAN |
10 | PDCH | QPSK
20 | PDCH | 8PSK
30 | PDCH | 16QAM
MS channel types and their assignment to a numeric parameter value
Parameter | Channel type
0 | PICH
1 | EACH
2 | CCCH
3 | DCCH
4 | ACKCH
5 | CQICH
6 | FCH
7 | S1CH
8 | S2CH
9 | INACTIVE
Contents
  • General Channel Detection
  • Managing Channel Tables
  • Configuring Channel Tables


General Channel Detection

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Channel Detection > General Channel Detection
General Channel Detection

The following commands configure how channels are detected in general.

Useful commands for general channel detection described elsewhere:
  • CONFigure:​CDPower[:​BTS]:​CTABle[:​STATe]
  • CONFigure:​CDPower[:​BTS]:​CTABle:​SELect
Remote commands exclusive to general channel detection:
List of Commands
[SENSe:]CDPower:ICTReshold


[SENSe:]CDPower:ICTReshold

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Channel Detection > General Channel Detection > [SENSe:]CDPower:ICTReshold
[SENSe:]CDPower:ICTReshold <ThresholdLevel>

This command defines the minimum power that a single channel must have compared to the total signal in order to be regarded as an active channel. Channels below the specified threshold are regarded as "inactive".

Parameters:
<ThresholdLevel>
Range: | -100 dB to 0 dB
*RST: | -60 dB
Example: CDP:ICTR -50

Sets the Inactice Channel Threshold to -50 dB.

Manual operation: See "Inactive Channel Threshold"


Managing Channel Tables

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Channel Detection > Managing Channel Tables
Managing Channel Tables
List of Commands
CONFigure:CDPower[:BTS]:CTABle:CATalog?
CONFigure:CDPower[:BTS]:CTABle:COPY
CONFigure:CDPower[:BTS]:CTABle:DELete
CONFigure:CDPower[:BTS]:CTABle:RESTore
CONFigure:CDPower[:BTS]:CTABle:SELect
CONFigure:CDPower[:BTS]:CTABle[:STATe]


CONFigure:CDPower[:BTS]:CTABle:CATalog?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Channel Detection > Managing Channel Tables > CONFigure:CDPower[:BTS]:CTABle:CATalog?
CONFigure:CDPower[:BTS]:CTABle:CATalog?

This command reads out the names of all channel tables stored on the instrument. The first two result values are global values for all channel tables, the subsequent values are listed for each individual table.

Return values:
<TotalSize> | Sum of file sizes of all channel table files (in bytes)
<FreeMem> | Available memory left on hard disk (in bytes)
<FileName> | File name of individual channel table file
<FileSize> | File size of individual channel table file (in bytes)
Example: | CONF:CDP:CTAB:CAT? Sample result (description see table below): 52853,2634403840,3GB_1_16.XML,3469,3GB_1_32.XML,5853,3GB_1_64.XML,10712,3GB_2.XML,1428,3GB_3_16.XML,3430,3GB_3_32.XML,5868,3GB_4.XML,678,3GB_5_2.XML,2554,3GB_5_4.XML,4101,3GB_5_8.XML,7202,3GB_6.XML,7209,MYTABLE.XML,349
Usage: | Query only
Manual operation: | See "Predefined Tables"
Description of query results in example:
Value | Description
52853 | Total size of all channel table files: 52583 bytes
2634403840 | Free memory on hard disk: 2.6 Gbytes
3GB_1_16.XML | Channel table 1: 3GB_1_16.XML
3469 | File size for channel table 1: 3469 bytes
3GB_1_32.XML | Channel table 2: 3GB_1_32.XML
5853 | File size for channel table 2: 5853 bytes
3GB_1_64.XML | Channel table 3: 3GB_1_64.XML
10712 | File size for channel table 3: 10712 bytes
... | Channel table x: ...


CONFigure:CDPower[:BTS]:CTABle:COPY

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Channel Detection > Managing Channel Tables > CONFigure:CDPower[:BTS]:CTABle:COPY
CONFigure:CDPower[:BTS]:CTABle:COPY <FileName>

This command copies one channel table into another one. The channel table to be copied is selected with command CONFigure:​CDPower[:​BTS]:​CTABle:​NAME.

Parameters:
<FileName> | string with a maximum of 8 characters name of the new channel table
Example: | CONF:CDP:CTAB:NAME 'NEW_TAB' Defines the channel table name to be copied. CONF:CDP:CTAB:COPY 'CTAB_2' Copies channel table 'NEW_TAB' to 'CTAB_2'.
Usage: | Event
Manual operation: | See "Copying a Table"


CONFigure:CDPower[:BTS]:CTABle:DELete

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Channel Detection > Managing Channel Tables > CONFigure:CDPower[:BTS]:CTABle:DELete
CONFigure:CDPower[:BTS]:CTABle:DELete

This command deletes the selected channel table. The channel table to be deleted is selected with the command CONFigure:​CDPower[:​BTS]:​CTABle:​NAME.

Example: | CONF:CDP:CTAB:NAME 'NEW_TAB' Defines the channel table name to be deleted. CONF:CDP:CTAB:DEL Deletes the table.
Manual operation: | See "Deleting a Table"


CONFigure:CDPower[:BTS]:CTABle:RESTore

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Channel Detection > Managing Channel Tables > CONFigure:CDPower[:BTS]:CTABle:RESTore
CONFigure:CDPower[:BTS]:CTABle:RESTore

This command restores the predefined channel tables to their factory-set values. In this way, you can undo unintentional overwriting.

Example: | CONF:CDP:CTAB:REST Restores the channel table.
Usage: | Event
Manual operation: | See "Restoring Default Tables"


CONFigure:CDPower[:BTS]:CTABle:SELect

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Channel Detection > Managing Channel Tables > CONFigure:CDPower[:BTS]:CTABle:SELect
CONFigure:CDPower[:BTS]:CTABle:SELect <FileName>

This command selects a predefined channel table file for comparison during channel detection.

Before using this command, the channel table must be switched on first with the command CONFigure:​CDPower[:​BTS]:​CTABle[:​STATe].

Parameters:
<FileName>
*RST: RECENT
Example: CONF:CDP:CTAB ON

Switches the channel table on.

CONF:CDP:CTAB:SEL 'CTAB_1'

Selects the predefined channel table 'CTAB_1'.

Manual operation: See "Selecting a Table"


CONFigure:CDPower[:BTS]:CTABle[:STATe]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Channel Detection > Managing Channel Tables > CONFigure:CDPower[:BTS]:CTABle[:STATe]
CONFigure:CDPower[:BTS]:CTABle[:STATe] <State>

This command switches the channel table on or off.

When switched on, the measured channel table is stored under the name "RECENT" and is selected for use. After the "RECENT" channel table is switched on, another channel table can be selected with the command CONFigure:​CDPower[:​BTS]:​CTABle:​SELect.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

CONF:CDP:CTAB ON

Manual operation: See "Using Predefined Channel Tables"


Configuring Channel Tables

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Channel Detection > Configuring Channel Tables
Configuring Channel Tables

Some general settings and functions are available when configuring a predefined channel table.

List of Commands
CONFigure:CDPower[:BTS]:CTABle:COMMent
CONFigure:CDPower[:BTS]:CTABle:DATA
CONFigure:CDPower[:BTS]:CTABle:DATA
CONFigure:CDPower[:BTS]:CTABle:NAME


CONFigure:CDPower[:BTS]:CTABle:COMMent

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Channel Detection > Configuring Channel Tables > CONFigure:CDPower[:BTS]:CTABle:COMMent
CONFigure:CDPower[:BTS]:CTABle:COMMent <Comment>

This command defines a comment for the selected channel table:

Prior to this command, the name of the channel table has to be defined with command CONFigure:​CDPower[:​BTS]:​CTABle:​NAME.

Parameters:
<Comment> |
Example: | CONF:CDP:CTAB:NAME 'NEW_TAB' Defines the channel table name. CONF:CDP:CTAB:COMM 'Comment for table 1' Defines a comment for the table. CONF:CDP:CTAB:DATA 8,0,0,0,0,0,1,0.00,8,1,0,0,0,0,1,0.00,7,1,0,256,8,0,1,0.00 Defines the table values.
Manual operation: | See "Comment"


CONFigure:CDPower[:BTS]:CTABle:DATA

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Channel Detection > Configuring Channel Tables > CONFigure:CDPower[:BTS]:CTABle:DATA
CONFigure:CDPower[:BTS]:CTABle:DATA <ChannelType>, <CodeClass>, <CodeNumber>, <Modulation>, <Reserved1>, <Reserved2>, <Status>, <CDPRelative>

This command defines a channel table.

The following description applies to cdma2000 BTS mode only. For MS mode, see CONFigure:​CDPower[:​BTS]:​CTABle:​DATA.

Before using this command, you must set the name of the channel table using the CONFigure:​CDPower[:​BTS]:​CTABle:​NAME command.

For a detailed description of the parameters refer to "BTS Channel Details".

Parameters:
<ChannelType> | Numeric channel type according to table "BTS channel types and their assignment to a numeric parameter value"
<CodeClass> | 2..7 Code class depending on spreading factor; see table "Relationship between various code parameters for CDMA2000 BTS signals"
<CodeNumber> | 0…spreading factor-1 Channel number (without SF)
<Modulation> | Modulation type including mapping Modulation types QPSK/8-PSK/16-QAM have complex values 0 BPSK-I 1 BPSK-Q 2 QPSK 3 8-PSK 4 16-QAM
<Reserved1> | Always 0 (reserved)
<Reserved2> | Always 0 (reserved)
<Status> | 0: inactive, 1: active Can be used in a setting command to disable a channel temporarily
<CDPRelative> | Power value in dB.
Example: | CONF:CDP:CTAB:NAME 'NEW_TAB' Selects channel table for editing. If a channel table with this name does not exist, a new channel table is created. CONF:CDP:CTAB:DATA 0,6,0,0,0,0,1,0.0,10,5,3,4,0,0,1,0.0 Defines a table with the following channels: PICH 0.64 and data channel with RC4/Walsh code 3.32.
Mode: | BTS application only
Manual operation: | See "Channel Type" See "Channel Number (Ch. SF)" See "Power" See "Status"


CONFigure:CDPower[:BTS]:CTABle:DATA

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Channel Detection > Configuring Channel Tables > CONFigure:CDPower[:BTS]:CTABle:DATA
CONFigure:CDPower[:BTS]:CTABle:DATA <ChannelType>, <CodeClass>, <CodeNumber>, <Mapping>, <Reserved1>, <Reserved2>, <Status>, <CDPRelative>

This command defines a channel table. The following description applies to MS mode only. For BTS mode, see CONFigure:​CDPower[:​BTS]:​CTABle:​DATA.

Before using this command, you must set the name of the channel table using the CONFigure:​CDPower[:​BTS]:​CTABle:​NAME command.

For a detailed description of the parameters refer to "MS Channel Details".

Parameters:
<ChannelType> | Numeric channel type according to table "MS channel types and their assignment to a numeric parameter value"
<CodeClass> | 2 to 4 Code class depending on spreading factor; see table "Relationship between various code parameters for CDMA2000 MS signals"
<CodeNumber> | 0…spreading factor-1 Channel number (without SF)
<Mapping> | 0 I branch 1 Q branch
<Reserved1>, <Reserved2> | Always 0 (reserved for future use)
<Status> | 0: inactive, 1: active Can be used in a setting command to disable a channel temporarily
<CDPRelative> | Power value in dB.
Example: | "INST:SEL M2K" 'Activate cdma2000 MS mode "CONF:CDP:CTAB:NAME 'NEW_TAB'" 'Select table to edit "CONF:CDP:CTAB:DATA 0,4,0,0,65535,0,1,0, 1,4,0,0,43690,0,1,0, 2,2,2,1,65535,0,1,0"
Mode: | MS mode only
Manual operation: | See "Channel Type" See "Channel Number (Ch. SF)" See "Power" See "Status"


CONFigure:CDPower[:BTS]:CTABle:NAME

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Channel Detection > Configuring Channel Tables > CONFigure:CDPower[:BTS]:CTABle:NAME
CONFigure:CDPower[:BTS]:CTABle:NAME <Name>

This command creates a new channel table file or selects an existing channel table in order to copy or delete it.

Parameters:
<Name>
string with a maximum of 8 characters

name of the channel table

*RST: RECENT
Example:

CONF:CDP:CTAB:NAME 'NEW_TAB'

Manual operation: See "Creating a New Table"
See "Name"


Sweep Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Sweep Settings
Sweep Settings
List of Commands
[SENSe:]AVERage:COUNt
[SENSe:]SWEep:COUNt


[SENSe:]AVERage:COUNt

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Sweep Settings > [SENSe:]AVERage:COUNt
[SENSe:]AVERage:COUNt <AverageCount>

This command defines the number of sweeps that the application uses to average traces.

In case of continuous sweeps, the application calculates the moving average over the average count.

In case of single sweep measurements, the application stops the measurement and calculates the average after the average count has been reached.

Parameters:
<AverageCount>

If you set a average count of 0 or 1, the application performs one single sweep in single sweep mode.

In continuous sweep mode, if the average count is set to 0, a moving average over 10 sweeps is performed.

Range: | 0 to 200000
*RST: | 0
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Sweep/Average Count"


[SENSe:]SWEep:COUNt

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Sweep Settings > [SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt <SweepCount>

This command defines the number of sweeps that the application uses to average traces.

(For Pulse measurements, see also "Trace Statistics" ).

In case of continuous sweeps, the application calculates the moving average over the average count.

In case of single sweeps, the application stops the measurement and calculates the average after the average count has been reached.

Parameters:
<SweepCount>

When you set a sweep count of 0 or 1, the R&S FSW performs one single sweep in single sweep mode.

In continuous sweep mode, if the sweep count is set to 0, a moving average over 10 sweeps is performed.

Range: | 0 to 200000
*RST: | 0
Example: SWE:COUN 64

Sets the number of sweeps to 64.

INIT:CONT OFF

Switches to single sweep mode.

INIT;*WAI

Starts a sweep and waits for its end.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Sweep/Average Count"


Automatic Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Automatic Settings
Automatic Settings
MSRA operating mode

In MSRA operating mode, the following automatic commands are not available, as they require a new data acquisition. However, CDMA2000 applications cannot perform data acquisition in MSRA operating mode.

Useful commands for adjusting settings automatically described elsewhere:
  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO ONCE
Remote commands exclusive to adjusting settings automatically:
List of Commands
[SENSe:]ADJust:ALL
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:LEVel


[SENSe:]ADJust:ALL

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Automatic Settings > [SENSe:]ADJust:ALL
[SENSe:]ADJust:ALL

This command initiates a measurement to determine and set the ideal settings for the current task automatically (only once for the current measurement).

This includes:

  • Reference level
  • Scaling
Example: | ADJ:ALL
Usage: | Event
Manual operation: | See "Adjusting all Determinable Settings Automatically (Auto All)"


[SENSe:]ADJust:CONFigure:DURation

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Automatic Settings > [SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation <Duration>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command defines the length of the measurement if [SENSe:​]ADJust:​CONFigure:​DURation:​MODE is set to MANual.

Parameters:
<Duration>
Numeric value in seconds
Range: | 0.001 to 16000.0
*RST: | 0.001
Default unit: | s
Example: ADJ:CONF:DUR:MODE MAN

Selects manual definition of the measurement length.

ADJ:CONF:LEV:DUR 5ms

Length of the measurement is 5 ms.

Manual operation: See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:DURation:MODE

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Automatic Settings > [SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:DURation:MODE <Mode>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command selects the way the R&S FSW determines the length of the measurement .

Parameters:
<Mode>
AUTO

The R&S FSW determines the measurement length automatically according to the current input data.

MANual

The R&S FSW uses the measurement length defined by [SENSe:​]ADJust:​CONFigure:​DURation.

*RST: AUTO
Manual operation: See "Resetting the Automatic Measurement Time (Meastime Auto)"
See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Automatic Settings > [SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:LOW 2

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level falls below 18 dBm.

Manual operation: See "Lower Level Hysteresis"


[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Automatic Settings > [SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:UPP 2
Example:

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level rises above 22 dBm.

Manual operation: See "Upper Level Hysteresis"


[SENSe:]ADJust:LEVel

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Automatic Settings > [SENSe:]ADJust:LEVel
[SENSe:]ADJust:LEVel

This command initiates a single (internal) measurement that evaluates and sets the ideal reference level for the current input data and measurement settings. This ensures that the settings of the RF attenuation and the reference level are optimally adjusted to the signal level without overloading the R&S FSW or limiting the dynamic range by an S/N ratio that is too small.

Example: | ADJ:LEV
Usage: | Event
Manual operation: | See "Setting the Reference Level Automatically (Auto Level)"


Evaluation Range

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Evaluation Range
Evaluation Range

The evaluation range defines which data is evaluated in the result display.

List of Commands
[SENSe:]CDPower:CODE
[SENSe:]CDPower:MAPPing
[SENSe:]CDPower:SET
[SENSe:]CDPower:SLOT


[SENSe:]CDPower:CODE

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Evaluation Range > [SENSe:]CDPower:CODE
[SENSe:]CDPower:CODE <CodeNo>

This command selects the code number.

For further details refer to "Code Number".

Parameters:
<CodeNo>
<numeric value>
Range: | 0 to base spreading factor - 1
Increment: | 1
*RST: | 0
Example: CDP:CODE 8

Selects the eighth channel.

Manual operation: See "Code Number"


[SENSe:]CDPower:MAPPing

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Evaluation Range > [SENSe:]CDPower:MAPPing
[SENSe:]CDPower:MAPPing <SignalComponent>

This command switches between the I and Q branch of the signal.

Parameters:
<SignalComponent>
I | Q
*RST: Q
Example:

CDP:MAPP Q

Manual operation: See "Mapping"
See "Branch (MS application only)"


[SENSe:]CDPower:SET

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Evaluation Range > [SENSe:]CDPower:SET
[SENSe:]CDPower:SET <SetNo>

This command selects a specific set for further analysis. The number of sets has to be defined with the [SENSe:​]CDPower:​SET:​COUNt command before using this command.

Parameters:
<SetNo>
Range: | 0 to SET COUNT -1
Increment: | 1
*RST: | 0
Example: CDP:SET:COUN 10

Selects the 11th set for further analysis (counting starts with 0).

Manual operation: See "Set to Analyze"


[SENSe:]CDPower:SLOT

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Evaluation Range > [SENSe:]CDPower:SLOT
[SENSe:]CDPower:SLOT <numeric value>

This command selects the slot (PCG) to be analyzed.

Parameters:
<numeric value>
Range: | 0 to 63
Increment: | 1
*RST: | 0
Example: CDP:SLOT 7

Selects slot number 7 for analysis.

Manual operation: See "Power Control Group"


Code Domain Analysis Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Code Domain Analysis Settings
Code Domain Analysis Settings

Some evaluations provide further settings for the results. The commands for Code Domain Analysis are described here.

List of Commands
[SENSe:]CDPower:NORMalize
[SENSe:]CDPower:ORDer
[SENSe:]CDPower:PDISplay
[SENSe:]CDPower:PPReference
[SENSe:]CDPower:PREFerence
[SENSe:]CDPower:SFACtor
[SENSe:]CDPower:TPMeas


[SENSe:]CDPower:NORMalize

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Code Domain Analysis Settings > [SENSe:]CDPower:NORMalize
[SENSe:]CDPower:NORMalize <State>

If enabled, the I/Q offset is eliminated from the measured signal. This is useful to deduct a DC offset to the baseband caused by the DUT, thus improving the EVM. Note, however, that for EVM measurements according to standard, compensation must be disabled.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

SENS:CDP:NORM ON

Activates the elimination of the I/Q offset.

Manual operation: See "Compensate IQ Offset"


[SENSe:]CDPower:ORDer

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Code Domain Analysis Settings > [SENSe:]CDPower:ORDer
[SENSe:]CDPower:ORDer <SortOrder>

This command sets the channel sorting for the Code Domain Power and Code Domain Error Power result displays.

Parameters:
<SortOrder>
HADamard | BITReverse
*RST: HADamard

For further details refer to "Code Display and Sort Order".

Example: CDP:ORD HAD

Sets Hadamard order.

TRAC? TRACE2

Reads out the results in Hadamard order.

CDP:ORD BITR

Sets BitReverse order.

TRAC? TRACE2

Reads out the results in BitReverse order.

Manual operation: See "Code Display Order"


[SENSe:]CDPower:PDISplay

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Code Domain Analysis Settings > [SENSe:]CDPower:PDISplay
[SENSe:]CDPower:PDISplay <Mode>

This command defines how the pilot channel power is displayed in the Result Summary. In relative mode, the reference power is the total power.

Parameters:
<Mode>
ABS | REL
*RST: REL
Example: CDP:PDIS REL

Pilot channel power is displayed in relation to the total power.

Manual operation: See "Code Power Display"


[SENSe:]CDPower:PPReference

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Code Domain Analysis Settings > [SENSe:]CDPower:PPReference
[SENSe:]CDPower:PPReference <Mode>

This command is only available for "Code Domain Power" evaluation in MS mode.

This command defines how the pilot channel power is displayed in the absolute summary. In relative mode, the reference power is the total power.

Parameters:
<Mode>
ABS | REL
*RST: ABS
Example: CDP:PPR REL

Pilot channel power is displayed in relation to the total power.

Manual operation: See "Pilot Power Display (MS application only)"


[SENSe:]CDPower:PREFerence

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Code Domain Analysis Settings > [SENSe:]CDPower:PREFerence
[SENSe:]CDPower:PREFerence <Power>

This command specifies the reference power for the relative power result displays (e.g. Code Domain Power, Power vs PCG).

Parameters:
<Power>
PICH | TOTal
PICH

The reference power is the power of the pilot channel.

Which pilot channel is used as reference depends on the antenna diversity (for details see [SENSe:​]CDPower:​ANTenna command).

TOTal

The reference power is the total power of the signal.

*RST: PICH

For further information refer to "Power Reference".

Example: CDP:PREF TOT

Sets total power as reference power.

Manual operation: See "Power Reference"


[SENSe:]CDPower:SFACtor

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Code Domain Analysis Settings > [SENSe:]CDPower:SFACtor
[SENSe:]CDPower:SFACtor <SpreadingFactor>

This command defines the base spreading factor. If the base spreading factor of 64 is used for channels with a spreading factor of 128 (code class 7), an alias power is displayed in the Code Domain Power and Code Domain Error Power diagrams.

For more information see "Code Display and Sort Order".

Parameters:
<SpreadingFactor>
64 | 128
*RST: 64
Example: CDP:SFAC 128

Selects base spreading factor 128.

Manual operation: See "Base Spreading Factor"


[SENSe:]CDPower:TPMeas

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring Code Domain Analysis > Code Domain Analysis Settings > [SENSe:]CDPower:TPMeas
[SENSe:]CDPower:TPMeas <State>

This command activates or deactivates the timing and phase offset evaluation of the channels to the pilot.

The results are queried using the TRAC:DATA? CTAB command or the CALC:MARK:FUNC:CDP[:BTS]:RES? command.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CDP:TPM ON

Activates timing and phase offset.

CDP:SLOT 2

Selects slot 2.

CDP:CODE 11

Selects code number 11.

CALC:MARK:FUNC:CDP:RES? TOFF

Reads out timing offset of the code with number 11 in slot 2.

CALC:MARK:FUNC:CDP:RES? POFF

Reads out the phase offset of the code with number 11 in slot 2.

Manual operation: See "Timing and phase offset calculation"


Configuring RF Measurements

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring RF Measurements
Configuring RF Measurements

RF measurements are performed in the Spectrum application, with some predefined settings as described in "RF Measurements".

For details on configuring these RF measurements in a remote environment, see "Configuring and Performing Measurements" .

The cdma2000 RF measurements must be activated in a CDMA2000 application, see "Activating the Measurement Channel".

The individiual measurements are activated using the CONFigure:​CDPower[:​BTS]:​MEASurement command (see "Selecting a Measurement").

Contents
  • Special RF Configuration Commands
  • Analysis for RF Measurements


Special RF Configuration Commands

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring RF Measurements > Special RF Configuration Commands
Special RF Configuration Commands

In addition to the common RF measurement configuration commands described for the base unit, the following special commands are available in cdma2000 applications:

List of Commands
CONFigure:CDPower[:BTS]:BCLass|BANDclass


CONFigure:CDPower[:BTS]:BCLass|BANDclass

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring RF Measurements > Special RF Configuration Commands > CONFigure:CDPower[:BTS]:BCLass|BANDclass
CONFigure:CDPower[:BTS]:BCLass|BANDclass <Bandclass>

This command selects the bandclass for the measurement. The bandclass defines the frequency band used for ACLR and SEM measurements. It also determines the corresponding limits and ACLR channel settings according to the CDMA2000 standard.

Parameters:
<Bandclass>

For an overview of available bandclasses and the corresponding parameter values see "Reference: Supported Bandclasses".

*RST: 0
Example: CONF:CDP:BCL 1

Selects band class 1, 1900 MHz

Manual operation: See "Bandclass"


Analysis for RF Measurements

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring RF Measurements > Analysis for RF Measurements
Analysis for RF Measurements

General result analysis settings concerning the trace, markers, lines etc. for RF measurements are identical to the analysis functions in the Spectrum application except for some special marker functions and spectrograms, which are not available in the CDMA2000 applications.

See
  • "Zooming into the Display"
  • "Configuring the Trace Display and Retrieving Trace Data"
  • "Working with Markers"
  • "Configuring Display and Limit Lines"


Configuring the Result Display

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display
Configuring the Result Display

The following commands are required to configure the screen display in a remote environment. The tasks for manual operation are described in "Measurements and Result Displays".

Contents
  • General Window Commands
  • Working with Windows in the Display
  • Zooming into the Display


General Window Commands

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > General Window Commands
General Window Commands

The following commands are required to configure general window layout, independent of the application.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
DISPlay:FORMat
DISPlay[:WINDow<n>]:SIZE


DISPlay:FORMat

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > General Window Commands > DISPlay:FORMat
DISPlay:FORMat <Format>

This command determines which tab is displayed.

Parameters:
<Format>
SPLit

Displays the MultiView tab with an overview of all active channels

(See "R&S MultiView" ).

SINGle

Displays the measurement channel that was previously focused.

*RST: SING
Example: DISP:FORM SPL


DISPlay[:WINDow<n>]:SIZE

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > General Window Commands > DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:SIZE <Size>

This command maximizes the size of the selected result display window temporarily. To change the size of several windows on the screen permanently, use the LAY:SPL command (see LAYout:​SPLitter).

Parameters:
<Size>
LARGe

Maximizes the selected window to full screen.

Other windows are still active in the background.

SMALl

Reduces the size of the selected window to its original size.

If more than one measurement window was displayed originally, these are visible again.

*RST: SMALl
Example: DISP:WIND2:LARG
Example:

See "Example 1: Adding and Arranging Windows" .


Working with Windows in the Display

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > Working with Windows in the Display
Working with Windows in the Display

The following commands are required to change the evaluation type and rearrange the screen layout for a measurement channel as you do using the SmartGrid in manual operation. Since the available evaluation types depend on the selected application, some parameters for the following commands also depend on the selected measurement channel.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace


LAYout:ADD[:WINDow]?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:ADD[:WINDow]?
LAYout:ADD[:WINDow]? <WindowName>,<Direction>,<WindowType>

This command adds a window to the display.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

To replace an existing window, use the LAYout:​REPLace[:​WINDow] command.

Parameters:
<WindowName>

String containing the name of the existing window the new window is inserted next to.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<Direction>
LEFT | RIGHt | ABOVe | BELow

Direction the new window is added relative to the existing window.

<WindowType>
text value

Type of result display (evaluation method) you want to add.

See the table below for available parameter values.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:ADD? '1',LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example: LAY:ADD? '1',BEL,'XPOW:CDP:ABSolute'

Adds a Code Domain Power display below window 1.

Example:

For a detailed example see "Example 1: Adding and Arranging Windows" and "Example 2: Replacing and Removing Windows" .

Example:

See "Programming Example" .

Usage: Query only
Manual operation: See "Bitstream"
See "Channel Table"
See "Code Domain Power / Code Domain Error Power"
See "Composite Constellation"
See "Composite EVM"
See "Mag Error vs Chip"
See "Peak Code Domain Error"
See "Phase Error vs Chip"
See "Power vs PCG"
See "Power vs Symbol"
See "Result Summary"
See "Symbol Constellation"
See "Symbol EVM"
See "Symbol Magnitude Error"
See "Symbol Phase Error"
See "Diagram"
See "Result Summary"
See "Marker Table"
See "Marker Peak List"
<WindowType> parameter values for CDMA2000 application
Parameter value | Window type
BITStream | Bitstream
CCONst | Composite Constellation
CDEPower | Code Domain Error Power
CDPower | Code Domain Power
CEVM | Composite EVM
CTABle | Channel Table
LEValuation | List evaluation (SEM, Power vs Time)
MECHip | Magnitude Error vs Chip
MTABle | Marker table
PCDerror | Peak Code Domain Error
PECHip | Phase Error vs Chip
PPCG | Power vs PCG
PSYMbol | Power vs Symbol
RSUMmary | Result Summary
SCONst | Symbol Constellation
SEVM | Symbol EVM
SMERror | Symbol Magnitude Error
SPERror | Symbol Phase Error


LAYout:CATalog[:WINDow]?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:CATalog[:WINDow]?
LAYout:CATalog[:WINDow]?

This command queries the name and index of all active windows from top left to bottom right. The result is a comma-separated list of values for each window, with the syntax:

<WindowName_1>,<WindowIndex_1>..<WindowName_n>,<WindowIndex_n>

Return values:
<WindowName>
string

Name of the window.

In the default state, the name of the window is its index.

<WindowIndex>
numeric value

Index of the window.

Example: LAY:CAT?

Result:

'2',2,'1',1

Two windows are displayed, named '2' (at the top or left), and '1' (at the bottom or right).

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:IDENtify[:WINDow]?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:IDENtify[:WINDow]?
LAYout:IDENtify[:WINDow]? <WindowName>

This command queries the index of a particular display window.

Note: to query the name of a particular window, use the LAYout:​WINDow<n>:​IDENtify? query.

Query parameters:
<WindowName> | String containing the name of a window.
Return values:
<WindowIndex> | Index number of the window.
Usage: | Query only


LAYout:REMove[:WINDow]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:REMove[:WINDow]
LAYout:REMove[:WINDow] <WindowName>

This command removes a window from the display.

Parameters:
<WindowName>

String containing the name of the window.

In the default state, the name of the window is its index.

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Event


LAYout:REPLace[:WINDow]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:REPLace[:WINDow]
LAYout:REPLace[:WINDow] <WindowName>,<WindowType>

This command replaces the window type (for example from "Diagram" to "Result Summary") of an already existing window while keeping its position, index and window name.

To add a new window, use the LAYout:​ADD[:​WINDow]? command.

Parameters:
<WindowName>

String containing the name of the existing window.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<WindowType>

Type of result display you want to use in the existing window.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Example: LAY:REPL:WIND '1',MTAB

Replaces the result display in window 1 with a marker table.

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:SPLitter

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:SPLitter
LAYout:SPLitter <Index1>,<Index2>,<Position>

This command changes the position of a splitter and thus controls the size of the windows on each side of the splitter.

As opposed to the DISPlay[:​WINDow<n>]:​SIZE command, the LAYout:SPLitter changes the size of all windows to either side of the splitter permanently, it does not just maximize a single window temporarily.

Note that windows must have a certain minimum size. If the position you define conflicts with the minimum size of any of the affected windows, the command will not work, but does not return an error.

SmartGrid coordinates for remote control of the splitters
Parameters:
<Index1>

The index of one window the splitter controls.

<Index2>

The index of a window on the other side of the splitter.

<Position>

New vertical or horizontal position of the splitter as a fraction of the screen area (without channel and status bar and softkey menu).

The point of origin (x = 0, y = 0) is in the lower left corner of the screen. The end point (x = 100, y = 100) is in the upper right corner of the screen. (See figure "SmartGrid coordinates for remote control of the splitters".)

The direction in which the splitter is moved depends on the screen layout. If the windows are positioned horizontally, the splitter also moves horizontally. If the windows are positioned vertically, the splitter also moves vertically.

Range: 0 to 100
Example: LAY:SPL 1,3,50

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Table') to the center (50%) of the screen, i.e. in the figure above, to the left.

Example: LAY:SPL 1,4,70

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Peak List') towards the top (70%) of the screen.

The following commands have the exact same effect, as any combination of windows above and below the splitter moves the splitter vertically.

LAY:SPL 3,2,70
LAY:SPL 4,1,70
LAY:SPL 2,1,70
Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:WINDow<n>:ADD?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:ADD? <Direction>,<WindowType>

This command adds a measurement window to the display. Note that with this command, the suffix <n> determines the existing window next to which the new window is added, as opposed to LAYout:​ADD[:​WINDow]?, for which the existing window is defined by a parameter.

To replace an existing window, use the LAYout:​WINDow<n>:​REPLace command.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

Parameters:
<Direction>
LEFT | RIGHt | ABOVe | BELow
<WindowType>

Type of measurement window you want to add.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:WIND1:ADD? LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:WINDow<n>:IDENtify?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:IDENtify?

This command queries the name of a particular display window (indicated by the <n> suffix).

Note: to query the index of a particular window, use the LAYout:​IDENtify[:​WINDow]? command.

Return values:
<WindowName> | String containing the name of a window. In the default state, the name of the window is its index.
Usage: | Query only


LAYout:WINDow<n>:REMove

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REMove

This command removes the window specified by the suffix <n> from the display.

The result of this command is identical to the LAYout:​REMove[:​WINDow] command.

Usage: Event


LAYout:WINDow<n>:REPLace

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:REPLace <WindowType>

This command changes the window type of an existing window (specified by the suffix <n>).

The result of this command is identical to the LAYout:​REPLace[:​WINDow] command.

To add a new window, use the LAYout:​WINDow<n>:​ADD? command.

Parameters:
<WindowType>

Type of measurement window you want to replace another one with.

See LAYout:​ADD[:​WINDow]? for a list of available window types.


Zooming into the Display

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > Zooming into the Display
Zooming into the Display
Contents
  • Using the Single Zoom
  • Using the Multiple Zoom


Using the Single Zoom

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > Zooming into the Display > Using the Single Zoom
Using the Single Zoom
List of Commands
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:STATe


DISPlay[:WINDow<n>]:ZOOM:AREA

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > Zooming into the Display > Using the Single Zoom > DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT
Manual operation: See "Single Zoom"


DISPlay[:WINDow<n>]:ZOOM:STATe

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > Zooming into the Display > Using the Single Zoom > DISPlay[:WINDow<n>]:ZOOM:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe <State>

This command turns the zoom on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DISP:ZOOM ON

Activates the zoom mode.

Manual operation: See "Single Zoom"
See "Restore Original Display"
See "Deactivating Zoom (Selection mode)"


Using the Multiple Zoom

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > Zooming into the Display > Using the Multiple Zoom
Using the Multiple Zoom
List of Commands
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe


DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > Zooming into the Display > Using the Multiple Zoom > DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area for a multiple zoom.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Suffix:
<zoom>
1...4

Selects the zoom window.

Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT
Manual operation: See "Multiple Zoom"


DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Result Display > Zooming into the Display > Using the Multiple Zoom > DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe <State>

This command turns the mutliple zoom on and off.

Suffix:
<zoom>
1...4

Selects the zoom window.

If you turn off one of the zoom windows, all subsequent zoom windows move up one position.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Multiple Zoom"
See "Restore Original Display"
See "Deactivating Zoom (Selection mode)"


Starting a Measurement

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Starting a Measurement
Starting a Measurement

The measurement is started immediately when a cdma2000 application is activated, however, you can stop and start a new measurement any time.

List of Commands
ABORt
INITiate:CONMeas
INITiate:CONTinuous
INITiate[:IMMediate]
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SEQuencer:REFResh[:ALL]
SYSTem:SEQuencer


ABORt

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Starting a Measurement > ABORt
ABORt

This command aborts a current measurement and resets the trigger system.

To prevent overlapping execution of the subsequent command before the measurement has been aborted successfully, use the *OPC? or *WAI command after ABOR and before the next command.

For details see "Preventing Overlapping Execution" .

To abort a sequence of measurements by the Sequencer, use the INITiate:​SEQuencer:​ABORt command.

Note on blocked remote control programs:

If a sequential command cannot be completed, for example because a triggered sweep never receives a trigger, the remote control program will never finish and the remote channel to the R&S FSW is blocked for further commands. In this case, you must interrupt processing on the remote channel first in order to abort the measurement.

To do so, send a "Device Clear" command from the control instrument to the R&S FSW on a parallel channel to clear all currently active remote channels. Depending on the used interface and protocol, send the following commands:

  • Visa: viClear()
  • GPIB: ibclr()
  • RSIB: RSDLLibclr()

Now you can send the ABORt command on the remote channel performing the measurement.

Example: | ABOR;:INIT:IMM Aborts the current measurement and immediately starts a new one.
Example: | ABOR;*WAI INIT:IMM Aborts the current measurement and starts a new one once abortion has been completed.
Usage: | SCPI confirmed


INITiate:CONMeas

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Starting a Measurement > INITiate:CONMeas
INITiate:CONMeas

This command restarts a (single) measurement that has been stopped (using INIT:CONT OFF) or finished in single sweep mode.

The measurement is restarted at the beginning, not where the previous measurement was stopped.

As opposed to INITiate[:​IMMediate], this command does not reset traces in maxhold, minhold or average mode. Therefore it can be used to continue measurements using maxhold or averaging functions.

Manual operation: See "Continue Single Sweep"


INITiate:CONTinuous

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Starting a Measurement > INITiate:CONTinuous
INITiate:CONTinuous <State>

This command controls the sweep mode.

Note that in single sweep mode, you can synchronize to the end of the measurement with *OPC, *OPC? or *WAI. In continuous sweep mode, synchronization to the end of the measurement is not possible. Thus, it is not recommended that you use continuous sweep mode in remote control, as results like trace data or markers are only valid after a single sweep end synchronization.

For details on synchronization see "Command Sequence and Synchronization"

If the sweep mode is changed for a measurement channel while the Sequencer is active (see INITiate:​SEQuencer:​IMMediate) the mode is only considered the next time the measurement in that channel is activated by the Sequencer.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Continuous sweep

OFF | 0

Single sweep

*RST: 1
Example: INIT:CONT OFF

Switches the sweep mode to single sweep.

INIT:CONT ON

Switches the sweep mode to continuous sweep.

Manual operation: See "Continuous Sweep/RUN CONT"


INITiate[:IMMediate]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Starting a Measurement > INITiate[:IMMediate]
INITiate[:IMMediate]

This command starts a (single) new measurement.

With sweep count or average count > 0, this means a restart of the corresponding number of measurements. With trace mode MAXHold, MINHold and AVERage, the previous results are reset on restarting the measurement.

You can synchronize to the end of the measurement with *OPC, *OPC? or *WAI.

For details on synchronization see "Command Sequence and Synchronization"

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Single Sweep/ RUN SINGLE"


INITiate:SEQuencer:ABORt

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Starting a Measurement > INITiate:SEQuencer:ABORt
INITiate:SEQuencer:ABORt

This command stops the currently active sequence of measurements. The Sequencer itself is not deactivated, so you can start a new sequence immediately using INITiate:​SEQuencer:​IMMediate.

To deactivate the Sequencer use SYSTem:​SEQuencer.

Usage: Event


INITiate:SEQuencer:IMMediate

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Starting a Measurement > INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:IMMediate

This command starts a new sequence of measurements by the Sequencer. Its effect is similar to the INITiate[:​IMMediate] command used for a single measurement.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: Event


INITiate:SEQuencer:MODE

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Starting a Measurement > INITiate:SEQuencer:MODE
INITiate:SEQuencer:MODE <Mode>

This command selects the way the R&S FSW application performs measurements sequentially.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Note: In order to synchronize to the end of a sequential measurement using *OPC, *OPC? or *WAI you must use SINGle Sequence mode.

For details on the Sequencer see "The Sequencer Concept" .

For details on synchronization see "Command Sequence and Synchronization"

Parameters:
<Mode>
SINGle

Each measurement is performed once (regardless of the channel's sweep mode), considering each channels' sweep count, until all measurements in all active channels have been performed.

CONTinuous

The measurements in each active channel are performed one after the other, repeatedly (regardless of the channel's sweep mode), in the same order, until the Sequencer is stopped.

CDEFined

First, a single sequence is performed. Then, only those channels in continuous sweep mode (INIT:CONT ON) are repeated.

*RST: CONTinuous
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .


INITiate:SEQuencer:REFResh[:ALL]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Starting a Measurement > INITiate:SEQuencer:REFResh[:ALL]
INITiate:SEQuencer:REFResh[:ALL]

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only in MSRA or MSRT mode.

The data in the capture buffer is re-evaluated by all active MSRA/MSRT applications.

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INIT:SEQ:REFR Refreshes the display for all channels.
Usage: | Event


SYSTem:SEQuencer

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Starting a Measurement > SYSTem:SEQuencer
SYSTem:SEQuencer <State>

This command turns the Sequencer on and off. The Sequencer must be active before any other Sequencer commands (INIT:SEQ...) are executed, otherwise an error will occur.

For details on the Sequencer see "The Sequencer Concept" .

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The Sequencer is activated and a sequential measurement is started immediately.

OFF | 0

The Sequencer is deactivated. Any running sequential measurements are stopped. Further Sequencer commands (INIT:SEQ...) are not available.

*RST: 0
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single Sequencer mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

SYST:SEQ OFF
Example:

See "Programming Example: Performing a Sequence of Measurements" .


Retrieving Results

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results
Retrieving Results

The following commands retrieve the results from a cdma2000 measurement in a remote environment.

When the channel type is required as a parameter by a remote command or provided as a result for a remote query, abbreviations or assignments to a numeric value are used as described in "Channel Detection".

Useful commands described elsewhere:
  • "Storing Measurement Results"
Specific commands:
Contents
  • Retrieving Calculated CDA Results
  • Retrieving CDA Trace Results
  • Measurement Results for TRACe<n>[:DATA]? TRACE<n>
  • Retrieving RF Results


Retrieving Calculated CDA Results

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Retrieving Calculated CDA Results
Retrieving Calculated CDA Results

The following commands describe how to retrieve the calculated results from the CDA measurements.

List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:CDPower[:BTS]:RESult?
CALCulate<n>:MARKer<m>:Y?


CALCulate<n>:MARKer<m>:FUNCtion:CDPower[:BTS]:RESult?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Retrieving Calculated CDA Results > CALCulate<n>:MARKer<m>:FUNCtion:CDPower[:BTS]:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:CDPower[:BTS]:RESult? <Measurement>

This command queries individual values of the measured and calculated results of the CDMA2000 code domain power measurement.

Query parameters:
<Measurement> | ACTive Number of active channels CDPabsolute Channel power absolute in dBm CDPRelative Channel power relative in dB (relative to total or PICH power, refer to CDP:PREF command) CERRor Chip rate error in ppm CHANnel Channel number DMType Domain type EVMRms Error vector magnitude RMS in % EVMPeak Error vector mag. peak in % FERPpm Frequency error in ppm FERRor Frequency error in Hz IQIMbalance IQ imbalance in % IQOFfset IQ offset in % MACCuracy Composite EVM in % PCDerror Peak code domain error in dB POFFset Phase offset in rad PPICh Pilot power in dBm PTOTal Total power in dBm RHO RHO SFACtor Spreading factor of channel SLOT PCG number SRATe Symbol rate in ksps TFRame I Trigger to frame TOFFset Timing offset in s
Example: | CALC:MARK:FUNC:CDP:RES? PTOT
Usage: | Query only
Manual operation: | See "Code Domain Power / Code Domain Error Power" See "Composite Constellation" See "Composite EVM" See "Peak Code Domain Error" See "Power vs Symbol" See "Result Summary" See "Symbol Constellation" See "Symbol EVM"


CALCulate<n>:MARKer<m>:Y?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Retrieving Calculated CDA Results > CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>:Y?

This command queries the position of a marker on the y-axis.

If necessary, the command activates the marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result> | Result at the marker position.
Example: | INIT:CONT OFF Switches to single measurement mode. CALC:MARK2 ON Switches marker 2. INIT;*WAI Starts a measurement and waits for the end. CALC:MARK2:Y? Outputs the measured value of marker 2.
Usage: | Query only
Manual operation: | See "CCDF" See "Marker Table" See "Marker Peak List" See "Marker 1 / Marker 2 / Marker 3 / Marker 4"


Retrieving CDA Trace Results

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Retrieving CDA Trace Results
Retrieving CDA Trace Results

The following commands describe how to retrieve the trace data from the CDA measurements. Note that for these measurements, only 1 trace per window can be configured.

List of Commands
FORMat[:DATA]
TRACe<n>[:DATA]?


FORMat[:DATA]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Retrieving CDA Trace Results > FORMat[:DATA]
FORMat[:DATA] <Format>

This command selects the data format that is used for transmission of trace data from the R&S FSW to the controlling computer.

Note that the command has no effect for data that you send to the R&S FSW. The R&S FSW automatically recognizes the data it receives, regardless of the format.

For details on data formats see "Formats for Returned Values: ASCII Format and Binary Format" .

Parameters:
<Format>
ASCii

ASCii format, separated by commas.

This format is almost always suitable, regardless of the actual data format. However, the data is not as compact as other formats may be.

REAL,32

32-bit IEEE 754 floating-point numbers in the "definite length block format".

In the Spectrum application, the format setting REAL is used for the binary transmission of trace data.

For I/Q data, 8 bytes per sample are returned for this format setting.

*RST: ASCII
Example: FORM REAL,32
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Usage: SCPI confirmed


TRACe<n>[:DATA]?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Retrieving CDA Trace Results > TRACe<n>[:DATA]?
TRACe<n>[:DATA]? <ResultType>

This command reads trace data from the R&S FSW.

For details on reading trace data for other than code domain measurements refer to TRACe<n>[:​DATA] .

Query parameters:
<ResultType>
TRACE1 | TRACE2 | TRACE3 | TRACE4

Reads out the trace data of the corresponding trace in the specified measurement window. The results of the trace data query depend on the evaluation method in the specified window, which is selected by the LAY:ADD:WIND command. The individual results are described in "Measurement Results for TRACe<n>[:DATA]? TRACE<n>".

CTABle

For the Channel Table result display, reads out the maximum values of the timing/phase offset between each assigned channel and the pilot channel (see [SENSe:​]CDPower:​TPMeas command).

To query the detailed channel information use the TRAC:DATA? TRACE1 command for a window with Channel Table evaluation.

LIST

Queries the results of the peak list evaluation for Spectrum Emission Mask measurements.

For each peak the following entries are given:

<peak frequency>, <absolute level of the peak>, <distance to the limit line>

For details see table "Return values for LIST parameter" .

Usage: Query only
SCPI confirmed
Manual operation: See "Mag Error vs Chip"
See "Phase Error vs Chip"
See "Symbol Magnitude Error"
See "Symbol Phase Error"


Measurement Results for TRACe<n>[:DATA]? TRACE<n>

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n>
Measurement Results for TRACe<n>[:DATA]? TRACE<n>

The results of the trace data query (TRACe<n>[:DATA]? TRACE<n>) depend on the evaluation method in the specified window, which is selected by the LAY:ADD:WIND command.

For each evaluation method the returned values for the trace data query are described in the following sections.

For details on the graphical results of these evaluation methods, see "Measurements and Result Displays".

Contents
  • Bitstream
  • Channel Table
  • Code Domain Error Power
  • Code Domain Power
  • Composite Constellation
  • Composite EVM (RMS)
  • EVM vs Chip
  • Frequency Error vs PCG
  • Mag Error vs Chip
  • Power vs PCG
  • Peak Code Domain Error
  • Phase Discontinuity vs PCG
  • Phase Error vs Chip
  • Power vs Symbol
  • Result Summary
  • Symbol Constellation
  • Symbol EVM
  • Symbol Magnitude Error
  • Symbol Phase Error


Bitstream

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Bitstream
Bitstream

When the trace data for this evaluation is queried, the bit stream of one PCG (i.e. one value per bit for each symbol) is transferred. Each symbol contains two consecutive bits in the case of a QPSK modulated PCG and 4 consecutive bits in the case of a 16QAM modulated PCG. One value is transferred per bit (range 0, 1). The number of symbols is not constant and may vary for each sweep. Individual symbols in the bit stream may be invalid depending on the channel type and the bit rate (symbols without power). The assigned invalid bits are marked by one of the digits "6", "7" or "9".


Channel Table

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Channel Table
Channel Table

Two different commands are available to retrieve the channel table results:

  • TRAC:DATA? TRACEx commands return detailed trace information for each channel
  • TRAC:DATA? CTABle provides the maximum values of the timing/phase offset between each assigned channel and the pilot channel
Contents
  • Results for TRACEx Parameters
  • Measurement Example: Retrieving the BTS Channel Table Values
  • Measurement Example: Retrieving the MS Channel Table Values
  • Results for CTABle Parameter


Results for TRACEx Parameters

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Channel Table > Results for TRACEx Parameters
Results for TRACEx Parameters

The command returns 8 values for each channel in the following order:

<channel type>, <code class>, <code number>, <radio configuration>, <absolute level>, <relative level>, <timing offset>, <phase offset>

Value

Description

Range/Unit

<channel type>

channel type

(see table "BTS channel types and their assignment to a numeric parameter value"

and table "MS channel types and their assignment to a numeric parameter value")

{0..13} (BTS)

{0..9} (MS)

<code class>

code class of the channel (see "Channels, Codes and Symbols")

{2...7} (BTS)

{1..6} (MS)

<code number>

code number within the channel

{0..127} (BTS)

{0..63}(MS)

<radio config>

(BTS only)

radio configuration (see "Radio Configuration")

<mapping> (MS only)

channel mapping

0 = I branch

1 = Q branch

<absolute level>

absolute power level of the channel

{-∞...∞}

dBm

<relative level>

relative power level of the channel, referred to either Total or Pilot power

{-∞...∞}

dB

<timing offset>

referred to the pilot channel

s

<phase offset>

referred to the pilot channel

9 for:

  • CDP:TPM OFF
  • > 50 active channels found
  • inactive channel

rad

In BTS measurements, the channels are sorted according to these rules:

  1. All detected special channels

  2. Data channels, in ascending order by code class and within the code class in ascending order by code number

  3. Unassigned codes, with the code class of the base spreading factor

In MS measurements, the channels are sorted according to these rules:

  1. All active channels

  2. All inactive or quasi-active channels, in ascending code number order, I branch first, followed by Q branch

    Data channels, in ascending order by code class and within the code class in ascending order by code number

  3. Unassigned codes, with the code class of the base spreading factor


Measurement Example: Retrieving the BTS Channel Table Values

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Channel Table > Measurement Example: Retrieving the BTS Channel Table Values
Measurement Example: Retrieving the BTS Channel Table Values

The example shows the results of the query for 5 channels with the following configuration:

Chan. type | Ch.no./SF | Code class | Power
PICH | 0.64 | 6 | -7.0 dB
PCH | 1.64 | 6 | -7.3 dB
CHAN | 8.32 | 5 | -8.0 dB
CHAN | 24.128 | 7 | -9.0 dB (alias with 24.64)
SYNC | 32.64 | 6 | -13.3 dB
INST:SEL BC2K
//Activate cdma2000 BTS, default is CDP relative in window 1 and
//Result Summary in window 2
INIT:CONT OFF
//Select single sweep
INIT:CONT OFF
//Select single sweep
LAY:REPL:WIND '1',CTAB
//Replace CDP by Channel Table evaluation in window 1
INIT;*WAI
//Start measurement with synchronization
TRAC? TRACE1
//Read out channel table
//Result:
//0 , 6, 0, 0,       0.0, –7.0, 9, 9,
//1 , 6, 32, 0,     –6.3, –13.3, 9, 9,
//2 , 6, 1, 0,      –0.3, –7.3, 9, 9,
//10, 5, 8, 3,      –1.0, –8.0, 9, 9,
//10, 7, 24, 3,     –2.0, –9.0, 9, 9,
//11, 6, 2, 3,      –47.6, –54.6, 9, 9,
//....
//11, 6, 63, 3,     –47.7, –54.7, 9, 9


Measurement Example: Retrieving the MS Channel Table Values

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Channel Table > Measurement Example: Retrieving the MS Channel Table Values
Measurement Example: Retrieving the MS Channel Table Values

The example shows the results of the query for 2 channels with the following configuration:

Chan. type | Ch.no./SF | Code class | Mapping | Power
PICH | 0.32 | 5 | I | -7.0 dB
CCCH | 2.8 | 3 | Q | -10:0 dB
INIT:CONT OFF
//Select single sweep
INIT:CONT OFF
//Select single sweep
LAY:REPL:WIND '1',CTAB
//Replace CDP by Channel Table evaluation in window 1
INIT;*WAI
//Start measurement with synchronization
TRAC? TRACE1
//Read out channel table
//Result:
//0 , 5, 0, 0,       0.0, -7.0, 9, 9,
//2 , 2, 2, 1,      -3.0, -10.0, 9, 9,
//9 , 5, 0, 1,      -46.3, -53.3, 9, 9,
//9 , 5, 1, 0,      -48.0, -55.0, 9, 9,
//9 , 5, 1, 1,      -43.2, -50.2, 9, 9,
//9 , 5, 2, 0,      -42.0, -49.0, 9, 9,
//9 , 5, 3, 0,      -47.6, -54.6, 9, 9,
//....
//9 , 5, 31, 1,     -47.7, -54.7, 9, 9


Results for CTABle Parameter

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Channel Table > Results for CTABle Parameter
Results for CTABle Parameter

The command returns 12 values for each channel in the following order:

<max. time offset in s>, <code number for max. time>, <code class for max. time>, <max. phase offset in rad>, <code number for max. phase>, <code class for max. phase>, <reserved 1>, …, <reserved 6>

Value | Description | Range/ Unit
<time offset> | maximum time offset | s
<code number> | code number of the channel with maximum time offset | {0..127} (BTS) {0..63}(MS)
<code class> | code class of the channel with maximum time offset | {2...7} (BTS) {1..6} (MS)
<phase offset> | maximum phase offset | rad
<code number> | code number of the channel with maximum phase offset | {0..127} (BTS) {0..63}(MS)
<code class> | code class of the channel with maximum phase offset | {2...7} (BTS) {1..6} (MS)
<reserved 1...6> | reserved for future use | 0
Measurement example for TRAC:DATA? CTAB
INIT:CONT OFF
//Select single sweep
INIT:CONT OFF
//Select single sweep
LAY:REPL:WIND '1',CTAB
//Replace CDP by Channel Table evaluation in window 1
INIT;*WAI
//Start measurement with synchronization
TRAC? CTAB
//Read out maximum timing and phase offsets
//Result: 1.20E–009,2,2,–3.01E–003,15,4,0,0,0,0,0,0
//where:
//1.20E–009,2,2,
//Max. time offset with code number and
//code class of associated channel
//–3.01E–003,15,4,
//Max. phase offset with code number
//and code class of associated channel
//0,0,0,0,0,0
//6 reserved values


Code Domain Error Power

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Code Domain Error Power
Code Domain Error Power

The command returns four values for each channel:

<code class>, <code number>, <error power>, <power ID>

The Hadamard or BitReverse order is important for sorting the channels, but not for the number of values.

With Hadamard, the individual codes are output in ascending order.

With BitReverse, codes which belong to a particular channel are adjacent to each other.

Since an error power is output for Code Domain Error Power, consolidation of the power values is not appropriate. The number of codes that are output therefore generally corresponds to the base spreading factor.

Value | Description | Range/ Unit
<code class> | code class of the channel (see "Channels, Codes and Symbols") | {2...7} (BTS) {1..6} (MS)
<code number> | code number within the channel | {0..127} (BTS) {0..63}(MS)
<signal level> | error power | {-∞...∞}dB
<power ID> | type of power detection: 0 - inactive channel 1 - power of own antenna 2 - alias power of own antenna 3 - alias power of other antenna 4 - alias power of own and other antenna |

To avoid alias power, set the base spreading factor correctly.

For details on these parameters see TRACe<n>[:​DATA]?.


Code Domain Power

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Code Domain Power
Code Domain Power

The command returns four values for each channel:

<code class>, <code number>, <signal level>, <power ID>

The number of displayed values depends on the spreading factor.

In Hadamard order, the different codes are output in ascending order together with their code power. The number of output codes corresponds to the base spreading factor.

In BitReverse order, codes belonging to a channel are next to one another and are therefore output in the class of the channel together with the consolidated channel power. The maximum number of output codes or channels cannot be higher than the base spreading factor, but decreases with every concentrated channel.

Value | Description | Range/ Unit
<code class> | code class of the channel (see "Channels, Codes and Symbols") | {2...7} (BTS) {1..6} (MS)
<code number> | code number within the channel | {0..127} (BTS) {0..63}(MS)
<signal level> | absolute or relative power, depending on the setting (See [SENSe:​]CDPower:​PREFerence) Hadamard order: power values for each code BitReverse order: power values for combined channels | {-∞...∞}dB or dBm
<power ID> | type of power detection: 0 - inactive channel 1 - power of own antenna 2 - alias power of own antenna 3 - alias power of other antenna 4 - alias power of own and other antenna |

To avoid alias power, set the base spreading factor correctly.

For details on these parameters see TRACe<n>[:​DATA]?.

Contents
  • Measurement Example: Retrieving the Code Domain Power in the BTS Application
  • Measurement Example: Retrieving the Code Domain Power (MS mode)


Measurement Example: Retrieving the Code Domain Power in the BTS Application

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Code Domain Power > Measurement Example: Retrieving the Code Domain Power in the BTS Application
Measurement Example: Retrieving the Code Domain Power in the BTS Application

The example shows the results of the query for 5 channels with the following configuration:

Chan. type | Ch.no./SF | Code class | Power
PICH | 0.64 | 6 | -7.0 dB
PCH | 1.64 | 6 | -7.3 dB
CHAN | 8.32 | 5 | -8.0 dB
CHAN | 24.128 | 7 | -9.0 dB (alias with 24.64)
SYNC | 32.64 | 6 | -13.3 dB
INST:SEL BC2K
//Activate cdma2000 BTS, default is CDP relative in window 1 and
//Result Summary in window 2
INIT:CONT OFF
//Select single sweep
CDP:ORD HAD
//Set order to Hadamard
INIT;*WAI
//Start measurement with synchronization
TRAC? TRACE1
//Read out CDP relative/Hadamard;
//Channel 8.32 is distributed to 8.64 and 40.64, in each case with half power:
//–8dB – 3dB = –11.0 dB
//Result:
//6, 0, –7.0,1,      6, 1, –7.3,1,
//6, 2,–54.6,0,      6, 3,–55.3,0,
//         ....      6, 7,–58.2,0,
//6, 8,–11.0,1,      6, 9,–53.4,0,
//         ....      6,24, –9.0,2,
//         ....      6,32,–13.3,1,
//         ....      6,40,–11.0,1,
//         ....      6,63,–54.7,0
CDP:ORD BITR
//Set order to BitReverse
TRAC? TRACE1
//Read out CDP relative/BitReverse
//Channel 8.32 can now be directly read out with its total power.
//The sort order changes in accordance with BitReverse.
//Result:
//6, 0, –7.0,1,      6,32,–13.3,1,
//6,16,–56.3,0,      6,48,–52.8,0,
//5, 8, –8.0,1,      6,24, –9.0,2,
//         ....      6, 1, –7.3,1,
//         ....      6,63,–54.7,0

INST:SEL BC2K
//Activate cdma2000 BTS, default is CDP relative in window 1 and
//Result Summary in window 2
INIT:CONT OFF
//Select single sweep
CDP:ORD HAD
//Set order to Hadamard
INIT;*WAI
//Start measurement with synchronization
TRAC? TRACE1
//Read out CDP relative/Hadamard
//Channel 8.32 is distributed to 8.64 and 40.64, in each case with half power:
// –8dB – 3dB = –11.0dB
//Result:
//6, 0, –7.0,1, 6, 1, –7.3,1,
//6, 2,–54.6,0, 6, 3,–55.3,0,
//.... 6, 7,–58.2,0,
//6, 8,–11.0,1, 6, 9,–53.4,0,
//.... 6,24, –9.0,2,
//.... 6,32,–13.3,1,
//.... 6,40,–11.0,1,
//.... 6,63,–54.7,0
CDP:ORD BITR
//Set order to BitReverse
TRAC? TRACE1
//Read out CDP relative/BitReverse
//Channel 8.32 can now be directly read out with its total power.
//The sort order changes in accordance with BitReverse.
//Result:
//6, 0, –7.0,1, 6,32,–13.3,1,
//6,16,–56.3,0, 6,48,–52.8,0,
//5, 8, –8.0,1, 6,24, –9.0,2,
//.... 6, 1, –7.3,1,
//.... 6,63,–54.7,0


Measurement Example: Retrieving the Code Domain Power (MS mode)

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Code Domain Power > Measurement Example: Retrieving the Code Domain Power (MS mode)
Measurement Example: Retrieving the Code Domain Power (MS mode)

The example shows the results of the query for 2 channels with the following configuration:

Chan. type | Ch.no./SF | Code class | Mapping | Power
PICH | 0.32 | 5 | I | -7.0 dB
CCCH | 2.8 | 3 | Q | -10:0 dB
INST:SEL MC2K
//Activate cdma2000 MS, default is CDP relative in window 1 and
//Result Summary in window 2
//Mapping set to I
INIT:CONT OFF
//Select single sweep
CDDP:MAPP Q
//Select Q branch
CDP:ORD HAD
//Set order to Hadamard
INIT;*WAI
//Start measurement with synchronization
TRAC? TRACE1
//Read out CDP relative/Hadamard/Q
//Result:
//5, 0,-52.3,3,      5, 1,-53.3,0,
//5, 2,-16.1,1,      5, 3,-55.3,0,
//         ....      5, 9,-58.2,0,
//5,10,-16.0,1,      5,11,-53.4,0,
//         ....      5,17,-49.0,0,
//5,18,-15.8,1,      5,19,-53.3,0,
//         ....      5,25,-51.0,0,
//5,26,-16.1,1,      5,27,-54.7,0
         ....      5,31,-51.7,0
//Code 0 is quasi-inactive since PICH is set to I
//Channel 2.8 is distributed between the active codes
//2.32, 10.32, 18.32 and 26.32
//each with one quarter of the power: -10dB - 6dB = -16.0dB
CDP:ORD BITR
//Set order to BitReverse
TRAC? TRACE1
//Read out CDP relative/BitReverse/Q
//Sorting is changed according to BitReverse.
//Result:
//5, 0,-52.3,3,      5,16,-57.3,0
//5, 8,-56.3.0,      ....
//3, 2,-10.0,1,      5, 6,-55.3,0,
         ....      5,31,-51.7,0
//Code 0 is quasi-inactive since PICH is set to I
//Channel 2.8 can now be read out directly with its total power
CDP:OVER ON
//Activate Overview mode
//CDP relative on window 1 I branch
//CDP relative on window 2 Q branch
TRAC? TRACE1
//Read out CDP relative of I branch
//Result:
//5, 0, -7.0,1,      5,16,-52.3,0
//5, 8,-57.1.0,      ....
//5, 2,-49.0,3,      5,18,-49.0,3,
//5,10,-49.0,3,      5,26,-49.0,3
//5, 6,-55.3,0,      5, 6,-53.4,0,
         ....      5,31,-51.7,0
//PICH is active
//Codes of channel 2.8 are quasi-inactive
TRAC? TRACE2
//Read out CDP relative of Q branch
//Result:
//5, 0,-52.3,3,      6,16,-57.3,0
//5, 8,-56.3.0,      ....
//3, 2,-10.0,1,      6, 3,-55.3,0,
         ....      5,31,-51.7,0


Composite Constellation

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Composite Constellation
Composite Constellation

When the trace data for this evaluation is queried, the real and the imaginary branches of each chip are transferred:

<Re chip0>, <Im chip0>, <Re chip1>, <Im chip1>, ...., <Re chipn>, <Im chipn>

The number of value pairs corresponds to the chip number of 1536 chips in a power control group.


Composite EVM (RMS)

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Composite EVM (RMS)
Composite EVM (RMS)

When the trace data for this evaluation is queried, one pair of PCG and level value is transferred for each PCG:

<PCG number>, <level value in %>

The number of value pairs corresponds to the number of captured PCGs.


EVM vs Chip

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > EVM vs Chip
EVM vs Chip

When the trace data for this evaluation is queried, a list of vector error values of all chips at the selected PCG is returned (=2560 values). The values are calculated as the square root of the square difference between the received signal and the reference signal for each chip, normalized to the square root of the average power at the selected PCG.


Frequency Error vs PCG

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Frequency Error vs PCG
Frequency Error vs PCG

When the trace data for this evaluation is queried, one pair of PCG and error value is transferred for each PCG:

<PCG number>, <value in Hz>


Mag Error vs Chip

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Mag Error vs Chip
Mag Error vs Chip

When the trace data for this evaluation is queried, a list of magnitude error values of all chips at the selected slot is returned (=2560 values). The values are calculated as the magnitude difference between the received signal and the reference signal for each chip in %, and are normalized to the square root of the average power at the selected slot.


Power vs PCG

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Power vs PCG
Power vs PCG

When the trace data for this evaluation is queried, one pair of PCG and level values is transferred for each PCG:

<PCG number>, <level value in dB>

The number of value pairs corresponds to the number of captured PCGs.


Peak Code Domain Error

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Peak Code Domain Error
Peak Code Domain Error

The command returns 2 values for each PCG in the following order:

<PCG number>, <level value in dB>

The number of value pairs corresponds to the number of captured PCGs.


Phase Discontinuity vs PCG

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Phase Discontinuity vs PCG
Phase Discontinuity vs PCG

When the trace data for this evaluation is queried, one pair of PCG and value is transferred for each PCG:

<PCG number>, <value in deg>


Phase Error vs Chip

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Phase Error vs Chip
Phase Error vs Chip

When the trace data for this evaluation is queried, a list of phase error values of all chips in the selected slot is returned (=2560 values). The values are calculated as the phase difference between the received signal and the reference signal for each chip in degrees, and are normalized to the square root of the average power at the selected slot.


Power vs Symbol

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Power vs Symbol
Power vs Symbol

When the trace data for this evaluation is queried. One power value per symbol is returned.

The number of values depends on the number of symbols and therefore the spreading factor. With transmit diversity activated, the number of values is reduced to half.

For details see "Number of bits per symbol".


Result Summary

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Result Summary
Result Summary

When the trace data for this evaluation is queried, the results of the result summary are output in the following order:

<PCG>, <PTOTal>, <PPICh>, <RHO>, <MACCuracy>, <PCDerror>, <ACTive>, <FERRor>, <FERPpm>, <TFRame>, <CERRor>, <IQOFfset>, <IQIMbalance>, <SRATe>, <CHANnel>, <SFACtor>, <TOFFset>, <POFFset>, <CDPRelative>, <CDPabsolute>, <EVMRms>, <EVMPeak>

Value | Description | Range / Unit
<PCG> | Number of the PCG |
<PTOTal> | Total power | {-∞...∞} dBm
<PPICh> | Pilot power | {-∞...∞} dBm
<RHO> | RHO | {0...1}
<MACCuracy> | Composite EVM | %
<PCDerror> | Peak Code Domain Error | dB
<ACTive> | Number of active channels |
<FERRor> | Frequency error | Hz
<FERPpm> | Frequency error | ppm
<TFRame> | Trigger to Frame | Returns a '9' if the trigger is set to Free Run
<CERRor> | Chip rate error | ppm
<IQOFfset> | IQ offset | %
<IQIMbalance> | IQ imbalance | %
<SRATe> | Symbol rate | ksps
<CHANnel> | Channel number |
<SFACtor> | Spreading factor of the channel |
<TOFFset> | Timing offset | returns a '9' if the timing/phase offset measurement is switched off or the number of active channel exceeds 50 unit: s
<POFFset> | Phase offset | returns a '9' if the timing/phase offset measurement is switched off or the number of active channel exceeds 50 unit: rad
<CDPRelative> | Relative (to total or pilot power) channel power | {-∞...∞} dBm
<CDPabsolute> | Absolute channel power | {-∞...∞} dB
<EVMRms> | Error vector magnitude (RMS) | %
<EVMPeak> | Error vector magnitude peak | %

Read out the modulation type with the command: CALCulate<n>:​MARKer<m>:​FUNCtion:​CDPower[:​BTS]:​RESult?


Symbol Constellation

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Symbol Constellation
Symbol Constellation

When the trace data for this evaluation is queried, the real and the imaginary branches of each symbol are transferred:

<Re0>, <Im0>, <Re1>, <Im1>, ...., <Ren>, <Imn>

The number of values depends on the number of symbols and therefore the spreading factor. With transmit diversity activated, the number of values is reduced to half.

For details see "Number of bits per symbol".


Symbol EVM

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Symbol EVM
Symbol EVM

When the trace data for this evaluation is queried. one EVM value per symbol is returned.

The number of values depends on the number of symbols and therefore the spreading factor. With transmit diversity activated, the number of values is reduced to half.

For details see "Number of bits per symbol".


Symbol Magnitude Error

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Symbol Magnitude Error
Symbol Magnitude Error

When the trace data for this evaluation is queried, the magnitude error in % of each symbol at the selected slot is transferred. The number of the symbols depends on the spreading factor of the selected channel:

NOFSymbols=10*2(8-CodeClass)


Symbol Phase Error

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Symbol Phase Error
Symbol Phase Error

When the trace data for this evaluation is queried, the phase error in degrees of each symbol at the selected slot is transferred. The number of the symbols depends on the spreading factor of the selected channel:

NOFSymbols=10*2(8-CodeClass)


Retrieving RF Results

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Retrieving RF Results
Retrieving RF Results

The following commands retrieve the results of the cdma2000 RF measurements.

Useful commands for retrieving results described elsewhere:
  • CALCulate<n>:​MARKer<m>:​Y?
Remote commands exclusive to retrieving RF results:
List of Commands
CALCulate:LIMit<k>:FAIL?
CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?
CALCulate:STATistics:RESult<t>?


CALCulate:LIMit<k>:FAIL?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Retrieving RF Results > CALCulate:LIMit<k>:FAIL?
CALCulate:LIMit<k>:FAIL?

This command queries the result of a limit check.

Note that for SEM measurements, the limit line suffix <k> is irrelevant, as only one specific SEM limit line is checked for the currently relevant power class.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result>
0

PASS

1

FAIL

Example: INIT;*WAI

Starts a new sweep and waits for its end.

CALC:LIM3:FAIL?

Queries the result of the check for limit line 3.

Example:

See "Example: SEM Measurement" .

Usage: Query only
SCPI confirmed
Manual operation: See "Spectrum Emission Mask"


CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Retrieving RF Results > CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?
CALCulate:MARKer:FUNCtion:POWer<sb>:RESult? <Measurement>

This command queries the results of power measurements.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement; for all other measurements: irrelevant

Query parameters:
<Measurement>
ACPower | MCACpower

ACLR measurements (also known as adjacent channel power or multicarrier adjacent channel measurements).

Returns the power for every active transmission and adjacent channel. The order is:

• power of the transmission channels

• power of adjacent channel (lower,upper)

• power of alternate channels (lower,upper)

MSR ACLR results:

For MSR ACLR measurements, the order of the returned results is slightly different:

• power of the transmission channels

• total power of the transmission channels for each sub block

• power of adjacent channels (lower, upper)

• power of alternate channels (lower, upper)

• power of gap channels (lower1, upper1, lower2, upper2)

The unit of the return values depends on the scaling of the y-axis:

• logarithmic scaling returns the power in the current unit

• linear scaling returns the power in W

CN

Carrier-to-noise measurements.

Returns the C/N ratio in dB.

CN0

Carrier-to-noise measurements.

Returns the C/N ratio referenced to a 1 Hz bandwidth in dBm/Hz.

CPOWer

Channel power measurements.

Returns the channel power. The unit of the return values depends on the scaling of the y-axis:

• logarithmic scaling returns the power in the current unit

• linear scaling returns the power in W

For SEM measurements, the return value is the channel power of the reference range (in the specified sub block).

PPOWer

Peak power measurements.

Returns the peak power. The unit of the return values depends on the scaling of the y-axis:

• logarithmic scaling returns the power in the current unit

• linear scaling returns the power in W

For SEM measurements, the return value is the peak power of the reference range (in the specified sub block).

OBANdwidth | OBWidth

Occupied bandwidth.

Returns the occupied bandwidth in Hz.

Example:

See "Example: Configuring and Performing an ACLR Measurement" .

Example:

See "Example: Configuring and Performing an MSR ACLR Measurement" .

Example:

See "Programming example" .

Example:

See "Programming Example: OBW Measurement" .

Example:

See "Programming Examples (-K73)" .

Example:

See "Programming Examples ( BTS)"

Usage: Query only
Manual operation: See "Power"
See "Channel Power ACLR"
See "Spectrum Emission Mask"
See "Occupied Bandwidth"
See "CCDF"


CALCulate:STATistics:RESult<t>?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Retrieving Results > Retrieving RF Results > CALCulate:STATistics:RESult<t>?
CALCulate:STATistics:RESult<t>? <ResultType>

This command queries the results of a CCDF or ADP measurement for a specific trace.

Parameters:
<ResultType>
MEAN

Average (=RMS) power in dBm measured during the measurement time.

PEAK

Peak power in dBm measured during the measurement time.

CFACtor

Determined crest factor (= ratio of peak power to average power) in dB.

ALL

Results of all three measurements mentioned before, separated by commas: <mean power>,<peak power>,<crest factor>

Example: CALC:STAT:RES2? ALL

Reads out the three measurement results of trace 2. Example of answer string: 5.56,19.25,13.69 i.e. mean power: 5.56 dBm, peak power 19.25 dBm, crest factor 13.69 dB

Example:

See "Programming Example: Measuring Statistics" .

Usage: Query only
Manual operation: See "CCDF"


General Analysis

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis
General Analysis

The following commands configure general result analysis settings concerning the trace and markers for CDA measurements.

For RF measurements, see "Analyzing Measurements (Basics)" .

Contents
  • Traces
  • Markers


Traces

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Traces
Traces

The trace settings determine how the measured data is analyzed and displayed on the screen. In cdma2000 applications, only one trace per window can be configured for Code Domain Analysis.

List of Commands
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]


DISPlay[:WINDow<n>]:TRACe<t>:MODE

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE <Mode>

This command selects the trace mode.

In case of max hold, min hold or average trace mode, you can set the number of single measurements with [SENSe:​]SWEep:​COUNt. Note that synchronization to the end of the measurement is possible only in single sweep mode.

For more information see "Analyzing Several Traces - Trace Mode" .

Parameters:
<Mode>
WRITe

Overwrite mode: the trace is overwritten by each sweep. This is the default setting.

AVERage

The average is formed over several sweeps. The "Sweep/Average Count" determines the number of averaging procedures.

MAXHold

The maximum value is determined over several sweeps and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is greater than the previous one.

MINHold

The minimum value is determined from several measurements and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is lower than the previous one.

VIEW

The current contents of the trace memory are frozen and displayed.

BLANk

Hides the selected trace.

*RST: Trace 1: WRITe, Trace 2-6: BLANk
Example: INIT:CONT OFF

Switching to single sweep mode.

SWE:COUN 16

Sets the number of measurements to 16.

DISP:TRAC3:MODE WRIT

Selects clear/write mode for trace 3.

INIT;*WAI

Starts the measurement and waits for the end of the measurement.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trace Mode"


DISPlay[:WINDow<n>]:TRACe<t>[:STATe]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Traces > DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:TRACe<t>[:STATe] <State>

This command turns a trace on and off.

The measurement continues in the background.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 for TRACe1, 0 for TRACe 2 to 6
Example: DISP:TRAC3 ON
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed


Markers

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers
Markers

Markers help you analyze your measurement results by determining particular values in the diagram. In cdma2000 applications, only 4 markers per window can be configured for Code Domain Analysis.

Contents
  • Individual Marker Settings
  • General Marker Settings
  • Marker Search and Positioning Settings


Individual Marker Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Individual Marker Settings
Individual Marker Settings
List of Commands
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>:X
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:Y?


CALCulate<n>:MARKer<m>:AOFF

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Individual Marker Settings > CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:AOFF

This command turns all markers off.

Example: | CALC:MARK:AOFF Switches off all markers.
Usage: | Event
Manual operation: | See "All Markers Off"


CALCulate<n>:MARKer<m>[:STATe]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Individual Marker Settings > CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>[:STATe] <State>

This command turns markers on and off. If the corresponding marker number is currently active as a deltamarker, it is turned into a normal marker.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK3 ON

Switches on marker 3.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "Marker State"
See "Marker Type"


CALCulate<n>:MARKer<m>:X

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Individual Marker Settings > CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:X <Position>

This command moves a marker to a particular coordinate on the x-axis.

If necessary, the command activates the marker.

If the marker has been used as a delta marker, the command turns it into a normal marker.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

The unit is either Hz (frequency domain) or s (time domain) or dB (statistics).

Range: The range depends on the current x-axis range.
Example: CALC:MARK2:X 1.7MHz

Positions marker 2 to frequency 1.7 MHz.

Manual operation: See "Marker Table"
See "Marker Peak List"
See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "X-value"


CALCulate<n>:DELTamarker:AOFF

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Individual Marker Settings > CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:AOFF

This command turns all delta markers off.

Example: | CALC:DELT:AOFF Turns all delta markers off.
Usage: | Event


CALCulate<n>:DELTamarker<m>[:STATe]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>[:STATe] <State>

This command turns delta markers on and off.

If necessary, the command activates the delta marker first.

No suffix at DELTamarker turns on delta marker 1.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2 ON

Turns on delta marker 2.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "Marker State"
See "Marker Type"


CALCulate<n>:DELTamarker<m>:X

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X <Position>

This command moves a delta marker to a particular coordinate on the x-axis.

If necessary, the command activates the delta marker and positions a reference marker to the peak power.

Example: | CALC:DELT:X? Outputs the absolute x-value of delta marker 1.
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / Marker 4" See "X-value"


CALCulate<n>:DELTamarker<m>:X:RELative?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:X:RELative?

This command queries the relative position of a delta marker on the x-axis.

If necessary, the command activates the delta marker first.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | CALC:DELT3:X:REL? Outputs the frequency of delta marker 3 relative to marker 1 or relative to the reference position.
Usage: | Query only
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / Marker 4"


CALCulate<n>:DELTamarker<m>:Y?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>:Y?

This command queries the relative position of a delta marker on the y-axis.

If necessary, the command activates the delta marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

The unit depends on the application of the command.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a sweep and waits for its end. CALC:DELT2 ON Switches on delta marker 2. CALC:DELT2:Y? Outputs measurement value of delta marker 2.
Usage: | Query only
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / Marker 4"


General Marker Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > General Marker Settings
General Marker Settings
List of Commands
DISPlay:MTABle


DISPlay:MTABle

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > General Marker Settings > DISPlay:MTABle
DISPlay:MTABle <DisplayMode>

This command turns the marker table on and off.

Parameters:
<DisplayMode>
ON

Turns the marker table on.

OFF

Turns the marker table off.

AUTO

Turns the marker table on if 3 or more markers are active.

*RST: AUTO
Example: DISP:MTAB ON

Activates the marker table.

Manual operation: See "Marker Table Display"


Marker Search and Positioning Settings

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings
Marker Search and Positioning Settings
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:PICH
CALCulate<n>:MARKer<m>:FUNCtion:TDPIch
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]


CALCulate<n>:MARKer<m>:FUNCtion:PICH

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:FUNCtion:PICH
CALCulate<n>:MARKer<m>:FUNCtion:PICH

This command sets the marker to channel 0.64.

Example: | CALC:MARK:FUNC:PICH Activates marker and positions it at pilot 0.64. CALC:MARK:Y? Queries value of the relative Code Domain Power of the pilot channel.
Mode: | BTS application only
Manual operation: | See "Marker To PICH"


CALCulate<n>:MARKer<m>:FUNCtion:TDPIch

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:FUNCtion:TDPIch
CALCulate<n>:MARKer<m>:FUNCtion:TDPIch

This command sets the marker to channel 16.128.

Example: | CALC:MARK:FUNC:TDPI Activates marker and positions it at TDPICH 16.128. CALC:MARK:Y? Queries value of the relative Code Domain Power of the transmit diversity pilot channel.
Mode: | BTS application only
Manual operation: | See "Marker To TDPICH"


CALCulate<n>:MARKer<m>:MAXimum:LEFT

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:LEFT

This command moves a marker to the next lower peak.

The search includes only measurement values to the left of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MAXimum:NEXT

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:NEXT

This command moves a marker to the next lower peak.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Peak"


CALCulate<n>:MARKer<m>:MAXimum:RIGHt

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum:RIGHt

This command moves a marker to the next lower peak.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

This command moves a marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:MARKer<m>:MINimum:LEFT

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:LEFT

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MINimum:NEXT

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:NEXT

This command moves a marker to the next minimum value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Minimum"


CALCulate<n>:MARKer<m>:MINimum:RIGHt

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum:RIGHt

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MINimum[:PEAK]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum[:PEAK]

This command moves a marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

This command moves a delta marker to the next higher value.

The search includes only measurement values to the left of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

This command moves a marker to the next higher value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

This command moves a delta marker to the next higher value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

This command moves a delta marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:DELTamarker<m>:MINimum:LEFT

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:LEFT

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MINimum:NEXT

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT

This command moves a marker to the next higher minimum value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Minimum"


CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > General Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

This command moves a delta marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


Configuring the Application Data Range (MSRA mode only)

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Application Data Range (MSRA mode only)
Configuring the Application Data Range (MSRA mode only)

In MSRA operating mode, only the MSRA Master actually captures data; the MSRA applications define an extract of the captured data for analysis, referred to as the application data.

For the CDMA2000 BTS application, the application data range is defined by the same commands used to define the signal capture in Signal and Spectrum Analyzer mode (see [SENSe:​]CDPower:​SET:​COUNt). Be sure to select the correct measurement channel before executing this command.

In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the application data for the 3GPP FDD BTS measurement.

The analysis interval used by the individual result displays cannot be edited, but is determined automatically. However, you can query the currently used analysis interval for a specific window.

The analysis line is displayed by default but can be hidden or re-positioned.

Remote commands exclusive to MSRA applications

The following commands are only available for MSRA application channels:

List of Commands
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
INITiate:REFResh
[SENSe:]MSRA:CAPTure:OFFSet


CALCulate:MSRA:ALINe:SHOW

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Application Data Range (MSRA mode only) > CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe:SHOW

This command defines whether or not the analysis line is displayed in all time-based windows in all MSRA applications and the MSRA Master.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Parameters:
<State>
ON | OFF
*RST: ON


CALCulate:MSRA:ALINe[:VALue]

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Application Data Range (MSRA mode only) > CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:ALINe[:VALue] <Position>

This command defines the position of the analysis line for all time-based windows in all MSRA applications and the MSRA Master.

Parameters:
<Position>

Position of the analysis line in seconds. The position must lie within the measurement time of the MSRA measurement.

Default unit: s


CALCulate:MSRA:WINDow<n>:IVAL?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Application Data Range (MSRA mode only) > CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:MSRA:WINDow<n>:IVAL?

This command queries the analysis interval for the window specified by the index <n>. This command is only available in application measurement channels, not the MSRA View or MSRA Master.

Return values:
<IntStart>

Start value of the analysis interval in seconds

Default unit: s
<IntStop>

Stop value of the analysis interval in seconds

Usage: Query only


INITiate:REFResh

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Application Data Range (MSRA mode only) > INITiate:REFResh
INITiate:REFResh

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only for applications in MSRA mode, not the MSRA Master.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INST:SEL 'IQ ANALYZER' Selects the IQ Analyzer channel. INIT:REFR Refreshes the display for the I/Q Analyzer channel.
Usage: | Event


[SENSe:]MSRA:CAPTure:OFFSet

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Configuring the Application Data Range (MSRA mode only) > [SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]MSRA:CAPTure:OFFSet <Offset>

This setting is only available for applications in MSRA mode, not for the MSRA Master. It has a similar effect as the trigger offset in other measurements.

Parameters:
<Offset>

This parameter defines the time offset between the capture buffer start and the start of the extracted application data. The offset must be a positive value, as the application can only analyze data that is contained in the capture buffer.

Range: | 0 to <Record length>
*RST: | 0
Manual operation: See "Capture Offset"


Querying the Status Registers

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Querying the Status Registers
Querying the Status Registers

The following commands query the status registers specific to the CDMA2000 applications. In addition, the CDMA2000 applications also use the standard status registers of the R&S FSW.

For details and a description of the common R&S FSW status registers see "Status Reporting System" .

*RST does not influence the status registers.

The STATus:QUEStionable:DIQ register is described in "STATus:QUEStionable:DIQ Register".

The STATus:QUEStionable:SYNC register contains information on the error situation in the code domain analysis of the cdma2000 applications. The bits can be queried with commands STATus:​QUEStionable:​SYNC:​CONDition? and STATus:​QUEStionable:​SYNC[:​EVENt]?.

Status error bits in STATus:QUEStionable:SYNC register for CDMA2000 applications

Bit No

Meaning

0

This bit is not used.

1

Frame Sync failed. This bit is set when synchronization is not possible within the application. Possible reasons:

  • Incorrectly set frequency
  • Incorrectly set level
  • Incorrectly set PN Offset
  • Incorrectly set values for Swap IQ
  • Invalid signal at input

2 to 14

These bits are not used.

15

This bit is always 0.

List of Commands
STATus:QUEStionable:SYNC[:EVENt]?
STATus:QUEStionable:SYNC:CONDition?
STATus:QUEStionable:SYNC:ENABle
STATus:QUEStionable:SYNC:NTRansition
STATus:QUEStionable:SYNC:PTRansition


STATus:QUEStionable:SYNC[:EVENt]?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Querying the Status Registers > STATus:QUEStionable:SYNC[:EVENt]?
STATus:QUEStionable:SYNC[:EVENt]? <ChannelName>

This command reads out the EVENt section of the status register.

The command also deletes the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


STATus:QUEStionable:SYNC:CONDition?

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Querying the Status Registers > STATus:QUEStionable:SYNC:CONDition?
STATus:QUEStionable:SYNC:CONDition? <ChannelName>

This command reads out the CONDition section of the status register.

The command does not delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


STATus:QUEStionable:SYNC:ENABle

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Querying the Status Registers > STATus:QUEStionable:SYNC:ENABle
STATus:QUEStionable:SYNC:ENABle <BitDefinition>, <ChannelName>

This command controls the ENABle part of a register.

The ENABle part allows true conditions in the EVENt part of the status register to be reported in the summary bit. If a bit is 1 in the enable register and its associated event bit transitions to true, a positive transition will occur in the summary bit reported to the next higher level.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


STATus:QUEStionable:SYNC:NTRansition

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Querying the Status Registers > STATus:QUEStionable:SYNC:NTRansition
STATus:QUEStionable:SYNC:NTRansition <BitDefinition>,<ChannelName>

This command controls the Negative TRansition part of a register.

Setting a bit causes a 1 to 0 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


STATus:QUEStionable:SYNC:PTRansition

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Querying the Status Registers > STATus:QUEStionable:SYNC:PTRansition
STATus:QUEStionable:SYNC:PTRansition <BitDefinition>,<ChannelName>

These commands control the Positive TRansition part of a register.

Setting a bit causes a 0 to 1 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


Commands for Compatibility

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Commands for Compatibility
Commands for Compatibility

The following commands are provided for compatibility to other signal analyzers only. For new remote commands programs use the specified alternative commands.

List of Commands
CALCulate<n>:FEED
[SENSe:]CDPower:LEVel:ADJust
[SENSe:]CDPower:PRESet


CALCulate<n>:FEED

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Commands for Compatibility > CALCulate<n>:FEED
CALCulate<n>:FEED <Evaluation>

This command selects the evaluation method of the measured data that is to be displayed in the specified window.

Note that this command is maintained for compatibility reasons only. Use the LAYout commands for new remote control programs (see "Working with Windows in the Display").

Parameters:
<Evaluation> | Type of evaluation you want to display. See the table below for available parameter values.
Example: | CALC:FEED 'XPOW:CDP' Selects the Code Domain Power result display.
<Evaluation> parameter values
String Parameter | Text Parameter | Evaluation
'XTIM:CDP:BSTReam' | BITStream | Bitstream
'XTIM:CDP:COMP:CONStellation' | CCONst | Composite Constellation
'XPOW:CDEPower' | CDEPower | Code Domain Error Power
'XTIM:CDP:COMP:EVM' | CDEVm | Composite EVM
'XPOW:CDP:RATio' | CDPower | Code Domain Power
'XTIM:CDP:MACCuracy' | CEVM | Composite EVM
'XTIM:CDP:ERR:CTABle' | CTABle | Channel Table
'XTIM:CDP:ERR:PCDomain' | PCDerror | Peak Code Domain Error
'XTIM:CDP:PVSYmbol' | PSYMbol | Power vs Symbol
'XTIM:CDP:ERR:SUMMary' | RSUMmary | Result Summary
‘XPOW:CDP:RATio' | SCONst | Symbol Constellation
'XTIM:CDP:SYMB:EVM' | SEVM | Symbol EVM


[SENSe:]CDPower:LEVel:ADJust

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Commands for Compatibility > [SENSe:]CDPower:LEVel:ADJust
[SENSe:]CDPower:LEVel:ADJust

This command adjusts the reference level to the measured channel power. This ensures that the settings of the RF attenuation and the reference level are optimally adjusted to the signal level without overloading the R&S FSW or limiting the dynamic range by an S/N ratio that is too small.

Note that this command is retained for compatibility reasons only. For new R&S FSW programs use [SENSe:​]ADJust:​LEVel.


[SENSe:]CDPower:PRESet

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Commands for Compatibility > [SENSe:]CDPower:PRESet
[SENSe:]CDPower:PRESet

This command resets the CDMA2000 channel to its predefined settings. Any RF measurement is aborted and the measurement type is reset to Code Domain Analysis.

Note that this command is retained for comaptibility reasons only. For new remote control programs use the SYSTem:​PRESet:​CHANnel[:​EXECute] command.

Usage: Event


Programming Examples for CDMA2000 BTS Measurements

cdma2000 Measurements (R&S FSW-K82/-K83) > Remote Commands for CDMA2000 Measurements > Programming Examples for CDMA2000 BTS Measurements
Programming Examples for CDMA2000 BTS Measurements

The following programming example demonstrates how to perform Code Domain Analysis on a CDMA2000 signal in a remote environment. It assumes the network has been set up for remote control.

Note that some commands may not be necessary as they reflect the default instrument settings; however, they are included to demonstrate their use.

//--------------Preparing the instrument -----------
//Reset the instrument
*RST
//Activate a CDMA2000 BTS measurement channel named "BTSMeasurement"
INST:CRE:NEW BC2K,'BTSMeasurement'
//Select the code domain analysis measurement
CONF:CDP:BTS:MEAS CDP
//Stop continuous sweep
INIT:CONT OFF

//---------------- Configuring the Measurement-----
//Set the reference level to 0 dBm
DISP:TRAC:Y:SCAL:RLEV 0
//Set the center frequency to 878.49 MHz
FREQ:CENT 878.49 MHz

//---------- Trigger settings --------------------
// Use these settings only if an external trigger is connected
// to the TRIGGER INPUT connector on the front panel of the analyzer.
// Otherwise ignore these commands.
// Define the use of an external trigger.
TRIGger:SOURce EXT

//------------ Signal Description -------------------
//IF KNOWN, define the pseudo noise offset of the base station from the external
//trigger of 2 (*64 chips) to accelerate calculation
//SENS:CDP:PNOF 2

//Capture data only from signal at antenna 1.
SENS:CDP:ANT 1
//Switch to multi-carrier signal detection and disable enhanced signal detection
//algorithm to accelerate calculation
CONF:CDP:BTS:MCAR ON
CONF:CDP:BTS:MCAR:MALG OFF
//Activate multicarrier RRC filter with rolloff 0.02 and cutoff at 1.25 MHz
CONF:CDP:BTS:MCAR:FILT ON
CONF:CDP:BTS:MCAR:FILT:TYPE RRC
CONF:CDP:BTS:MCAR:FILT:ROFF 0.02
CONF:CDP:BTS:MCAR:FILT:COFR 1.25MHZ

//----------- Channel detection --------------------------
//Configure an inactive threshold of -60.0 dB
SENS:CDP:ICTR -60

//---------- Configuring the result display ------------
// Activate the following result displays:
// 1: Code Domain Power (default, upper left)
// 2: Result Summary (default, below CDP)
// 3: Code Domain Error Power (next to CDP)
// 4: Bitstream Table (next to Result Summary)
LAYout:ADD:WINDow? '1',RIGH,PCD
LAYout:ADD:WINDow? '2',RIGH,BITS

//----------- Code domain settings ---------------------------
//Use a base spreading factor of 128
SENS:CDP:SFAC 128
//Configure compensation for I/Q offset
SENS:CDP:NORM ON
//Calculate timing and phase offset
SENS:CDP:TPM ON
//Define relative code power results, referred to total power of the signal
SENS:CDP:PDIS REL
SENS:CDP:PREF TOT
//Use bit-reverse sort order for code display
SENS:CDP:ORD BITR

//------------- Data acquisition -------------------------
//Configure data capture for 3 PCGs, analyze set 0, code number 3
SENS:CDP:IQL 3
SENS:CDP:SET 0
SENS:CDP:CODE 3

//--------------Performing the Measurement-----
//Select single sweep mode.
INIT:CONT OFF
//Initiate a new measurement and waits until the sweep has finished.
INIT;*WAI

//---------------Retrieving Results-------------
//Retrieve the composite EVM
CALC:MARK:FUNC:CDP:BTS:RES? MACC
//Retrieve the channel power, relative to total power
CALC:MARK:FUNC:CDP:BTS:RES? CDPR
//Retrieve the total power
CALC:MARK:FUNC:CDP:BTS:RES? PTOT
//Retrieve the peak error vector magnitude in percent
CALC:MARK:FUNC:CDP:BTS:RES? EVMP
//Retrieve the trace data of the Code Domain Error Power display
TRAC3:DATA? TRACE1


Annex - Reference Data

cdma2000 Measurements (R&S FSW-K82/-K83) > Annex - Reference Data
Annex - Reference Data
Contents
  • Reference: Predefined Channel Tables
  • Reference: Code Tables
  • Reference: Supported Bandclasses
  • Abbreviations


Reference: Predefined Channel Tables

cdma2000 Measurements (R&S FSW-K82/-K83) > Annex - Reference Data > Reference: Predefined Channel Tables
Reference: Predefined Channel Tables

Predefined channel tables provide quick configuration for the channel search in commonly used measurement scenarios in accordance with the cdma2000 specification.

To use channels other than those in the predefined channel tables, you can copy the original tables and modify the channels in the copy.

Contents
  • BTS Channel Tables
  • MS Channel Tables


BTS Channel Tables

cdma2000 Measurements (R&S FSW-K82/-K83) > Annex - Reference Data > Reference: Predefined Channel Tables > BTS Channel Tables
BTS Channel Tables

The cdma2000 BTS Analysis application provides the following set of channel tables compliant with the cdma2000 specification:

The standard does not specify a channel number for the data channels.

Channel table | Contents
RECENT | Contains the most recently selected channel table
MPC_RC1 | Base Station Main Path 6 Channels Radio Configuration 1 Channel table with F-PICH/F-SYNC/F-PCH and 6 data channels.
MPC_RC4 | Base Station Main Path 6 Channels Radio Configuration 4 Channel table with F-PICH/F-SYNC/F-PCH and 6 data channels.
TDC_RC4 | Base Station Transmit Diversity Path 6 Channels Radio Configuration 4 Channel table with F-PICH/F-SYNC/F-PCH and 6 data channels.
BPC_RC4 | Base Station Both Paths 6 Channels Radio Configuration 4 Channel table with F-PICH/F-TDPICH/F-SYNC/F-PCH and 6 data channels
Base station channel table for main branch in radio configuration 1 (MPC_RC1)
Channel Type | Number of Channels | Code Channel (Walsh Code.SF) | Radio Configuration
F-PICH | 1 | 0.64 | -
F-SYNC | 1 | 32.64 | -
F-PCH | 1 | 1.64 | -
F-CHAN | 6 | 9.64 10.64 11.64 15.64 17.64 25.64 | 1 1 1 1 1 1
Base station channel table for main branch in radio configuration 4 (MPC_RC4)
Channel Type | Number of Channels | Code Channel (Walsh Code.SF) | Radio Configuration
F-PICH | 1 | 0.64 | -
F-SYNC | 1 | 32.64 | -
F-PCH | 1 | 1.64 | -
F-CHAN | 6 | 9.128 10.128 11.128 15.128 17.128 25.128 | 4 4 4 4 4 4
Base station test model for aggregate signal in radio configuration 4 (TDC_RC4)
Channel Type | Number of Channels | Code Channel (Walsh Code.SF) | Radio Configuration
F-PICH | 1 | 16.128 | -
F-SYNC | 1 | 32.64 | -
F-PCH | 1 | 1.64 | -
F-CHAN | 6 | 9.128 10.128 11.128 15.128 17.128 25.128 | 4 4 4 4 4 4
Base station test model for aggregate signal in radio configuration 4 (BPC_RC4)
Channel Type | Number of Channels | Code Channel (Walsh Code.SF) | Radio Configuration
F-PICH | 1 | 0.64 | -
TDPICH | 1 | 16.128 | -
F-SYNC | 1 | 32.64 | -
F-PCH | 1 | 1.64 | -
F-CHAN | 6 | 9.128 10.128 11.128 15.128 17.128 25.128 | 4 4 4 4 4 4


MS Channel Tables

cdma2000 Measurements (R&S FSW-K82/-K83) > Annex - Reference Data > Reference: Predefined Channel Tables > MS Channel Tables
MS Channel Tables

The cdma2000 MS application provides the following set of channel tables compliant with the cdma2000 specification:

Channel table

Contents

RECENT

Contains the channels that were automatically created during the last measurement with the "Auto Search" option activated (for details refer to "Using Predefined Channel Tables").

EACHOP

Channel table for Enhanced Access CHannel OPeration with PICH and EACH

RCCCHOP

Channel table for Reverse Common Control CHannel OPeration with PICH and CCCH

RTCHOP3

Channel table for Reverse Traffic CHannel OPeration with the following 3 channels:

  • PICH
  • DCCH
  • FCH

RTCHOP5

Channel table for Reverse Traffic CHannel OPeration with the following 5 channels:

  • PICH
  • DCCH
  • FCH
  • S1CH
  • S2CH
Channel table for enhanced access channel operation
Channel type | Code channel (Walsh Code.SF) | Mapping
PICH | 0.32 | I
EACH | 2.8 | Q
Channel table for reverse commom control channel operation
Channel type | Code channel (Walsh Code.SF) | Mapping
PICH | 0.32 | I
CCCH | 2.8 | Q
Channel table for REVERSE TRAFFIC CHANNEL OPERATION 3
Channel type | Code channel (Walsh Code.SF) | Mapping
PICH | 0.32 | I
FCH | 4.16 | Q
S1CH | 2.4 | Q
Channel table for REVERSE TRAFFIC CHANNEL OPERATION 5
Channel type | Code channel (Walsh Code.SF) | Mapping
PICH | 0.32 | I
DCCH | 8.16 | I
FCH | 4.16 | Q
S1CH | 2.4 | Q
S2CH | 6.8 | I


Reference: Code Tables

cdma2000 Measurements (R&S FSW-K82/-K83) > Annex - Reference Data > Reference: Code Tables
Reference: Code Tables
Hadamard and BitReverse Code Tables

The following tables show the code sequences with Hadamard and BitReverse orders for the Code Domain Power and Code Domain Error Power result displays.

As an example, the corresponding cells for channel 8.32 (channel number 8 for spreading factor 32) are marked to show where the different codes of this channel are located.

Codetable for base spreading factor 64
Code table for base spreading factor 128 (part1)
Code table for base spreading factor 128 (part 2)


Reference: Supported Bandclasses

cdma2000 Measurements (R&S FSW-K82/-K83) > Annex - Reference Data > Reference: Supported Bandclasses
Reference: Supported Bandclasses

The bandclass defines the frequency band used for ACLR and SEM measurements. It also determines the corresponding limits and ACLR channel settings according to the CDMA2000 standard. The used bandclass is defined in the SEM or ACLR measurement settings (see "Bandclass").

Supported bandclasses for CDMA2000 RF measurements
Bandclass | SCPI para | Description
0 | 0 | 800 MHz Cellular Band
1 | 1 | 1.9 GHz PCS Band
2 | 2 | TACS Band
3A | 3 | JTACS Band: >832 MHz and ≤ 834 MHz >838 MHz and ≤ 846 MHz >860 MHz and ≤ 895 MHz
3B | 21 | JTACS Band: >810 MHz and ≤ 860 MHz except: >832 MHz and ≤ 834 MHz >838 MHz and ≤ 846 MHz
3C | 22 | JTACS Band: ≤810 MHz and >895 MHz
4 | 4 | Korean PCS Band
5 | 5 | 450 MHz NMT Band
6 | 6 | 2 GHz IMT-2000 Band
7 | 7 | 700 MHz Band
8 | 8 | 1800 MHz Band
9 | 9 | 900 MHz Band
10 | 10 | Secondary 800 MHz
11 | 11 | 400 MHz European PAMR Band
12 | 12 | 800 MHz PAMR Band
13 | 13 | 2.5 GHz IMT-2000 Extension Band
14 | 14 | US PCS 1.9 GHz Band
15 | 15 | AWS Band
16 | 16 | US 2.5 GHz Band
17 | 17 | US 2.5 GHz Forward Link Only Band


Abbreviations

cdma2000 Measurements (R&S FSW-K82/-K83) > Annex - Reference Data > Abbreviations
Abbreviations

For a comprehensive glossary refer to the cdma2000 standard.

APICH | auxiliary pilot channel
ATDPCH | auxiliary transmit diversity pilot channel
BCH | broadcast channel
CACH | common assignment channel
CCCH | common control channel (2.8)
CDEP | code domain error power
CDP | code domain power
Composite EVM | in accordance with the cdma2000 specifications, determines the square root of the squared error between the real and the imaginary parts of the test signal and an ideally generated reference signal (EVM referred to the total signal) in a composite EVM measurement.
CPCCH | common power control channel
Crest factor | ratio of peak to average value of the signal
EACH | Enhanced access channel 2.8
FCH | Fundamental channel 4.16
Inactive Channel Threshold | minimum power that a single channel must have compared with the total signal to be recognized as an active channel.
MC1 | multi-carrier1 (one carrier system 1X).
MC2 | multi-carrier3 (three carrier system 3X).
OTD | orthogonal transmit diversity, two antennas used
PCG | power control group: name in cdma2000 system for 1536 chips or 1.25 ms interval; transmitter power is constant during a power control group
PCH | paging channel
PDCH | packet data channel
PDCCH | packet data control channel
PICH | pilot channel 0.64 (MS: 0.32)
RC | radio configuration; definition of sampling rate, permissible data rates, modulation types and use of special channels, and transmit diversity
S1CH | Supplemental 1 channel 1.2 or 2.4 (in higher layers this channel is also referred to as supplemental channel 0 – SCH0).
S2CH | Supplemental 2 channel 2.4 or 6.8 (in higher layers this channel is also referred to as supplemental channel 1 – SCH1).
SCH0 | Refer to S1CH
SCH1 | Refer to S2CH
Set | a group of 64 consecutive PCGs
SF | spreading factor
SYNC | synchronisation channel 32.64
TD | transmit diversity, two antennas used
TDPICH | transmit diversity pilot channel 16.128
x.y | Walsh code x.y, with code number x and spreading factor y of the channel


List of Remote Commands (CDMA2000)

cdma2000 Measurements (R&S FSW-K82/-K83) > List of Remote Commands (CDMA2000)
List of Remote Commands (CDMA2000)
[SENSe:]ADJust:ALL
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:LEVel
[SENSe:]AVERage:COUNt
[SENSe:]CDPower:ANTenna
[SENSe:]CDPower:CODE
[SENSe:]CDPower:ICTReshold
[SENSe:]CDPower:IQLength
[SENSe:]CDPower:LCODe:MASK
[SENSe:]CDPower:LCODe:MODE
[SENSe:]CDPower:LCODe:OFFSet
[SENSe:]CDPower:LEVel:ADJust
[SENSe:]CDPower:MAPPing
[SENSe:]CDPower:NORMalize
[SENSe:]CDPower:ORDer
[SENSe:]CDPower:PDISplay
[SENSe:]CDPower:PNOFfset
[SENSe:]CDPower:PPReference
[SENSe:]CDPower:PREFerence
[SENSe:]CDPower:PRESet
[SENSe:]CDPower:QINVert
[SENSe:]CDPower:SET
[SENSe:]CDPower:SET:COUNt
[SENSe:]CDPower:SFACtor
[SENSe:]CDPower:SLOT
[SENSe:]CDPower:TPMeas
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:LINK
[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor
[SENSe:]FREQuency:OFFSet
[SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:TYPE?
[SENSe:]SWEep:COUNt
ABORt
CALCulate:LIMit<k>:FAIL?
CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:STATistics:RESult<t>?
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:FEED
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:FUNCtion:CDPower[:BTS]:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:PICH
CALCulate<n>:MARKer<m>:FUNCtion:TDPIch
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:UNIT:POWer
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
CONFigure:CDPower[:BTS]:BCLass|BANDclass
CONFigure:CDPower[:BTS]:CTABle:CATalog?
CONFigure:CDPower[:BTS]:CTABle:COMMent
CONFigure:CDPower[:BTS]:CTABle:COPY
CONFigure:CDPower[:BTS]:CTABle:DATA
CONFigure:CDPower[:BTS]:CTABle:DATA
CONFigure:CDPower[:BTS]:CTABle:DELete
CONFigure:CDPower[:BTS]:CTABle:NAME
CONFigure:CDPower[:BTS]:CTABle:RESTore
CONFigure:CDPower[:BTS]:CTABle:SELect
CONFigure:CDPower[:BTS]:CTABle[:STATe]
CONFigure:CDPower[:BTS]:MCARrier:FILTer:COFRequency
CONFigure:CDPower[:BTS]:MCARrier:FILTer:ROFF
CONFigure:CDPower[:BTS]:MCARrier:FILTer:TYPE
CONFigure:CDPower[:BTS]:MCARrier:FILTer[:STATe]
CONFigure:CDPower[:BTS]:MCARrier:MALGo
CONFigure:CDPower[:BTS]:MCARrier[:STATe]
CONFigure:CDPower[:BTS]:MEASurement
DIAGnostic:SERVice:NSOurce
DISPlay:FORMat
DISPlay:MTABle
DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe
FORMat[:DATA]
INITiate:CONMeas
INITiate:CONTinuous
INITiate:REFResh
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SEQuencer:REFResh[:ALL]
INITiate[:IMMediate]
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:ATTenuation:PROTection:RESet
INPut:CONNector
INPut:COUPling
INPut:DIQ:CDEVice
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:GAIN:STATe
INPut:GAIN[:VALue]
INPut:IMPedance
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
INPut:SELect
INSTrument:CREate:DUPLicate
INSTrument:CREate:REPLace
INSTrument:CREate[:NEW]
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace
OUTPut:DIQ
OUTPut:DIQ:CDEVice
OUTPut:IF:IFFRequency
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth
STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:DIQ:ENABle
STATus:QUEStionable:DIQ:NTRansition
STATus:QUEStionable:DIQ:PTRansition
STATus:QUEStionable:DIQ[:EVENt]?
STATus:QUEStionable:SYNC:CONDition?
STATus:QUEStionable:SYNC:ENABle
STATus:QUEStionable:SYNC:NTRansition
STATus:QUEStionable:SYNC:PTRansition
STATus:QUEStionable:SYNC[:EVENt]?
SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:SEQuencer
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon[:STATe]
TRACe<n>[:DATA]?
TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel:VIDeo
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:TIME:RINTerval


Legal Notice

R&S®FSW-K82/-K83
CDMA2000® Measurements

© 2014 Rohde & Schwarz GmbH & Co. KG

Mühldorfstr. 15, 81671 München, Germany

Phone: +49 89 41 29 - 0

Fax: +49 89 41 29 12 164

E-mail: info@rohde-schwarz.com

Internet: www.rohde-schwarz.com

Subject to change – Data without tolerance limits is not binding.

R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.

CDMA2000® is a registered trademark of the Telecommunications Industry Association (TIA -USA).

Trade names are trademarks of the owners.